Port vncrepeater to -ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4560 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-11 16:46:04 +00:00
parent ce998a3c88
commit 7a98537bef
2 changed files with 91 additions and 0 deletions

59
net/vncrepeater/Makefile Normal file
View File

@ -0,0 +1,59 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=vncrepeater
PKG_VERSION:=0.12
PKG_RELEASE:=1
PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/vncrepeater
SECTION:=net
CATEGORY:=Network
DEPENDS:=+uclibcxx
TITLE:=UltraVNC repeater for Linux
DESCRIPTION:=Viewer can be behind Nat router or directly connected to the internet\\\
Instead of forwarding serveral ports, you only need to forward 1 port\\\
If the PC that runs the Repeater has access to the local DNS server,\\\
you can use your local DNS names instead of 10.10.10.12.\\\
This could be handy when you have a dynamic DHCP server allocating\\\
ip adresses for your PC.\\\
URL:=http://ultravnc.sourceforge.net/addons/repeater.html
endef
define Package/vncrepeater/
/etc/vncrepeater.conf
endef
define Build/Compile
$(call Build/Compile/Default,CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
repeater)
endef
define Package/vncrepeater/install
install -d -m0755 $(1)/usr/sbin $(1)/etc
$(CP) $(PKG_BUILD_DIR)/repeater $(1)/usr/sbin/$(PKG_NAME)
install -d -m0755 $(1)/etc
$(CP) $(PKG_BUILD_DIR)/uvncrepeater.ini $(1)/etc/vncrepeater.conf
install -d -m0755 $(1)/etc/init.d
$(CP) $(PKG_BUILD_DIR)/S60vncrepeater $(1)/etc/init.d/
endef
$(eval $(call BuildPackage,vncrepeater))

View File

@ -0,0 +1,32 @@
diff -urN vncrepeater-0.12/Makefile vncrepeater-0.12.new/Makefile
--- vncrepeater-0.12/Makefile 2006-03-31 07:40:14.000000000 +0200
+++ vncrepeater-0.12.new/Makefile 2006-04-11 10:26:06.345879104 +0200
@@ -1,21 +1,21 @@
-CFLAGS=-Wall
+CFLAGS=-Wall
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
repeater.o: repeater.cpp
- g++ $(CFLAGS) -c repeater.cpp
+ $(CC) $(CFLAGS) -c repeater.cpp
repeaterproc.o: repeaterproc.cpp
- g++ $(CFLAGS) -c repeaterproc.cpp
+ $(CC) $(CFLAGS) -c repeaterproc.cpp
openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
+ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
iniparser.o: iniparser.cpp
- g++ $(CFLAGS) -c iniparser.cpp
+ $(CC) $(CFLAGS) -c iniparser.cpp
readini.o: readini.cpp
- g++ $(CFLAGS) -c readini.cpp
+ $(CC) $(CFLAGS) -c readini.cpp
clean:
rm -f *.o repeater