[package] update mjpg-streamer to revision 74 (#4347)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14443 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-02-08 13:48:04 +00:00
parent f5b97f21e5
commit 7afafcd592
2 changed files with 14 additions and 15 deletions

View File

@ -9,9 +9,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=mjpg-streamer PKG_NAME:=mjpg-streamer
PKG_REV:=68 PKG_REV:=74
PKG_VERSION:=r$(PKG_REV) PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/ PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/
@ -39,7 +39,7 @@ define Package/mjpg-streamer/install
$(INSTALL_DIR) $(1)/sbin $(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/sbin $(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/sbin
$(INSTALL_DIR) $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(foreach input_plugin,uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib $(CP) $(foreach input_plugin,file uvc gspcav1,$(PKG_BUILD_DIR)/input_$(input_plugin).so) $(1)/usr/lib
$(CP) $(foreach output_plugin,http file autofocus,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib $(CP) $(foreach output_plugin,http file autofocus,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib
$(INSTALL_DIR) $(1)/webcam_www $(INSTALL_DIR) $(1)/webcam_www
$(CP) $(PKG_BUILD_DIR)/www/* $(1)/webcam_www $(CP) $(PKG_BUILD_DIR)/www/* $(1)/webcam_www

View File

@ -1,12 +1,11 @@
diff -urN mjpg-streamer-r68/Makefile mjpg-streamer-r68.new/Makefile diff -urN mjpg-streamer-r74/Makefile mjpg-streamer-r74.new/Makefile
--- mjpg-streamer-r68/Makefile 2008-09-27 16:26:56.000000000 +0200 --- mjpg-streamer-r74/Makefile 2009-02-08 14:51:37.000000000 +0100
+++ mjpg-streamer-r68.new/Makefile 2009-01-18 16:11:32.000000000 +0100 +++ mjpg-streamer-r74.new/Makefile 2009-02-08 14:52:48.000000000 +0100
@@ -28,7 +28,7 @@ @@ -31,7 +31,6 @@
APP_BINARY = mjpg_streamer PLUGINS = input_uvc.so
PLUGINS += output_file.so
# define the names and targets of the plugins PLUGINS += output_http.so
-PLUGINS = input_uvc.so output_file.so output_http.so input_testpicture.so output_autofocus.so input_gspcav1.so -PLUGINS += input_testpicture.so
+PLUGINS = input_uvc.so output_file.so output_http.so output_autofocus.so input_gspcav1.so PLUGINS += output_autofocus.so
PLUGINS += input_gspcav1.so
# define the names of object files PLUGINS += input_file.so
OBJECTS=mjpg_streamer.o utils.o