fix segfault and set right dependency
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8326 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1969270eb8
commit
7d1f96e49f
@ -43,14 +43,14 @@ endef
|
||||
|
||||
define Package/olsrd-mod-bmf
|
||||
$(call Package/olsrd)
|
||||
DEPENDS:=olsrd libpthread kmod-tun
|
||||
DEPENDS:=olsrd +libpthread +kmod-tun
|
||||
TITLE:=Basic multicast forwarding plugin
|
||||
MENU:=0
|
||||
endef
|
||||
|
||||
define Package/olsrd-mod-dyn-gw
|
||||
$(call Package/olsrd)
|
||||
DEPENDS:=olsrd
|
||||
DEPENDS:=olsrd +libpthread
|
||||
TITLE:=Dynamic internet gateway plugin
|
||||
MENU:=0
|
||||
endef
|
||||
|
22
net/olsrd/patches/110-cflags.patch
Normal file
22
net/olsrd/patches/110-cflags.patch
Normal file
@ -0,0 +1,22 @@
|
||||
Index: olsrd-0.5.2/Makefile.inc
|
||||
===================================================================
|
||||
--- olsrd-0.5.2.orig/Makefile.inc 2007-08-03 04:25:53.320043315 +0200
|
||||
+++ olsrd-0.5.2/Makefile.inc 2007-08-03 04:25:57.816299546 +0200
|
||||
@@ -62,7 +62,7 @@ LDFLAGS += -Wl,-export-dynamic
|
||||
endif
|
||||
|
||||
# options to save space on small systems
|
||||
-DEFINES += -DSUPPORT_OLD_PLUGIN_VERSIONS=1
|
||||
+CFLAGS += -DSUPPORT_OLD_PLUGIN_VERSIONS=1
|
||||
|
||||
# search sources and headers in current dir and in src/
|
||||
SRCS = $(wildcard src/*.c)
|
||||
@@ -102,7 +102,7 @@ endif
|
||||
CFLAGS += -MD
|
||||
|
||||
# we always need the includes and defines
|
||||
-CFLAGS += $(INCLUDES) $(DEFINES)
|
||||
+CFLAGS += $(INCLUDES)
|
||||
|
||||
TAGFILE ?= src/TAGS
|
||||
|
Loading…
x
Reference in New Issue
Block a user