[package] update openl2tp to 1.7 (#8141)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23752 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2bde8e6eaf
commit
7d2e2363ef
@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=openl2tp
|
||||
PKG_VERSION:=1.6
|
||||
PKG_VERSION:=1.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/openl2tp
|
||||
PKG_MD5SUM:=87f035ca5ddf7c61e720f422cdc997cf
|
||||
PKG_MD5SUM:=2fd12112cf50c67dc3c7d848beb34947
|
||||
|
||||
PKG_BUILD_DEPENDS:=libreadline libncurses
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_PPPD_VERSION:=2.4.4
|
||||
PPPD_VERSION:=2.4.4
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -52,9 +52,9 @@ define Package/openl2tp/install
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/l2tpconfig $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openl2tpd $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_PPPD_VERSION)
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pppd/openl2tp.so $(1)/usr/lib/pppd/$(PKG_PPPD_VERSION)/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pppd/pppol2tp.so $(1)/usr/lib/pppd/$(PKG_PPPD_VERSION)/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PPPD_VERSION)
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pppd/openl2tp.so $(1)/usr/lib/pppd/$(PPPD_VERSION)/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pppd/pppol2tp.so $(1)/usr/lib/pppd/$(PPPD_VERSION)/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/openl2tp
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/plugins/event_sock.so $(1)/usr/lib/openl2tp/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/plugins/ipsec.so $(1)/usr/lib/openl2tp/
|
||||
|
@ -1,12 +1,6 @@
|
||||
---
|
||||
Makefile | 26 +++++++++++++-------------
|
||||
cli/Makefile | 2 +-
|
||||
usl/Makefile | 2 +-
|
||||
3 files changed, 15 insertions(+), 15 deletions(-)
|
||||
|
||||
--- openl2tp-1.6.orig/Makefile
|
||||
+++ openl2tp-1.6/Makefile
|
||||
@@ -8,7 +8,7 @@ L2TP_FEATURE_LAIC_SUPPORT= y
|
||||
--- orig/Makefile 2010-03-18 14:04:47.000000000 +0500
|
||||
+++ new/Makefile 2010-10-28 07:30:10.673418106 +0600
|
||||
@@ -8,7 +8,7 @@
|
||||
L2TP_FEATURE_LAOC_SUPPORT= y
|
||||
L2TP_FEATURE_LNIC_SUPPORT= y
|
||||
L2TP_FEATURE_LNOC_SUPPORT= y
|
||||
@ -15,7 +9,7 @@
|
||||
#L2TP_FEATURE_LOCAL_STAT_FILE= y
|
||||
|
||||
# Define USE_DMALLOC to enable dmalloc memory debugging
|
||||
@@ -29,31 +29,31 @@ L2TP_USE_ASYNC_RPC= y
|
||||
@@ -29,31 +29,31 @@
|
||||
# Build for UML environment?
|
||||
# UML_TARGET= y
|
||||
|
||||
@ -40,10 +34,10 @@
|
||||
# Points to pppd install.
|
||||
# By default, pppd headers are assumed to be in /usr/include/pppd. but
|
||||
# can be pointed to a local pppd source tree if desired.
|
||||
-PPPD_VERSION= 2.4.4
|
||||
+#PPPD_VERSION= 2.4.4
|
||||
# PPPD_SRCDIR= /usr/local/src/ppp-2.4.4
|
||||
# PPPD_LIBDIR= /usr/lib/pppd/2.4.4
|
||||
-PPPD_VERSION= 2.4.5
|
||||
+#PPPD_VERSION= 2.4.5
|
||||
# PPPD_SRCDIR= /usr/local/src/ppp-2.4.5
|
||||
# PPPD_LIBDIR= /usr/lib/pppd/2.4.5
|
||||
|
||||
# Points to readline install root. READLINE_DIR should have lib/ & include/ subdirs
|
||||
# If not defined, readline is assumed to be installed in the standard places that
|
||||
@ -57,7 +51,7 @@
|
||||
|
||||
# END CONFIGURABLE SETTINGS
|
||||
|
||||
@@ -135,9 +135,9 @@ endif
|
||||
@@ -142,9 +142,9 @@
|
||||
|
||||
CPPFLAGS= $(CPPFLAGS.l2tptest) $(CPPFLAGS-y)
|
||||
CFLAGS= -I. -Iusl -Icli -isystem $(KERNEL_BLDDIR)/include \
|
||||
@ -69,9 +63,9 @@
|
||||
|
||||
OPT_CFLAGS?= -O
|
||||
|
||||
--- openl2tp-1.6.orig/cli/Makefile
|
||||
+++ openl2tp-1.6/cli/Makefile
|
||||
@@ -7,7 +7,7 @@ CLI_SRCS_TEST.o= $(CLI_SRCS_TEST.c:%.c=%
|
||||
--- orig/cli/Makefile 2008-02-03 19:55:30.000000000 +0500
|
||||
+++ new/cli/Makefile 2010-10-28 07:15:39.000000000 +0600
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
LDFLAGS.cli_test= -L.. -L. $(READLINE_LDFLAGS) -lcli -lusl -lreadline -lcurses -lc
|
||||
|
||||
@ -80,9 +74,9 @@
|
||||
|
||||
.PHONY: all test clean
|
||||
|
||||
--- openl2tp-1.6.orig/usl/Makefile
|
||||
+++ openl2tp-1.6/usl/Makefile
|
||||
@@ -14,7 +14,7 @@ LIBS.dmalloc= -ldmalloc
|
||||
--- orig/usl/Makefile 2008-02-24 16:52:50.000000000 +0500
|
||||
+++ new/usl/Makefile 2010-10-28 07:15:39.000000000 +0600
|
||||
@@ -14,7 +14,7 @@
|
||||
endif
|
||||
|
||||
CPPFLAGS+= $(CFLAGS.optimize) -g
|
||||
|
Loading…
x
Reference in New Issue
Block a user