[packages] lxc: update to latest git version

Signed-off-by: Luka Perkov <luka@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@38798 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2013-11-14 00:08:53 +00:00
parent d6c307c854
commit 7e3fe08e7f
4 changed files with 18 additions and 25 deletions

View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lxc
PKG_VERSION:=2013-09-24
PKG_VERSION:=2013-11-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/lxc/lxc.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=9d0cda4f22f76d693e2ceef0f77f2ba24227433c
PKG_SOURCE_VERSION:=a9a0ed90dd1cdadd412576a45af16419efc0e939
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_PARALLEL:=1
@ -23,20 +23,16 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
LXC_APPLETS += \
attach cgroup checkpoint console execute freeze info kill monitor \
restart start stop unfreeze unshare wait
attach cgroup checkpoint clone config console create destroy execute \
freeze info kill monitor monitord restart snapshot start stop unfreeze \
unshare user-nic wait
LXC_SCRIPTS += \
checkconfig clone create destroy ls netstat ps shutdown version
checkconfig ls netstat ps top version
DEPENDS_APPLETS = +libpthread +libcap +liblxc
DEPENDS_checkpoint = @BROKEN
DEPENDS_clone = @BROKEN
DEPENDS_create = @BROKEN
DEPENDS_destroy = @BROKEN
DEPENDS_restart = @BROKEN
DEPENDS_shutdown = +lxc-info +lxc-wait @BROKEN
DEPENDS_top = @BROKEN
define Package/lxc/Default

View File

@ -1,13 +1,13 @@
--- a/configure.ac
+++ b/configure.ac
@@ -11,29 +11,6 @@ AC_CANONICAL_HOST
@@ -22,29 +22,6 @@ AC_CANONICAL_HOST
AM_PROG_CC_C_O
AC_GNU_SOURCE
-# Detect the distribution. This is used for the default configuration and
-# for some distro-specific build options.
-AC_MSG_CHECKING([host distribution])
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, oracle, fedora, suse, gentoo, debian, arch, slackware, paldo, mandriva or pardus.]))
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, oracle, fedora, suse, gentoo, debian, arch, slackware, paldo, openmandriva or pardus.]))
-if test "z$with_distro" = "z"; then
- with_distro=`lsb_release -is`
-fi
@ -21,8 +21,8 @@
- AC_CHECK_FILE(/etc/arch-release,with_distro="arch")
- AC_CHECK_FILE(/etc/slackware-version,with_distro="slackware")
- AC_CHECK_FILE(/etc/frugalware-release,with_distro="frugalware")
- AC_CHECK_FILE(/etc/mandrakelinux-release, with_distro="mandriva")
- AC_CHECK_FILE(/etc/mandriva-release,with_distro="mandriva")
- AC_CHECK_FILE(/etc/mandrakelinux-release, with_distro="openmandriva")
- AC_CHECK_FILE(/etc/mandriva-release,with_distro="openmandriva")
- AC_CHECK_FILE(/etc/pardus-release,with_distro="pardus")
-fi
-with_distro=`echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]'`

View File

@ -11,15 +11,12 @@
char *newname;
--- a/src/lxc/lxc_user_nic.c
+++ b/src/lxc/lxc_user_nic.c
@@ -43,11 +43,7 @@
#include <linux/sockios.h>
@@ -49,6 +49,8 @@
#include "config.h"
#include "utils.h"
-#ifndef HAVE_GETLINE
-#ifdef HAVE_FGETLN
#include <../include/getline.h>
-#endif
-#endif
+#include <../include/getline.h>
+
#if ISTEST
#define CONF_FILE "/tmp/lxc-usernet"
#define DB_FILE "/tmp/nics"

View File

@ -1,9 +1,9 @@
--- a/src/lxc/lxc-checkconfig.in
+++ b/src/lxc/lxc-checkconfig.in
@@ -3,6 +3,17 @@
# Allow environment variables to override grep and config
@@ -4,6 +4,17 @@
: ${CONFIG:=/proc/config.gz}
: ${GREP:=zgrep}
: ${MODNAME:=configs}
+: ${ZGREP:=zgrep}
+: ${GUNZIP:=gunzip}
+