[package] rtorrent: update to 0.9.3-git
Signed-off-by: Peter Wagner <tripolar@gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/packages@37592 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e9c341f578
commit
7f01d130ba
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007-2011 OpenWrt.org
|
||||
# Copyright (C) 2007-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,15 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
PKG_VERSION:=0.8.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=0.9.3-git
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads
|
||||
PKG_MD5SUM:=b804c45c01c40312926bcea6b55bb084
|
||||
PKG_RELEASE:=$(PKG_SOURCE_VERSION)-1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=7689059dbc1ee05f855eb28883cbe59d162d4431
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
@ -28,7 +31,6 @@ define Package/rtorrent
|
||||
TITLE:=BitTorrent client for ncurses
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
DEPENDS:=+libcurl +libtorrent +libncursesw +libsigcxx +xmlrpc-c-server +libpthread
|
||||
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||
endef
|
||||
|
||||
define Package/rtorrent/description
|
||||
@ -38,7 +40,6 @@ define Package/rtorrent/description
|
||||
clients in an ncurses client.
|
||||
endef
|
||||
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing -fno-inline
|
||||
TARGET_LDFLAGS += -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
|
@ -1,22 +1,30 @@
|
||||
Index: rtorrent-0.8.6/scripts/common.m4
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6.orig/scripts/common.m4
|
||||
+++ rtorrent-0.8.6/scripts/common.m4
|
||||
@@ -184,7 +184,7 @@ AC_DEFUN([TORRENT_CHECK_MADVISE], [
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS(config.h)
|
||||
-AM_PATH_CPPUNIT(1.9.6)
|
||||
|
||||
AC_PROG_CXX
|
||||
AC_PROG_LIBTOOL
|
||||
--- a/scripts/common.m4
|
||||
+++ b/scripts/common.m4
|
||||
@@ -223,7 +223,7 @@ dnl Need to fix this so that it uses t
|
||||
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_MSG_CHECKING(for execinfo.h)
|
||||
|
||||
- AC_RUN_IFELSE(
|
||||
+ AC_LINK_IFELSE(
|
||||
[[#include <execinfo.h>
|
||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
||||
#include <execinfo.h>
|
||||
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
|
||||
]],
|
||||
@@ -199,7 +199,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
])],
|
||||
@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
|
||||
AC_MSG_CHECKING(the byte alignment)
|
||||
|
||||
- AC_RUN_IFELSE(
|
||||
+ AC_LINK_IFELSE(
|
||||
[[#include <inttypes.h>
|
||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
||||
#include <inttypes.h>
|
||||
int main() {
|
||||
char buf[8] = { 0, 0, 0, 0, 1, 0, 0, 0 };
|
||||
char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
|
||||
|
@ -1,13 +1,11 @@
|
||||
Index: rtorrent-0.8.6/src/display/canvas.h
|
||||
===================================================================
|
||||
--- rtorrent-0.8.6.orig/src/display/canvas.h
|
||||
+++ rtorrent-0.8.6/src/display/canvas.h
|
||||
--- a/src/display/canvas.h
|
||||
+++ b/src/display/canvas.h
|
||||
@@ -48,7 +48,7 @@ class Canvas {
|
||||
public:
|
||||
typedef std::vector<Attributes> attributes_list;
|
||||
|
||||
- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
|
||||
+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
|
||||
m_window(newwin(height, width, y, x)) {}
|
||||
- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
|
||||
+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
|
||||
~Canvas() { delwin(m_window); }
|
||||
|
||||
void refresh() { wnoutrefresh(m_window); }
|
||||
|
Loading…
x
Reference in New Issue
Block a user