[package] update lftp to 4.0.5 (#6383)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18970 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-12-29 22:45:42 +00:00
parent a87ce4ebce
commit 8004d98396
3 changed files with 21 additions and 39 deletions

View File

@ -9,12 +9,15 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=lftp PKG_NAME:=lftp
PKG_VERSION:=4.0.3 PKG_VERSION:=4.0.5
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://lftp.cybermirror.org/old/ PKG_SOURCE_URL:=http://lftp.cybermirror.org \
PKG_MD5SUM:=24f4b25718fef09cbc4d26ea73bd1578 http://lftp.cybermirror.org/old
PKG_MD5SUM:=5400cad5f91e131ac2ded7c24aea594c
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -27,6 +30,12 @@ define Package/lftp
URL:=http://lftp.yar.ru/ URL:=http://lftp.yar.ru/
endef endef
define Package/lftp/description
lftp is sophisticated file transfer program with command line interface. It
supports FTP, HTTP, FISH, SFTP and FILE (local FS) protocols. GNU Readline
library is used for input.
endef
# uses GNU configure # uses GNU configure
CONFIGURE_ARGS += \ CONFIGURE_ARGS += \
@ -43,16 +52,13 @@ CONFIGURE_VARS += \
LDFLAGS="$$$$LDFLAGS" \ LDFLAGS="$$$$LDFLAGS" \
LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc $(LIBGCC_S) -ldl" \ LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc $(LIBGCC_S) -ldl" \
define Build/Compile MAKE_VARS += \
$(MAKE) -C $(PKG_BUILD_DIR) \
LD="\$$$$(CC)" \ LD="\$$$$(CC)" \
all
endef
define Package/lftp/install define Package/lftp/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/lftp $(1)/usr/bin $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lftp $(1)/usr/bin
endef endef
define Package/lftp/postinst define Package/lftp/postinst

View File

@ -1,6 +1,5 @@
diff -burN lftp-3.7.7/lib/gettext.h lftp-3.7.7.patched/lib/gettext.h --- a/lib/gettext.h
--- lftp-3.7.7/lib/gettext.h 2008-05-16 18:28:43.000000000 +0200 +++ b/lib/gettext.h
+++ lftp-3.7.7.patched/lib/gettext.h 2009-01-03 18:59:05.374184151 +0100
@@ -22,7 +22,6 @@ @@ -22,7 +22,6 @@
#if ENABLE_NLS #if ENABLE_NLS

View File

@ -1,23 +0,0 @@
diff -burN lftp-3.7.7/lib/sys_time.in.h lftp-3.7.7.patched/lib/sys_time.in.h
--- lftp-3.7.7/lib/sys_time.in.h 2008-10-24 16:00:33.000000000 +0200
+++ lftp-3.7.7.patched/lib/sys_time.in.h 2009-01-03 21:20:34.129104049 +0100
@@ -39,6 +39,10 @@
# include <time.h>
# endif
+#ifdef __cplusplus
+extern "C" {
+#endif
+
# if ! @HAVE_STRUCT_TIMEVAL@
struct timeval
{
@@ -53,4 +57,8 @@
int gettimeofday (struct timeval *restrict, void *restrict);
# endif
+#ifdef __cplusplus
+}
+#endif
+
#endif /* _GL_SYS_TIME_H */