[package] update libgnutls to 0.9.5 (#5955)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18574 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
86802efdf5
commit
806773ac34
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnutls
|
||||
PKG_VERSION:=2.6.4
|
||||
PKG_VERSION:=2.8.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@GNU/gnutls \
|
||||
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
|
||||
PKG_MD5SUM:=747111ab0d86e7b06a4bb120ba456ad8
|
||||
PKG_MD5SUM:=
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
@ -67,6 +67,7 @@ define Package/libgnutls
|
||||
$(call Package/gnutls/Default)
|
||||
TITLE+= (library)
|
||||
DEPENDS+= +zlib +libgcrypt +libgpg-error
|
||||
SUBMENU:=SSL
|
||||
endef
|
||||
|
||||
define Package/libgnutls/description
|
||||
@ -79,6 +80,7 @@ define Package/libgnutls-extra
|
||||
$(call Package/gnutls/Default)
|
||||
TITLE+= (extra library)
|
||||
DEPENDS+= +libgnutls
|
||||
SUBMENU:=SSL
|
||||
endef
|
||||
|
||||
define Package/libgnutls-extra/description
|
||||
@ -91,6 +93,7 @@ define Package/libgnutls-openssl
|
||||
$(call Package/gnutls/Default)
|
||||
TITLE+= (OpenSSL compat library)
|
||||
DEPENDS+= +libgnutls
|
||||
SUBMENU:=SSL
|
||||
endef
|
||||
|
||||
define Package/libgnutls-openssl/description
|
||||
@ -126,8 +129,7 @@ define Build/Compile
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgnutls{,-extra}-config $(2)/bin/
|
||||
mkdir -p $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/gnutls $(1)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(1)/usr/lib/pkgconfig/
|
||||
|
@ -1,11 +1,13 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -573,7 +573,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
|
||||
-SUBDIRS = lgl gl includes lib libextra src doc tests po \
|
||||
+SUBDIRS = lgl gl includes lib libextra src \
|
||||
$(am__append_1)
|
||||
ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lgl/m4
|
||||
EXTRA_DIST = cfg.mk maint.mk .clcopying
|
||||
Index: gnutls-2.8.5/Makefile.in
|
||||
===================================================================
|
||||
--- gnutls-2.8.5.orig/Makefile.in 2009-11-02 11:36:03.000000000 +0100
|
||||
+++ gnutls-2.8.5/Makefile.in 2009-11-28 00:12:19.000000000 +0100
|
||||
@@ -147,7 +147,7 @@
|
||||
distdir dist dist-all distcheck
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
-DIST_SUBDIRS = lib libextra gl src doc tests guile
|
||||
+DIST_SUBDIRS = lib libextra gl src guile
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
top_distdir = $(distdir)
|
||||
|
Loading…
x
Reference in New Issue
Block a user