libsigc++: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@41729 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-07-18 10:06:16 +00:00
parent ecfcf0466b
commit 899cbae013
2 changed files with 0 additions and 83 deletions

View File

@ -1,61 +0,0 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libsigc++
PKG_VERSION:=2.2.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
PKG_MD5SUM:=73419b477f3bb9ddb9905c88a92f4b4c
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/libsigcxx
SECTION:=libs
CATEGORY:=Libraries
TITLE:=typesafe callback system for standard C++
URL:=http://libsigc.sourceforge.net/
DEPENDS:=+libstdcpp
endef
define Package/libsigcxx/description
It allows you to define signals and to connect those signals to any
callback function, either global or a member function, regardless of
whether it is static or virtual.
endef
TARGET_CFLAGS += $(FPIC)
TARGET_CPPFLAGS += \
-fno-strict-aliasing -fno-inline \
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libsigcxx/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libsigcxx))

View File

@ -1,22 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ doc_subdirs = docs
else
doc_subdirs =
endif
-SUBDIRS = sigc++ tests examples $(doc_subdirs)
+SUBDIRS = sigc++
sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include
nodist_sigc_config_HEADERS = sigc++config.h
--- a/Makefile.in
+++ b/Makefile.in
@@ -116,7 +116,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
distdir dist dist-all distcheck
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = sigc++ tests examples docs
+DIST_SUBDIRS = sigc++
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)