Update to asterisk 1.4.21 (yes there's a 1.4.21.1 but I haven't tested it)
Package 'rawplayer' for asterisk. Requires the tonezone patch for app-meetme Disabled ilbc which required a separate (non-free) package. Signed-off-by: Michael Geddes <michael at frog dot wheelycreek dot net> git-svn-id: svn://svn.openwrt.org/openwrt/packages@12794 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
457a704be9
commit
8b28448af3
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=asterisk
|
||||
PKG_VERSION:=1.4.11
|
||||
PKG_VERSION:=1.4.21
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.digium.com/pub/asterisk/old-releases/
|
||||
PKG_MD5SUM:=3ba9b399fedc68de4845b1c5603d167c
|
||||
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
||||
PKG_MD5SUM:=c4cf69eb6eae3105806b08d3efc28ec7
|
||||
|
||||
PKG_BUILD_DEPENDS:= libopenh323 pwlib
|
||||
|
||||
@ -50,7 +50,7 @@ endef
|
||||
define Package/asterisk14
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=Complete open source PBX
|
||||
DEPENDS:= +libltdl +libncurses +libpopt +libpthread @!TARGET_avr32
|
||||
DEPENDS:= +libncurses +libpopt +libpthread @!TARGET_avr32
|
||||
endef
|
||||
|
||||
define Package/asterisk14/description
|
||||
@ -83,6 +83,58 @@ $(call Package/asterisk14/Default/description)
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-app-meetme
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=conferencing support
|
||||
DEPENDS:= +asterisk14 +zaptel14-libtonezone
|
||||
endef
|
||||
|
||||
define Package/asterisk14-app-meetme/description
|
||||
$(call Package/asterisk14/Default/description)
|
||||
This package provides the MeetMe application driver Conferencing support to
|
||||
Asterisk.
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-oss
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=OSS soundcards support
|
||||
DEPENDS:= +asterisk14
|
||||
endef
|
||||
|
||||
define Package/asterisk14-chan-oss/description
|
||||
$(call Package/asterisk14/Default/description)
|
||||
This package provides the channel driver for OSS sound cards support to
|
||||
Asterisk.
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-app-meetme
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=conferencing support
|
||||
DEPENDS:= +asterisk14 +zaptel14-libtonezone
|
||||
endef
|
||||
|
||||
define Package/asterisk14-app-meetme/description
|
||||
$(call Package/asterisk14/Default/description)
|
||||
This package provides the MeetMe application driver Conferencing support to
|
||||
Asterisk.
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-oss
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=OSS soundcards support
|
||||
DEPENDS:= +asterisk14
|
||||
endef
|
||||
|
||||
define Package/asterisk14-chan-oss/description
|
||||
$(call Package/asterisk14/Default/description)
|
||||
This package provides the channel driver for OSS sound cards support to
|
||||
Asterisk.
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-alsa
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=ALSA soundcards support
|
||||
@ -147,17 +199,17 @@ $(call Package/asterisk14/Default/description)
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-codec-ilbc
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=ILBC Translator
|
||||
DEPENDS:= +asterisk14
|
||||
endef
|
||||
#define Package/asterisk14-codec-ilbc
|
||||
#$(call Package/asterisk14/Default)
|
||||
# TITLE:=ILBC Translator
|
||||
# DEPENDS:= +asterisk14
|
||||
#endef
|
||||
|
||||
define Package/asterisk14-codec-ilbc/description
|
||||
$(call Package/asterisk14/Default/description)
|
||||
This package contains the ILBC (Internet Low Bitrate Codec) translator
|
||||
for Asterisk.
|
||||
endef
|
||||
#define Package/asterisk14-codec-ilbc/description
|
||||
#$(call Package/asterisk14/Default/description)
|
||||
# This package contains the ILBC (Internet Low Bitrate Codec) translator
|
||||
# for Asterisk.
|
||||
#endef
|
||||
|
||||
|
||||
define Package/asterisk14-codec-lpc10
|
||||
@ -176,7 +228,7 @@ endef
|
||||
define Package/asterisk14-codec-speex
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=Speex/PCM16 Codec Translator
|
||||
DEPENDS:= +asterisk14 +libspeex
|
||||
DEPENDS:= +asterisk14 +libspeex +libspeexdsp
|
||||
endef
|
||||
|
||||
define Package/asterisk14-chan-speex/description
|
||||
@ -272,11 +324,20 @@ $(call Package/asterisk14/Default/description)
|
||||
This package contains voicemail related modules for Asterisk.
|
||||
endef
|
||||
|
||||
define Package/asterisk14-rawplayer
|
||||
$(call Package/asterisk14/Default)
|
||||
TITLE:=Play raw files for asterisk
|
||||
endef
|
||||
|
||||
define Package/asterisk14-rawplayer/description
|
||||
Contains the rawplayer utility for asterisk
|
||||
endef
|
||||
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--without-curl \
|
||||
--without-curses \
|
||||
--without-gsm \
|
||||
--with-gsm="$(STAGING_DIR)/usr" \
|
||||
--without-imap \
|
||||
--without-isdnnet \
|
||||
--without-kde \
|
||||
@ -289,7 +350,6 @@ CONFIGURE_ARGS+= \
|
||||
--without-odbc \
|
||||
--without-ogg \
|
||||
--without-osptk \
|
||||
--without-oss \
|
||||
--with-popt="$(STAGING_DIR)/usr" \
|
||||
--without-pri \
|
||||
--without-qt \
|
||||
@ -299,21 +359,35 @@ CONFIGURE_ARGS+= \
|
||||
--without-tds \
|
||||
--without-termcap \
|
||||
--without-tinfo \
|
||||
--without-tonezone \
|
||||
--without-vorbis \
|
||||
--without-vpb \
|
||||
--with-z="$(STAGING_DIR)/usr" \
|
||||
--without-zaptel \
|
||||
|
||||
EXTRA_CFLAGS:= $(TARGET_CPPFLAGS)
|
||||
EXTRA_LDFLAGS:= $(TARGET_LDFLAGS)
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-chan-alsa),)
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-app-meetme),)
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-asound="$(STAGING_DIR)/usr"
|
||||
--with-tonezone="$(STAGING_DIR)/usr" --with-zaptel="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS+= \
|
||||
--without-asound
|
||||
--without-tonezone --without-zaptel
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-chan-alsa),)
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-asound="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS+= \
|
||||
--without-asound
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-chan-oss),)
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-oss
|
||||
else
|
||||
CONFIGURE_ARGS+= \
|
||||
--without-oss
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-chan-gtalk),)
|
||||
@ -406,6 +480,8 @@ define Build/Compile
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install samples
|
||||
$(SED) 's|/var/lib/asterisk|/usr/lib/asterisk|g' $(PKG_INSTALL_DIR)/etc/asterisk/musiconhold.conf
|
||||
|
||||
$(TARGET_CC) -O2 $(PKG_BUILD_DIR)/contrib/utils/rawplayer.c -o $(PKG_BUILD_DIR)/rawplayer
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
@ -485,9 +561,10 @@ define Package/asterisk14/install
|
||||
cd modules; \
|
||||
rm -rf *adsi* *festival* *modem* *oss* *phone* *intercom* \
|
||||
*mp3* *nbscat* *sqlite* *mysql* *postgres* *pgsql* \
|
||||
*voicemail* *speex* *flash* *page* *zap* *jpeg* \
|
||||
*voicemail* *speex* *flash* *page* *meetme* *zap* *jpeg* \
|
||||
*snmp* \
|
||||
chan_alsa.so \
|
||||
chan_oss.so \
|
||||
chan_gtalk.so \
|
||||
chan_h323.so \
|
||||
chan_mgcp.so \
|
||||
@ -568,6 +645,54 @@ define Package/asterisk14-mini/install
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-app-meetme/conffiles
|
||||
/etc/asterisk/meetme.conf
|
||||
endef
|
||||
|
||||
define Package/asterisk14-app-meetme/install
|
||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/meetme.conf $(1)/etc/asterisk/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/app_meetme.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-oss/conffiles
|
||||
/etc/asterisk/oss.conf
|
||||
endef
|
||||
|
||||
define Package/asterisk14-chan-oss/install
|
||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/oss.conf $(1)/etc/asterisk/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_oss.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-app-meetme/conffiles
|
||||
/etc/asterisk/meetme.conf
|
||||
endef
|
||||
|
||||
define Package/asterisk14-app-meetme/install
|
||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/meetme.conf $(1)/etc/asterisk/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/app_meetme.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-oss/conffiles
|
||||
/etc/asterisk/oss.conf
|
||||
endef
|
||||
|
||||
define Package/asterisk14-chan-oss/install
|
||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/asterisk/oss.conf $(1)/etc/asterisk/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_oss.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-chan-alsa/conffiles
|
||||
/etc/asterisk/alsa.conf
|
||||
endef
|
||||
@ -631,11 +756,11 @@ define Package/asterisk14-chan-skinny/install
|
||||
endef
|
||||
|
||||
|
||||
define Package/asterisk14-codec-ilbc/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/codec_ilbc.so $(1)/usr/lib/asterisk/modules/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/format_ilbc.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
#define Package/asterisk14-codec-ilbc/install
|
||||
# $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/codec_ilbc.so $(1)/usr/lib/asterisk/modules/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/format_ilbc.so $(1)/usr/lib/asterisk/modules/
|
||||
#endef
|
||||
|
||||
|
||||
define Package/asterisk14-codec-lpc10/install
|
||||
@ -718,15 +843,23 @@ define Package/asterisk14-voicemail/install
|
||||
$(CP) $(PKG_INSTALL_DIR)//usr/lib/asterisk/sounds/vm-*.gsm $(1)/usr/lib/asterisk/sounds/
|
||||
endef
|
||||
|
||||
define Package/asterisk14-rawplayer/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rawplayer \
|
||||
$(1)/usr/bin
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,asterisk14))
|
||||
$(eval $(call BuildPackage,asterisk14-mini))
|
||||
$(eval $(call BuildPackage,asterisk14-app-meetme))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-oss))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-alsa))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-gtalk))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-h323))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-mgcp))
|
||||
$(eval $(call BuildPackage,asterisk14-chan-skinny))
|
||||
$(eval $(call BuildPackage,asterisk14-codec-ilbc))
|
||||
#$(eval $(call BuildPackage,asterisk14-codec-ilbc))
|
||||
$(eval $(call BuildPackage,asterisk14-codec-lpc10))
|
||||
$(eval $(call BuildPackage,asterisk14-codec-speex))
|
||||
$(eval $(call BuildPackage,asterisk14-pbx-dundi))
|
||||
@ -736,3 +869,4 @@ $(eval $(call BuildPackage,asterisk14-pgsql))
|
||||
$(eval $(call BuildPackage,asterisk14-sqlite))
|
||||
$(eval $(call BuildPackage,asterisk14-voicemail))
|
||||
$(eval $(call BuildPackage,asterisk14-sounds))
|
||||
$(eval $(call BuildPackage,asterisk14-rawplayer))
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -Nru asterisk-1.4.5.org/main/Makefile asterisk-1.4.5/main/Makefile
|
||||
--- asterisk-1.4.5.org/main/Makefile 2007-04-10 18:05:55.000000000 +0200
|
||||
+++ asterisk-1.4.5/main/Makefile 2007-06-22 08:59:22.000000000 +0200
|
||||
@@ -135,7 +135,7 @@
|
||||
@rm -f $(ASTTOPDIR)/include/asterisk/build.h.tmp
|
||||
@$(CC) -c -o buildinfo.o $(ASTCFLAGS) buildinfo.c
|
||||
$(ECHO_PREFIX) echo " [LD] $^ -> $@"
|
||||
diff -Nru asterisk-1.4.18.org/main/Makefile asterisk-1.4.18/main/Makefile
|
||||
--- asterisk-1.4.18.org/main/Makefile 2008-01-29 18:43:41.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/main/Makefile 2008-03-02 19:30:04.000000000 +0100
|
||||
@@ -144,7 +144,7 @@
|
||||
ifneq ($(findstring chan_h323,$(MENUSELECT_CHANNELS)),)
|
||||
$(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS)
|
||||
else
|
||||
- $(CMD_PREFIX) $(CXX) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS)
|
||||
+ $(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS)
|
||||
endif
|
||||
@$(ASTTOPDIR)/build_tools/strip_nonapi $@
|
||||
|
||||
clean::
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Nru asterisk-1.4.5.org/channels/chan_iax2.c asterisk-1.4.5/channels/chan_iax2.c
|
||||
--- asterisk-1.4.5.org/channels/chan_iax2.c 2007-06-14 23:50:40.000000000 +0200
|
||||
+++ asterisk-1.4.5/channels/chan_iax2.c 2007-06-22 09:03:01.000000000 +0200
|
||||
@@ -1376,7 +1376,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/channels/chan_iax2.c asterisk-1.4.18/channels/chan_iax2.c
|
||||
--- asterisk-1.4.18.org/channels/chan_iax2.c 2008-01-31 20:52:49.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/channels/chan_iax2.c 2008-03-02 19:32:14.000000000 +0100
|
||||
@@ -1554,7 +1554,7 @@
|
||||
last++;
|
||||
else
|
||||
last = s;
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- asterisk-1.4.5.org/configure.ac 2007-06-04 18:02:31.000000000 +0200
|
||||
+++ asterisk-1.4.5/configure.ac 2007-06-22 08:47:51.000000000 +0200
|
||||
@@ -900,7 +900,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
|
||||
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:33:55.000000000 +0100
|
||||
@@ -884,7 +884,7 @@
|
||||
|
||||
AST_EXT_LIB_CHECK([SQLITE], [sqlite], [sqlite_exec], [sqlite.h])
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Nru asterisk-1.4.5.org/apps/app_rxfax.c asterisk-1.4.5/apps/app_rxfax.c
|
||||
--- asterisk-1.4.5.org/apps/app_rxfax.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ asterisk-1.4.5/apps/app_rxfax.c 2007-06-22 09:05:59.000000000 +0200
|
||||
diff -Nru asterisk-1.4.18.org/apps/app_rxfax.c asterisk-1.4.18/apps/app_rxfax.c
|
||||
--- asterisk-1.4.18.org/apps/app_rxfax.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/apps/app_rxfax.c 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -0,0 +1,376 @@
|
||||
+/*
|
||||
+ * Asterisk -- A telephony toolkit for Linux.
|
||||
@ -378,9 +378,9 @@ diff -Nru asterisk-1.4.5.org/apps/app_rxfax.c asterisk-1.4.5/apps/app_rxfax.c
|
||||
+AST_MODULE_INFO_STANDARD(ASTERISK_GPL_KEY, "Trivial FAX Receive Application");
|
||||
+
|
||||
+/*- End of file ------------------------------------------------------------*/
|
||||
diff -Nru asterisk-1.4.5.org/apps/app_txfax.c asterisk-1.4.5/apps/app_txfax.c
|
||||
--- asterisk-1.4.5.org/apps/app_txfax.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ asterisk-1.4.5/apps/app_txfax.c 2007-06-22 09:05:59.000000000 +0200
|
||||
diff -Nru asterisk-1.4.18.org/apps/app_txfax.c asterisk-1.4.18/apps/app_txfax.c
|
||||
--- asterisk-1.4.18.org/apps/app_txfax.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/apps/app_txfax.c 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -0,0 +1,303 @@
|
||||
+/*
|
||||
+ * Asterisk -- A telephony toolkit for Linux.
|
||||
@ -685,29 +685,29 @@ diff -Nru asterisk-1.4.5.org/apps/app_txfax.c asterisk-1.4.5/apps/app_txfax.c
|
||||
+AST_MODULE_INFO_STANDARD(ASTERISK_GPL_KEY, "Trivial FAX Transmit Application");
|
||||
+
|
||||
+/*- End of file ------------------------------------------------------------*/
|
||||
diff -Nru asterisk-1.4.5.org/build_tools/menuselect-deps.in asterisk-1.4.5/build_tools/menuselect-deps.in
|
||||
--- asterisk-1.4.5.org/build_tools/menuselect-deps.in 2007-03-16 00:53:26.000000000 +0100
|
||||
+++ asterisk-1.4.5/build_tools/menuselect-deps.in 2007-06-22 09:05:59.000000000 +0200
|
||||
diff -Nru asterisk-1.4.18.org/build_tools/menuselect-deps.in asterisk-1.4.18/build_tools/menuselect-deps.in
|
||||
--- asterisk-1.4.18.org/build_tools/menuselect-deps.in 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/build_tools/menuselect-deps.in 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
POPT=@PBX_POPT@
|
||||
PRI=@PBX_PRI@
|
||||
QT=@PBX_QT@
|
||||
RADIUS=@PBX_RADIUS@
|
||||
+SPANDSP=@PBX_SPANDSP@
|
||||
SPEEX=@PBX_SPEEX@
|
||||
SPEEXDSP=@PBX_SPEEXDSP@
|
||||
SQLITE=@PBX_SQLITE@
|
||||
SSL=@PBX_OPENSSL@
|
||||
diff -Nru asterisk-1.4.5.org/configure.ac asterisk-1.4.5/configure.ac
|
||||
--- asterisk-1.4.5.org/configure.ac 2007-06-04 18:02:31.000000000 +0200
|
||||
+++ asterisk-1.4.5/configure.ac 2007-06-22 09:05:59.000000000 +0200
|
||||
@@ -195,6 +195,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
|
||||
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -198,6 +198,7 @@
|
||||
AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
|
||||
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
|
||||
AST_EXT_LIB_SETUP([QT], [Qt], [qt])
|
||||
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
|
||||
+AST_EXT_LIB_SETUP([SPANDSP], [spandsp Library], [spandsp])
|
||||
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
|
||||
AST_EXT_LIB_SETUP([SPEEXDSP], [Speexdsp], [speexdsp])
|
||||
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
|
||||
AST_EXT_LIB_SETUP([SUPPSERV], [mISDN Supplemental Services], [suppserv])
|
||||
@@ -896,6 +897,8 @@
|
||||
@@ -878,6 +879,8 @@
|
||||
|
||||
AST_EXT_LIB_CHECK([RADIUS], [radiusclient-ng], [rc_read_config], [radiusclient-ng.h])
|
||||
|
||||
@ -715,10 +715,10 @@ diff -Nru asterisk-1.4.5.org/configure.ac asterisk-1.4.5/configure.ac
|
||||
+
|
||||
AST_EXT_LIB_CHECK([SPEEX], [speex], [speex_encode], [speex/speex.h], [-lm])
|
||||
|
||||
AST_EXT_LIB_CHECK([SQLITE], [sqlite], [sqlite_exec], [sqlite.h])
|
||||
diff -Nru asterisk-1.4.5.org/include/asterisk/plc.h asterisk-1.4.5/include/asterisk/plc.h
|
||||
--- asterisk-1.4.5.org/include/asterisk/plc.h 2006-06-14 16:12:56.000000000 +0200
|
||||
+++ asterisk-1.4.5/include/asterisk/plc.h 2007-06-22 09:07:42.000000000 +0200
|
||||
AST_EXT_LIB_CHECK([SPEEXDSP], [speexdsp], [speex_preprocess_ctl], [speex/speex.h], [-lm])
|
||||
diff -Nru asterisk-1.4.18.org/include/asterisk/plc.h asterisk-1.4.18/include/asterisk/plc.h
|
||||
--- asterisk-1.4.18.org/include/asterisk/plc.h 2006-06-14 16:12:56.000000000 +0200
|
||||
+++ asterisk-1.4.19.1/include/asterisk/plc.h 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -1,18 +1,17 @@
|
||||
-/*! \file
|
||||
- * \brief SpanDSP - a series of DSP components for telephony
|
||||
@ -860,10 +860,10 @@ diff -Nru asterisk-1.4.5.org/include/asterisk/plc.h asterisk-1.4.5/include/aster
|
||||
}
|
||||
#endif
|
||||
|
||||
diff -Nru asterisk-1.4.5.org/makeopts.in asterisk-1.4.5/makeopts.in
|
||||
--- asterisk-1.4.5.org/makeopts.in 2007-05-25 16:28:46.000000000 +0200
|
||||
+++ asterisk-1.4.5/makeopts.in 2007-06-22 09:05:59.000000000 +0200
|
||||
@@ -138,6 +138,9 @@
|
||||
diff -Nru asterisk-1.4.18.org/makeopts.in asterisk-1.4.18/makeopts.in
|
||||
--- asterisk-1.4.18.org/makeopts.in 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/makeopts.in 2008-03-02 19:35:45.000000000 +0100
|
||||
@@ -137,6 +137,9 @@
|
||||
RADIUS_INCLUDE=@RADIUS_INCLUDE@
|
||||
RADIUS_LIB=@RADIUS_LIB@
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Nru asterisk-1.4.5.org/configure.ac asterisk-1.4.5/configure.ac
|
||||
--- asterisk-1.4.5.org/configure.ac 2007-06-04 18:02:31.000000000 +0200
|
||||
+++ asterisk-1.4.5/configure.ac 2007-06-22 09:09:03.000000000 +0200
|
||||
@@ -419,7 +419,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
|
||||
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:38:21.000000000 +0100
|
||||
@@ -470,7 +470,7 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Nru asterisk-1.4.5.org/Makefile asterisk-1.4.5/Makefile
|
||||
--- asterisk-1.4.5.org/Makefile 2007-05-24 21:05:08.000000000 +0200
|
||||
+++ asterisk-1.4.5/Makefile 2007-06-22 09:10:18.000000000 +0200
|
||||
@@ -200,7 +200,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/Makefile asterisk-1.4.18/Makefile
|
||||
--- asterisk-1.4.18.org/Makefile 2008-01-29 18:21:33.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/Makefile 2008-03-02 19:39:23.000000000 +0100
|
||||
@@ -215,7 +215,7 @@
|
||||
endif
|
||||
|
||||
ifneq ($(PROC),ultrasparc)
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -ruN asterisk-1.4.9-old/acinclude.m4 asterisk-1.4.9-new/acinclude.m4
|
||||
--- asterisk-1.4.9-old/acinclude.m4 2007-09-04 17:20:27.000000000 +0200
|
||||
+++ asterisk-1.4.9-new/acinclude.m4 2007-09-04 17:17:04.000000000 +0200
|
||||
@@ -496,6 +496,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/acinclude.m4 asterisk-1.4.18/acinclude.m4
|
||||
--- asterisk-1.4.18.org/acinclude.m4 2007-07-25 19:14:14.000000000 +0200
|
||||
+++ asterisk-1.4.19.1/acinclude.m4 2008-03-02 19:40:27.000000000 +0100
|
||||
@@ -508,6 +508,7 @@
|
||||
;;
|
||||
esac
|
||||
AC_MSG_RESULT(${OPENH323_BUILD})
|
||||
@ -9,10 +9,10 @@ diff -ruN asterisk-1.4.9-old/acinclude.m4 asterisk-1.4.9-new/acinclude.m4
|
||||
|
||||
AC_SUBST([OPENH323_SUFFIX])
|
||||
AC_SUBST([OPENH323_BUILD])
|
||||
diff -ruN asterisk-1.4.9-old/configure.ac asterisk-1.4.9-new/configure.ac
|
||||
--- asterisk-1.4.9-old/configure.ac 2007-09-04 17:20:27.000000000 +0200
|
||||
+++ asterisk-1.4.9-new/configure.ac 2007-09-04 17:22:08.000000000 +0200
|
||||
@@ -807,7 +807,7 @@
|
||||
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
|
||||
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
|
||||
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:40:27.000000000 +0100
|
||||
@@ -835,7 +835,7 @@
|
||||
if test "${HAS_PWLIB:-unset}" != "unset"; then
|
||||
AST_CHECK_OPENH323_PLATFORM()
|
||||
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff -Nru asterisk-1.4.5.org/codecs/gsm/Makefile asterisk-1.4.5/codecs/gsm/Makefile
|
||||
--- asterisk-1.4.5.org/codecs/gsm/Makefile 2007-02-17 01:31:42.000000000 +0100
|
||||
+++ asterisk-1.4.5/codecs/gsm/Makefile 2007-06-22 09:13:13.000000000 +0200
|
||||
@@ -38,7 +38,7 @@
|
||||
######### probably require gcc.
|
||||
|
||||
ifeq (, $(findstring $(OSARCH) , Darwin SunOS ))
|
||||
-ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel ))
|
||||
+ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel mips ))
|
||||
ifeq (, $(findstring $(shell uname -m) , ppc ppc64 alpha armv4l s390 ))
|
||||
OPTIMIZE+=-march=$(PROC)
|
||||
endif
|
||||
@@ -209,7 +209,7 @@
|
||||
# XXX should merge with GSM_OBJECTS
|
||||
ifeq ($(OSARCH),linux-gnu)
|
||||
ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc s390 ))
|
||||
-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel ))
|
||||
+ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel mips ))
|
||||
GSM_SOURCES+= $(SRC)/k6opt.s
|
||||
endif
|
||||
endif
|
||||
@@ -261,7 +261,7 @@
|
||||
|
||||
ifeq ($(OSARCH),linux-gnu)
|
||||
ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc ))
|
||||
-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel ))
|
||||
+ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel mips ))
|
||||
GSM_OBJECTS+= $(SRC)/k6opt.o
|
||||
endif
|
||||
endif
|
Loading…
x
Reference in New Issue
Block a user