[packages] mercurial: update to 1.8, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25868 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a39dc985f1
commit
90531c161f
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mercurial
|
||||
PKG_VERSION:=1.7.2
|
||||
PKG_VERSION:=1.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://mercurial.selenic.com/release
|
||||
PKG_MD5SUM:=e9e99a0a20ded8f6d9463ffb94021b12
|
||||
PKG_MD5SUM:=c97b39832f2da60f951d1b7701688bd2
|
||||
|
||||
PKG_BUILD_DEPENDS:=python-mini
|
||||
|
||||
|
@ -17,7 +17,7 @@
|
||||
|
||||
class GzipFileWithTime(gzip.GzipFile):
|
||||
|
||||
@@ -198,7 +197,6 @@ class fileit(object):
|
||||
@@ -205,7 +204,6 @@ class fileit(object):
|
||||
archivers = {
|
||||
'files': fileit,
|
||||
'tar': tarit,
|
||||
@ -27,7 +27,7 @@
|
||||
'zip': zipit,
|
||||
--- a/mercurial/bundlerepo.py
|
||||
+++ b/mercurial/bundlerepo.py
|
||||
@@ -312,7 +312,7 @@ def getremotechanges(ui, repo, other, re
|
||||
@@ -307,7 +307,7 @@ def getremotechanges(ui, repo, other, re
|
||||
cg = other.changegroup(incoming, "incoming")
|
||||
else:
|
||||
cg = other.changegroupsubset(incoming, revs, 'incoming')
|
||||
@ -45,9 +45,9 @@
|
||||
-import struct, os, bz2, zlib, tempfile
|
||||
+import struct, os, zlib, tempfile
|
||||
|
||||
def getchunk(source):
|
||||
"""return the next chunk from changegroup 'source' as a string"""
|
||||
@@ -41,7 +41,6 @@ class nocompress(object):
|
||||
def readexactly(stream, n):
|
||||
'''read n bytes from stream.read and abort if less was available'''
|
||||
@@ -45,7 +45,6 @@ class nocompress(object):
|
||||
bundletypes = {
|
||||
"": ("", nocompress),
|
||||
"HG10UN": ("HG10UN", nocompress),
|
||||
@ -55,7 +55,7 @@
|
||||
"HG10GZ": ("HG10GZ", lambda: zlib.compressobj()),
|
||||
}
|
||||
|
||||
@@ -55,14 +54,13 @@ def collector(cl, mmfs, files):
|
||||
@@ -59,14 +58,13 @@ def collector(cl, mmfs, files):
|
||||
return collect
|
||||
|
||||
# hgweb uses this list to communicate its preferred type
|
||||
@ -71,7 +71,7 @@
|
||||
The bundle file will be deleted in case of errors.
|
||||
"""
|
||||
|
||||
@@ -120,12 +118,6 @@ def decompressor(fh, alg):
|
||||
@@ -124,12 +122,6 @@ def decompressor(fh, alg):
|
||||
zd = zlib.decompressobj()
|
||||
for chunk in f:
|
||||
yield zd.decompress(chunk)
|
||||
@ -86,15 +86,15 @@
|
||||
return util.chunkbuffer(generator(fh))
|
||||
--- a/mercurial/hgweb/hgwebdir_mod.py
|
||||
+++ b/mercurial/hgweb/hgwebdir_mod.py
|
||||
@@ -192,7 +192,7 @@ class hgwebdir(object):
|
||||
|
||||
@@ -204,7 +204,7 @@ class hgwebdir(object):
|
||||
def archivelist(ui, nodeid, url):
|
||||
allowed = ui.configlist("web", "allow_archive", untrusted=True)
|
||||
archives = []
|
||||
- for i in [('zip', '.zip'), ('gz', '.tar.gz'), ('bz2', '.tar.bz2')]:
|
||||
+ for i in [('zip', '.zip'), ('gz', '.tar.gz')]:
|
||||
if i[0] in allowed or ui.configbool("web", "allow" + i[0],
|
||||
untrusted=True):
|
||||
yield {"type" : i[0], "extension": i[1],
|
||||
archives.append({"type" : i[0], "extension": i[1],
|
||||
--- a/mercurial/hgweb/hgweb_mod.py
|
||||
+++ b/mercurial/hgweb/hgweb_mod.py
|
||||
@@ -39,7 +39,7 @@ class hgweb(object):
|
||||
@ -135,7 +135,7 @@
|
||||
:``tgz``: tar archive, compressed using gzip
|
||||
:``uzip``: zip archive, uncompressed
|
||||
:``zip``: zip archive, compressed using deflate
|
||||
@@ -559,8 +558,8 @@ def bundle(ui, repo, fname, dest=None, *
|
||||
@@ -644,8 +643,8 @@ def bundle(ui, repo, fname, dest=None, *
|
||||
-a/--all (or --base null).
|
||||
|
||||
You can change compression method with the -t/--type option.
|
||||
@ -146,7 +146,7 @@
|
||||
|
||||
The bundle file can then be transferred using conventional means
|
||||
and applied to another repository with the unbundle or pull
|
||||
@@ -624,8 +623,8 @@ def bundle(ui, repo, fname, dest=None, *
|
||||
@@ -712,8 +711,8 @@ def bundle(ui, repo, fname, dest=None, *
|
||||
else:
|
||||
cg = repo.changegroup(o, 'bundle')
|
||||
|
||||
@ -157,7 +157,7 @@
|
||||
bundletype = btypes.get(bundletype)
|
||||
if bundletype not in changegroup.bundletypes:
|
||||
raise util.Abort(_('unknown bundle type specified with --type'))
|
||||
@@ -4084,7 +4083,7 @@ table = {
|
||||
@@ -4307,7 +4306,7 @@ table = {
|
||||
_('a base changeset assumed to be available at the destination'),
|
||||
_('REV')),
|
||||
('a', 'all', None, _('bundle all changesets in the repository')),
|
||||
|
Loading…
x
Reference in New Issue
Block a user