Add prosody, XMPP server written in LUA
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14237 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8d368d19ad
commit
923c8d8c38
64
net/prosody/Makefile
Normal file
64
net/prosody/Makefile
Normal file
@ -0,0 +1,64 @@
|
||||
#
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=prosody
|
||||
PKG_VERSION:=0.2.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://prosody.im/downloads/source/
|
||||
PKG_MD5SUM:=825b37b6917e5c21a8596c027e0972ec
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/prosody
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+liblua +libidn
|
||||
TITLE:=XMPP server
|
||||
URL:=http://prosody.im
|
||||
endef
|
||||
|
||||
define Package/prosody/description
|
||||
Prosody is an exciting new server for Jabber/XMPP
|
||||
written in Lua. It aims to be easy to use, and light
|
||||
on resources
|
||||
endef
|
||||
|
||||
define Package/prosody/conffiles
|
||||
/etc/prosody/prosody.cfg.lua
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); ./configure \
|
||||
--prefix=/usr \
|
||||
--with-lua="$(STAGING_DIR)/host/bin" \
|
||||
--with-lua-include="$(STAGING_DIR)/usr/include/" \
|
||||
--with-lua-lib="$(STAGING_DIR)/usr/lib" \
|
||||
--cflags="$(TARGET_CFLAGS)" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,\
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
PREFIX="/usr" \
|
||||
all install \
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/prosody/install
|
||||
$(INSTALL_DIR) $(1)/
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,prosody))
|
28
net/prosody/patches/001-cross_compile.patch
Normal file
28
net/prosody/patches/001-cross_compile.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -urN prosody-0.2.0/util-src/Makefile prosody-0.2.0.new/util-src/Makefile
|
||||
--- prosody-0.2.0/util-src/Makefile 2008-12-27 22:54:07.000000000 +0100
|
||||
+++ prosody-0.2.0.new/util-src/Makefile 2009-01-28 12:25:44.000000000 +0100
|
||||
@@ -20,18 +20,18 @@
|
||||
rm -f ../util/*.so
|
||||
|
||||
encodings.o: encodings.c
|
||||
- gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o encodings.o encodings.c
|
||||
+ $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o encodings.o encodings.c
|
||||
encodings.so: encodings.o
|
||||
- export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o encodings.so encodings.o -L/usr/local/lib -llua$(LUA_SUFFIX) -lcrypto -lidn
|
||||
+ export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o encodings.so encodings.o -L$(STAGING_DIR)/usr/lib -llua$(LUA_SUFFIX) -lcrypto -lidn
|
||||
|
||||
|
||||
hashes.o: hashes.c
|
||||
- gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o hashes.o hashes.c
|
||||
+ $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o hashes.o hashes.c
|
||||
hashes.so: hashes.o
|
||||
- export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o hashes.so hashes.o -L/usr/local/lib -llua$(LUA_SUFFIX) -lcrypto -lssl
|
||||
+ export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o hashes.so hashes.o -L$(STAGING_DIR)/usr/lib -llua$(LUA_SUFFIX) -lcrypto -lssl
|
||||
|
||||
pposix.o: pposix.c
|
||||
- gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o pposix.o pposix.c
|
||||
+ $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o pposix.o pposix.c
|
||||
pposix.so: pposix.o
|
||||
- export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o pposix.so pposix.o -L/usr/local/lib -llua$(LUA_SUFFIX)
|
||||
+ export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o pposix.so pposix.o -L$(STAGING_DIR)/usr/lib -llua$(LUA_SUFFIX)
|
||||
|
Loading…
x
Reference in New Issue
Block a user