[packages] yafc: force full autoreconf, fix cross compilation after reconf
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24533 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
73dc4c93de
commit
9342770e42
@ -16,6 +16,7 @@ PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=832d074183a36ee15b47553ed5962fce
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -29,6 +30,8 @@ define Package/yafc
|
||||
endef
|
||||
|
||||
# uses GNU configure
|
||||
CONFIGURE_VARS += \
|
||||
bash_cv_func_sigsetjmp=missing
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- yafc-1.1.1/configure 2005-10-06 08:26:31.000000000 +0200
|
||||
+++ yafc-1.1.1.new/configure 2006-07-11 13:40:21.000000000 +0200
|
||||
@@ -24640,7 +24640,7 @@
|
||||
|
||||
fi
|
||||
|
||||
-
|
||||
+cross_compiling=no
|
||||
echo "$as_me:$LINENO: checking for presence of POSIX-style sigsetjmp/siglongjmp" >&5
|
||||
echo $ECHO_N "checking for presence of POSIX-style sigsetjmp/siglongjmp... $ECHO_C" >&6
|
||||
if test "${bash_cv_func_sigsetjmp+set}" = set; then
|
||||
@@ -24659,7 +24659,7 @@
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-
|
||||
+cross_compiling=yes
|
||||
#ifdef HAVE_UNISTD_H
|
||||
#include <unistd.h>
|
||||
#endif
|
Loading…
x
Reference in New Issue
Block a user