add ushare package
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10886 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fccc97ce40
commit
93c58686b3
72
multimedia/ushare/Makefile
Normal file
72
multimedia/ushare/Makefile
Normal file
@ -0,0 +1,72 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ushare
|
||||
PKG_VERSION:=1.1a
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ushare.geexbox.org/releases/
|
||||
PKG_MD5SUM:=5bbcdbf1ff85a9710fa3d4e82ccaa251
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/ushare
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
TITLE:= UPnP A/V & DLNA Media Server
|
||||
URL:=http://ushare.geexbox.org/
|
||||
DEPENDS:=+libdlna +libupnp
|
||||
endef
|
||||
|
||||
define Package/ushare/description
|
||||
uShare is a UPnP (TM) A/V & DLNA Media Server. It implements the server
|
||||
component that provides UPnP media devices with information on available
|
||||
multimedia files.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
# this is *NOT* GNU configure
|
||||
( cd $(PKG_BUILD_DIR); \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -lfaad -lpthread -lavcodec -lavformat -lavutil -lz" \
|
||||
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
|
||||
PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \
|
||||
./configure \
|
||||
--cross-compile \
|
||||
--cross-prefix="$(TARGET_CROSS)" \
|
||||
--prefix="/usr" \
|
||||
--sysconfdir="/etc" \
|
||||
--enable-dlna \
|
||||
--disable-nls \
|
||||
--disable-debug \
|
||||
--disable-optimize \
|
||||
--disable-strip \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/ushare/conffiles
|
||||
/etc/ushare.conf
|
||||
endef
|
||||
|
||||
define Package/ushare/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/ushare.conf $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ushare $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,ushare))
|
12
multimedia/ushare/patches/100-configure_grep_fix.patch
Normal file
12
multimedia/ushare/patches/100-configure_grep_fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN ushare-1.1a-orig/configure ushare-1.1a/configure
|
||||
--- ushare-1.1a-orig/configure 2007-12-09 14:03:36.000000000 +0100
|
||||
+++ ushare-1.1a/configure 2008-04-19 22:48:35.000000000 +0200
|
||||
@@ -130,7 +130,7 @@
|
||||
var=$1
|
||||
shift
|
||||
for f in $@; do
|
||||
- if eval echo \$$var | grep -qv -e "$f"; then
|
||||
+ if eval echo \$$var | grep -qv -e "$(echo $f | sed -e 's|\.|\\\.|g')"; then
|
||||
eval "$var=\"\$$var $f\""
|
||||
fi
|
||||
done
|
Loading…
x
Reference in New Issue
Block a user