update to openssh 4.7p1, patches refreshed

git-svn-id: svn://svn.openwrt.org/openwrt/packages@9101 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
pavlov 2007-10-02 22:00:29 +00:00
parent 56b0dceb28
commit 95a2c9d2bd
3 changed files with 18 additions and 14 deletions

View File

@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=4.5p1
PKG_VERSION:=4.7p1
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@ -18,7 +18,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
PKG_MD5SUM:=6468c339886f78e8a149b88f695839dd
PKG_MD5SUM:=50a800fd2c6def9e9a53068837e87b91
PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install

View File

@ -1,5 +1,7 @@
--- /tmp/openssh-4.5p1/cipher.c 2006-08-04 21:39:39.000000000 -0500
+++ openssh-4.5p1/cipher.c 2007-03-03 20:02:45.000000000 -0600
Index: openssh-4.7p1/cipher.c
===================================================================
--- openssh-4.7p1.orig/cipher.c 2007-10-02 16:53:04.000000000 -0500
+++ openssh-4.7p1/cipher.c 2007-10-02 16:53:04.000000000 -0500
@@ -72,7 +72,9 @@
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, EVP_des_ede3_cbc },

View File

@ -1,13 +1,15 @@
--- /tmp/openssh-4.5p1/mac.c 2006-09-01 00:38:37.000000000 -0500
+++ openssh-4.5p1/mac.c 2007-03-03 20:02:45.000000000 -0600
@@ -51,8 +51,10 @@
{ "hmac-sha1-96", EVP_sha1, 96 },
{ "hmac-md5", EVP_md5, 0 },
{ "hmac-md5-96", EVP_md5, 96 },
Index: openssh-4.7p1/mac.c
===================================================================
--- openssh-4.7p1.orig/mac.c 2007-10-02 16:53:04.000000000 -0500
+++ openssh-4.7p1/mac.c 2007-10-02 16:53:04.000000000 -0500
@@ -59,8 +59,10 @@
{ "hmac-sha1-96", SSH_EVP, EVP_sha1, 96, -1, -1 },
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
+#ifndef OPENSSL_NO_RIPEMD
{ "hmac-ripemd160", EVP_ripemd160, 0 },
{ "hmac-ripemd160@openssh.com", EVP_ripemd160, 0 },
{ "hmac-ripemd160", SSH_EVP, EVP_ripemd160, 0, -1, -1 },
{ "hmac-ripemd160@openssh.com", SSH_EVP, EVP_ripemd160, 0, -1, -1 },
+#endif
{ NULL, NULL, 0 }
{ "umac-64@openssh.com", SSH_UMAC, NULL, 0, 128, 64 },
{ NULL, 0, NULL, 0, -1, -1 }
};