[packages] drop palantir as v4l was dropped

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32111 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2012-06-07 15:01:07 +00:00
parent cef07a646b
commit 95ce87f083
2 changed files with 0 additions and 88 deletions

View File

@ -1,62 +0,0 @@
#
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=palantir
PKG_VERSION:=2.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
PKG_MD5SUM:=3a5b1fb340857f6d8e357bf39b77583e
PKG_BUILD_DEPENDS:=libjpeg
define Package/palantir
SECTION:=multimedia
CATEGORY:=Multimedia
DEPENDS:=+libjpeg +libpthread
TITLE:=A multichannel interactive streaming solution
URL:=http://www.fastpath.it/products/palantir/
endef
define Package/palantir/description
Palantir is a Linux-based streaming system designed to transmit live
video, audio and data over a TCP/IP network, as well as to control
remote devices.
endef
define Package/palantir/conffiles
/etc/palantir.conf
endef
include $(INCLUDE_DIR)/package.mk
export CPPFLAGS=$(TARGET_CPPFLAGS)
export LDFLAGS=$(TARGET_LDFLAGS)
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
$(TARGET_CONFIGURE_OPTS) \
CCINC="$(TARGET_CPPFLAGS)" \
COPTS="$(TARGET_CFLAGS)" \
lib/libgsm.a
$(MAKE) -C $(PKG_BUILD_DIR)/server \
$(TARGET_CONFIGURE_OPTS) \
COPTS="$(TARGET_CFLAGS)" \
palantir
endef
define Package/palantir/install
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,palantir))

View File

@ -1,26 +0,0 @@
Index: palantir-2.7/server/libgsm/Makefile
===================================================================
--- palantir-2.7.orig/server/libgsm/Makefile 2008-04-07 22:35:39.000000000 +0200
+++ palantir-2.7/server/libgsm/Makefile 2008-04-07 22:35:39.000000000 +0200
@@ -53,7 +53,7 @@
endif
CC += -ansi -pedantic
-CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1
+CCFLAGS = -c $(COPTS) -DNeedFunctionPrototypes=1
LD = $(CC)
Index: palantir-2.7/server/Makefile
===================================================================
--- palantir-2.7.orig/server/Makefile 2008-04-07 22:35:39.000000000 +0200
+++ palantir-2.7/server/Makefile 2008-04-07 22:35:39.000000000 +0200
@@ -47,7 +47,7 @@
.PHONY : tools man
-CFLAGS= -Wall -D_REENTRANT -O2 -g
+CFLAGS= -Wall -D_REENTRANT $(COPTS)
# -O3
CC= gcc
libjpeg= -ljpeg