Upgrade cups to 1.3.7
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12640 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
efbe258198
commit
976d40ceef
@ -9,7 +9,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cups
|
||||
PKG_VERSION:=1.1.23
|
||||
PKG_VERSION:=1.3.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
|
||||
@ -17,7 +17,7 @@ PKG_SOURCE_URL:= \
|
||||
http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
|
||||
ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
|
||||
ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=4ce09b1dce09b6b9398af0daae9adf63
|
||||
PKG_MD5SUM:=db4a45a17104f10f3ee599d88267c9e5
|
||||
|
||||
PKG_BUILD_DEPENDS:=zlib
|
||||
|
||||
@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/cups
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+zlib
|
||||
DEPENDS:=+zlib +libpthread +libpng +libjpeg
|
||||
TITLE:=Common UNIX Printing System
|
||||
URL:=http://www.cups.org/
|
||||
SUBMENU:=printing
|
||||
@ -59,6 +59,7 @@ define Build/Configure
|
||||
--disable-ssl \
|
||||
--disable-slp, \
|
||||
UNAME="Linux" \
|
||||
LIBS="-L$(STAGING_DIR)/usr/lib -lz -lpng -ljpeg" \
|
||||
)
|
||||
endef
|
||||
|
||||
@ -82,7 +83,7 @@ define Package/cups/install
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||
rm -f $(1)/usr/bin/cups-config
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/share/cups/templates
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
|
||||
@ -104,7 +105,7 @@ define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/cups $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,cups))
|
||||
|
@ -1,11 +1,14 @@
|
||||
--- cups-1.1.23.old/Makefile 2005-01-03 20:29:44.000000000 +0100
|
||||
+++ cups-1.1.23/Makefile 2005-03-23 20:15:24.000000000 +0100
|
||||
@@ -28,7 +28,7 @@
|
||||
diff -urN cups-1.3.7/Makefile cups-1.3.7.new/Makefile
|
||||
--- cups-1.3.7/Makefile 2008-02-16 00:26:51.000000000 +0100
|
||||
+++ cups-1.3.7.new/Makefile 2008-07-13 16:46:01.000000000 +0200
|
||||
@@ -19,8 +19,8 @@
|
||||
# Directories to make...
|
||||
#
|
||||
|
||||
-DIRS = cups backend berkeley cgi-bin filter man pdftops \
|
||||
+DIRS = cups backend berkeley cgi-bin \
|
||||
scheduler systemv
|
||||
-DIRS = cups backend berkeley cgi-bin filter locale man monitor \
|
||||
- notifier $(PDFTOPS) scheduler systemv test \
|
||||
+DIRS = cups backend berkeley cgi-bin filter monitor \
|
||||
+ notifier scheduler systemv \
|
||||
$(PHPDIR) \
|
||||
conf data doc $(FONTS) ppd templates
|
||||
|
||||
#
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -urN cups-1.1.23.old/Makedefs.in cups-1.1.23/Makedefs.in
|
||||
--- cups-1.1.23.old/Makedefs.in 2005-01-03 20:29:44.000000000 +0100
|
||||
+++ cups-1.1.23/Makedefs.in 2005-03-23 20:28:06.000000000 +0100
|
||||
@@ -47,7 +47,7 @@
|
||||
# Installation programs...
|
||||
#
|
||||
|
||||
-INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755 -s
|
||||
+INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755
|
||||
INSTALL_DATA = $(INSTALL) -m 644
|
||||
INSTALL_DIR = $(INSTALL) -d
|
||||
INSTALL_LIB = $(LIBTOOL) $(INSTALL) -m 755
|
@ -1,20 +0,0 @@
|
||||
--- cups-1.1.23/doc/index.html.orig 2005-01-03 21:13:59.000000000 +0100
|
||||
+++ cups-1.1.23/doc/index.html 2005-03-23 22:18:15.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
<AREA SHAPE="RECT" COORDS="12,10,50,20" HREF="http://www.easysw.com" ALT="Easy Software Products Home Page">
|
||||
<AREA SHAPE="RECT" COORDS="82,10,196,20" HREF="/admin" ALT="Do Administration Tasks">
|
||||
<AREA SHAPE="RECT" COORDS="216,10,280,20" HREF="/classes" ALT="Manage Printer Classes Status">
|
||||
- <AREA SHAPE="RECT" COORDS="300,10,336,20" HREF="/documentation.html" ALT="On-Line Help">
|
||||
+ <AREA SHAPE="RECT" COORDS="300,10,336,20" HREF="http://www.cups.org/documentation.php" ALT="On-Line Help">
|
||||
<AREA SHAPE="RECT" COORDS="356,10,394,20" HREF="/jobs" ALT="Manage Jobs">
|
||||
<AREA SHAPE="RECT" COORDS="414,10,476,20" HREF="/printers" ALT="Manage Printers">
|
||||
<AREA SHAPE="RECT" COORDS="496,10,568,20" HREF="http://www.cups.org" ALT="Download the Current CUPS Software">
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
<H1><A HREF="admin">Do Administration Tasks</A></H1>
|
||||
<H1><A HREF="classes">Manage Printer Classes</A></H1>
|
||||
-<H1><A HREF="documentation.html">On-Line Help</A></H1>
|
||||
+<H1><A HREF="http://www.cups.org/documentation.php">On-Line Help</A></H1>
|
||||
<H1><A HREF="jobs">Manage Jobs</A></H1>
|
||||
<H1><A HREF="printers">Manage Printers</A></H1>
|
||||
<H1><A HREF="http://www.cups.org">Download the Current CUPS Software</A></H1>
|
@ -1,11 +1,12 @@
|
||||
--- cups-1.1.23/systemv/Makefile.old Sun Oct 15 03:33:34 2006
|
||||
+++ cups-1.1.23/systemv/Makefile Sun Oct 15 03:33:55 2006
|
||||
@@ -77,7 +77,7 @@
|
||||
diff -urN cups-1.3.7/systemv/Makefile cups-1.3.7.new/systemv/Makefile
|
||||
--- cups-1.3.7/systemv/Makefile 2007-07-11 23:46:42.000000000 +0200
|
||||
+++ cups-1.3.7.new/systemv/Makefile 2008-07-13 16:15:46.000000000 +0200
|
||||
@@ -70,7 +70,7 @@
|
||||
$(INSTALL_BIN) lp $(BINDIR)
|
||||
$(INSTALL_BIN) lpoptions $(BINDIR)
|
||||
$(INSTALL_BIN) lpstat $(BINDIR)
|
||||
- -$(INSTALL_BIN) -m 4755 -o $(CUPS_USER) -g $(CUPS_GROUP) lppasswd $(BINDIR)
|
||||
+ -$(INSTALL_BIN) lppasswd $(BINDIR)
|
||||
if test ! -x $(BINDIR)/lppasswd; then \
|
||||
chmod 755 $(BINDIR)/lppasswd; \
|
||||
fi
|
||||
- $(INSTALL_BIN) -m 4755 -o root lppasswd $(BINDIR) || $(INSTALL_BIN) lppasswd $(BINDIR)
|
||||
+ $(INSTALL_BIN) lppasswd $(BINDIR)
|
||||
if test "x$(SYMROOT)" != "x"; then \
|
||||
$(INSTALL_DIR) $(SYMROOT); \
|
||||
for file in $(TARGETS); do \
|
||||
|
@ -1,11 +1,12 @@
|
||||
--- cups.dev/configure Sun Oct 15 15:22:17 2006
|
||||
+++ cups.old/configure Sun Oct 15 15:21:40 2006
|
||||
@@ -1300,7 +1300,7 @@
|
||||
diff -urN cups-1.3.7/configure cups-1.3.7.new/configure
|
||||
--- cups-1.3.7/configure 2008-04-01 23:59:43.000000000 +0200
|
||||
+++ cups-1.3.7.new/configure 2008-07-13 16:17:08.000000000 +0200
|
||||
@@ -1920,7 +1920,7 @@
|
||||
|
||||
|
||||
|
||||
-uname=`uname`
|
||||
+uname=${UNAME:-`uname`}
|
||||
uversion=`uname -r | sed -e '1,$s/[^0-9]//g'`
|
||||
case "$uname" in
|
||||
GNU* | GNU/*)
|
||||
uversion=`uname -r | sed -e '1,$s/^[^0-9]*\([0-9]*\)\.\([0-9]*\).*/\1\2/'`
|
||||
uarch=`uname -m`
|
||||
|
||||
|
66
net/cups/patches/150-64bit_host_fix.patch
Normal file
66
net/cups/patches/150-64bit_host_fix.patch
Normal file
@ -0,0 +1,66 @@
|
||||
--- cups-1.3.7/cups-config.in 2007-07-11 23:46:42.000000000 +0200
|
||||
+++ cups-1.3.7.new/cups-config.in 2008-07-13 17:17:00.000000000 +0200
|
||||
@@ -53,7 +53,7 @@
|
||||
CFLAGS="$CFLAGS -I$includedir"
|
||||
fi
|
||||
|
||||
- if test $libdir != /usr/lib -a $libdir != /usr/lib32 -a $libdir != /usr/lib64; then
|
||||
+ if test $libdir != /usr/lib -a $libdir != /usr/lib -a $libdir != /usr/lib; then
|
||||
LDFLAGS="$LDFLAGS -L$libdir"
|
||||
fi
|
||||
fi
|
||||
diff -urN cups-1.3.7/config-scripts/cups-3264.m4 cups-1.3.7.new/config-scripts/cups-3264.m4
|
||||
--- cups-1.3.7/config-scripts/cups-3264.m4 2007-07-11 23:46:42.000000000 +0200
|
||||
+++ cups-1.3.7.new/config-scripts/cups-3264.m4 2008-07-13 17:21:36.000000000 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
|
||||
LIB64DIR="$exec_prefix/lib"
|
||||
if test -d /usr/lib64; then
|
||||
- LIB64DIR="${LIB64DIR}64"
|
||||
+ LIB64DIR="${LIB64DIR}"
|
||||
fi
|
||||
UNINSTALL64="uninstall64bit"
|
||||
fi
|
||||
diff -urN cups-1.3.7/config-scripts/cups-directories.m4 cups-1.3.7.new/config-scripts/cups-directories.m4
|
||||
--- cups-1.3.7/config-scripts/cups-directories.m4 2007-09-18 22:39:31.000000000 +0200
|
||||
+++ cups-1.3.7.new/config-scripts/cups-directories.m4 2008-07-13 17:21:51.000000000 +0200
|
||||
@@ -107,7 +107,7 @@
|
||||
;;
|
||||
Linux*)
|
||||
if test -d /usr/lib64; then
|
||||
- libdir="$exec_prefix/lib64"
|
||||
+ libdir="$exec_prefix/lib"
|
||||
fi
|
||||
;;
|
||||
HP-UX*)
|
||||
--- cups-1.3.7/configure 2008-04-01 23:59:43.000000000 +0200
|
||||
+++ cups-1.3.7.new/configure 2008-07-13 17:20:19.000000000 +0200
|
||||
@@ -9217,7 +9217,7 @@
|
||||
;;
|
||||
Linux*)
|
||||
if test -d /usr/lib64; then
|
||||
- libdir="$exec_prefix/lib64"
|
||||
+ libdir="$exec_prefix/lib"
|
||||
fi
|
||||
;;
|
||||
HP-UX*)
|
||||
@@ -9761,9 +9761,6 @@
|
||||
LIB32CUPS="32bit/libcups.so.2"
|
||||
LIB32CUPSIMAGE="32bit/libcupsimage.so.2"
|
||||
LIB32DIR="$exec_prefix/lib"
|
||||
- if test -d /usr/lib32; then
|
||||
- LIB32DIR="${LIB32DIR}32"
|
||||
- fi
|
||||
UNINSTALL32="uninstall32bit"
|
||||
fi
|
||||
|
||||
@@ -9773,9 +9770,6 @@
|
||||
LIB64CUPS="64bit/libcups.so.2"
|
||||
LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
|
||||
LIB64DIR="$exec_prefix/lib"
|
||||
- if test -d /usr/lib64; then
|
||||
- LIB64DIR="${LIB64DIR}64"
|
||||
- fi
|
||||
UNINSTALL64="uninstall64bit"
|
||||
fi
|
||||
;;
|
Loading…
x
Reference in New Issue
Block a user