[packages/ctorrent] allow negative integers ... should fix random "error, initial meta info failed"
taken from this bugreport: http://sourceforge.net/tracker/?func=detail&aid=3159066&group_id=202532&atid=981959 thanks Norbert Zagyi <znorbi@znorbi.net> for the hint git-svn-id: svn://svn.openwrt.org/openwrt/packages@35041 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fb2956f426
commit
9796959bf1
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ctorrent
|
||||
PKG_VERSION:=dnh3.3.2
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/dtorrent \
|
||||
|
13
net/ctorrent/patches/100-negative-ints.patch
Normal file
13
net/ctorrent/patches/100-negative-ints.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/bencode.cpp
|
||||
+++ b/bencode.cpp
|
||||
@@ -44,6 +44,10 @@ size_t buf_long(const char *b,size_t len
|
||||
p++; len--;
|
||||
}
|
||||
|
||||
+ if( *p == '-'){
|
||||
+ p++; len--;
|
||||
+ }
|
||||
+
|
||||
for(psave = p; len && isdigit(*p); p++,len--) ;
|
||||
|
||||
if(!len || MAX_INT_SIZ < (p - psave) || *p != endchar) return 0;
|
Loading…
x
Reference in New Issue
Block a user