[package] update openldap to 2.4.16 (#5129)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15906 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d6f57ff8dc
commit
9a6bf8adf5
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openldap
|
||||
PKG_VERSION:=2.2.29
|
||||
PKG_VERSION:=2.4.16
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
@ -16,7 +16,7 @@ PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
|
||||
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
|
||||
ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
|
||||
ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
|
||||
PKG_MD5SUM:=6c4c72a1336aa45b463e738034c078d6
|
||||
PKG_MD5SUM:=ed5b86e9d2b372d10edfe3bb59fee165
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
@ -101,8 +101,6 @@ define Package/libopenldap/install
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/share/openldap
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/openldap/* $(1)/usr/share/openldap/
|
||||
endef
|
||||
|
||||
define Package/openldap-utils/install
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -ruN openldap-2.2.26-orig/libraries/liblunicode/Makefile.in openldap-2.2.26-1/libraries/liblunicode/Makefile.in
|
||||
--- openldap-2.2.26-orig/libraries/liblunicode/Makefile.in 2005-01-20 18:01:03.000000000 +0100
|
||||
+++ openldap-2.2.26-1/libraries/liblunicode/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -29,8 +29,8 @@
|
||||
LDAP_INCDIR= ../../include
|
||||
LDAP_LIBDIR= ../../libraries
|
||||
|
||||
-ucgendat: $(XLIBS) ucgendat.o
|
||||
- $(LTLINK) -o $@ ucgendat.o $(LIBS)
|
||||
+ucgendat:
|
||||
+ $(HOSTCC) -I$(LDAP_INCDIR) -o $@ ./ucdata/ucgendat.c
|
||||
./ucgendat $(srcdir)/UnicodeData.txt -x $(srcdir)/CompositionExclusions.txt
|
||||
|
||||
DATFILES = case.dat cmbcl.dat comp.dat ctype.dat decomp.dat num.dat kdecomp.dat
|
||||
diff -ur openldap.old/libraries/liblunicode/ucdata/ucgendat.c openldap.dev/libraries/liblunicode/ucdata/ucgendat.c
|
||||
--- openldap.old/libraries/liblunicode/ucdata/ucgendat.c 2005-01-20 18:01:03.000000000 +0100
|
||||
+++ openldap.dev/libraries/liblunicode/ucdata/ucgendat.c 2007-04-01 20:35:57.000000000 +0200
|
||||
@@ -1611,7 +1611,7 @@
|
||||
FILE *in;
|
||||
char *prog, *opath;
|
||||
|
||||
- prog = lutil_progname( "ucgendat", argc, argv );
|
||||
+ prog = argv[0];
|
||||
|
||||
opath = 0;
|
||||
in = stdin;
|
@ -1,36 +1,24 @@
|
||||
diff -ruN openldap-2.2.26-orig/clients/tools/Makefile.in openldap-2.2.26-1/clients/tools/Makefile.in
|
||||
--- openldap-2.2.26-orig/clients/tools/Makefile.in 2005-01-20 18:00:55.000000000 +0100
|
||||
+++ openldap-2.2.26-1/clients/tools/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -98,7 +98,7 @@
|
||||
diff -ruN openldap-2.4.16-orig/clients/tools/Makefile.in openldap-2.4.16/clients/tools/Makefile.in
|
||||
--- openldap-2.4.16-orig/clients/tools/Makefile.in
|
||||
+++ openldap-2.4.16/clients/tools/Makefile.in
|
||||
@@ -120,7 +120,7 @@
|
||||
-$(MKDIR) $(DESTDIR)$(bindir)
|
||||
@( \
|
||||
for prg in $(PROGRAMS); do \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT) \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 $$prg$(EXEEXT) \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT) \
|
||||
$(DESTDIR)$(bindir); \
|
||||
done \
|
||||
)
|
||||
diff -ruN openldap-2.2.26-orig/servers/slapd/Makefile.in openldap-2.2.26-1/servers/slapd/Makefile.in
|
||||
--- openldap-2.2.26-orig/servers/slapd/Makefile.in 2005-01-20 18:01:05.000000000 +0100
|
||||
+++ openldap-2.2.26-1/servers/slapd/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -355,7 +355,7 @@
|
||||
diff -ruN openldap-2.4.16-orig/servers/slapd/Makefile.in openldap-2.4.16-1/servers/slapd/Makefile.in
|
||||
--- openldap-2.4.16-orig/servers/slapd/Makefile.in
|
||||
+++ openldap-2.4.16/servers/slapd/Makefile.in
|
||||
@@ -375,7 +375,7 @@
|
||||
install-slapd: FORCE
|
||||
-$(MKDIR) $(DESTDIR)$(libexecdir)
|
||||
-$(MKDIR) $(DESTDIR)$(localstatedir)/run
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 \
|
||||
slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
|
||||
@for i in $(SUBDIRS); do \
|
||||
if test -d $$i -a -f $$i/Makefile ; then \
|
||||
diff -ruN openldap-2.2.26-orig/servers/slurpd/Makefile.in openldap-2.2.26-1/servers/slurpd/Makefile.in
|
||||
--- openldap-2.2.26-orig/servers/slurpd/Makefile.in 2005-01-20 18:01:19.000000000 +0100
|
||||
+++ openldap-2.2.26-1/servers/slurpd/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -60,7 +60,7 @@
|
||||
@-$(INSTALL) -m 700 -d $(DESTDIR)$(localstatedir)/openldap-slurp
|
||||
@( \
|
||||
for prg in $(PROGRAMS); do \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT) \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT) \
|
||||
$(DESTDIR)$(libexecdir); \
|
||||
done \
|
||||
)
|
||||
if test -d $$i && test -f $$i/Makefile ; then \
|
||||
|
Loading…
x
Reference in New Issue
Block a user