[Package] lcd4linux: update to r1159. Fixes #8897

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28313 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jmccrohan 2011-09-27 23:43:35 +00:00
parent 883cc2b222
commit 9b2795b461
2 changed files with 12 additions and 1 deletions

View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lcd4linux
PKG_REV:=1158
PKG_REV:=1159
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=1

View File

@ -0,0 +1,11 @@
--- a/plugin_netinfo.c
+++ b/plugin_netinfo.c
@@ -264,7 +264,7 @@
sin = get_netmask(arg1);
if (NULL != sin) {
logval = (long double) (get_netmask(arg1)->sin_addr.s_addr);
- netlen = (int) rint(log2l(logval) / log2l(2.0));
+ netlen = (int) rint(log2f(logval) / log2f(2.0));
qprintf(value, sizeof(value), "/%d", netlen);
} else {
qprintf(value, sizeof(value), "/?");