[Package] lcd4linux: update to r1159. Fixes #8897
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28313 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
883cc2b222
commit
9b2795b461
@ -8,7 +8,7 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lcd4linux
|
PKG_NAME:=lcd4linux
|
||||||
PKG_REV:=1158
|
PKG_REV:=1159
|
||||||
PKG_VERSION:=r$(PKG_REV)
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
11
utils/lcd4linux/patches/110-uclibc-logarithm-fix.patch
Normal file
11
utils/lcd4linux/patches/110-uclibc-logarithm-fix.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/plugin_netinfo.c
|
||||||
|
+++ b/plugin_netinfo.c
|
||||||
|
@@ -264,7 +264,7 @@
|
||||||
|
sin = get_netmask(arg1);
|
||||||
|
if (NULL != sin) {
|
||||||
|
logval = (long double) (get_netmask(arg1)->sin_addr.s_addr);
|
||||||
|
- netlen = (int) rint(log2l(logval) / log2l(2.0));
|
||||||
|
+ netlen = (int) rint(log2f(logval) / log2f(2.0));
|
||||||
|
qprintf(value, sizeof(value), "/%d", netlen);
|
||||||
|
} else {
|
||||||
|
qprintf(value, sizeof(value), "/?");
|
Loading…
x
Reference in New Issue
Block a user