[packages] icmptx: update to v0.2, switched to git for source retrieval

git-svn-id: svn://svn.openwrt.org/openwrt/packages@15461 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-04-27 22:59:50 +00:00
parent df0aeeab8a
commit 9c7603b355
2 changed files with 28 additions and 25 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,29 +8,32 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=icmptx
PKG_VERSION:=0.01
PKG_VERSION:=0.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thomer.com/icmptx/
PKG_MD5SUM:=f83d1d7789a1b100abcc00d1a56ee95d
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/jakkarth/icmptx.git
PKG_SOURCE_VERSION:=33e0b826f99df290ee792f6aa587af273d674309
include $(INCLUDE_DIR)/package.mk
define Package/icmptx
SECTION:=net
CATEGORY:=Network
TITLE:=allows you to pass IP packets via ICMP queries
URL:=http://thomer.com/icmptx/
TITLE:=IP-over-ICMP tunnel
URL:=http://github.com/jakkarth/icmptx
endef
define Build/Configure
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)"
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
OPT_FLAGS="$(TARGET_CFLAGS)" \
icmptx
endef
define Package/icmptx/install

View File

@ -1,24 +1,24 @@
diff -urN icmptx-0.01/Makefile icmptx-0.01.new/Makefile
--- icmptx-0.01/Makefile 2005-12-20 09:09:34.000000000 +0100
+++ icmptx-0.01.new/Makefile 2007-01-21 16:48:36.000000000 +0100
@@ -3,16 +3,16 @@
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,17 @@
-flags=-g3 -Wall -ansi -pedantic -D_GNU_SOURCE
+OPT_FLAGS=-g3
+
+flags=$(OPT_FLAGS) -Wall -ansi -pedantic -D_GNU_SOURCE
all: icmptx
icmptx: it.o icmptx.o tun_dev.o
- gcc $(flags) -o icmptx icmptx.o it.o tun_dev.o
+ $(CC) -o icmptx icmptx.o it.o tun_dev.o
icmptx: it.o icmptx.c tun_dev.o
- gcc $(flags) -o icmptx icmptx.c it.o tun_dev.o
+ $(CC) $(flags) -o icmptx icmptx.c it.o tun_dev.o
it.o: it.c
it.o: it.c tun_dev.h
- gcc $(flags) -c it.c
+ $(CC) -c it.c
icmptx.o: icmptx.c
- gcc $(flags) -c icmptx.c
+ $(CC) -c icmptx.c
+ $(CC) $(flags) -c it.c
tun_dev.o: tun_dev.c
- gcc $(flags) -c tun_dev.c
+ $(CC) -c tun_dev.c
+ $(CC) $(flags) -c tun_dev.c
clean:
rm -f tun_dev.o it.o icmptx.o icmptx
rm -f tun_dev.o it.o icmptx