packages: Update bluez-hcidump, bluez-libs, and bluez-utils. Closes #3036, thanks michu.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10231 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
agb 2008-01-21 23:25:05 +00:00
parent 20bcb1d4c1
commit a0164474f4
5 changed files with 57 additions and 26 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez-libs
PKG_VERSION:=2.24
PKG_VERSION:=3.24
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
PKG_MD5SUM:=d0ba50e251ae1e7f2c09024facde8e40
PKG_MD5SUM:=3af3dfa6ff01715e91bdc985d71ee21e
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez-hcidump
PKG_VERSION:=1.30
PKG_VERSION:=1.40
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
PKG_MD5SUM:=46ac502055ccab1fd6f11cab7187e9c7
PKG_MD5SUM:=c5793b79c3e7fea3a367c08c26c8e23c
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install

View File

@ -1,4 +1,4 @@
#
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez-utils
PKG_VERSION:=2.24
PKG_RELEASE:=3
PKG_VERSION:=3.24
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
PKG_MD5SUM:=5f5488ff3d31bdb9cd36b7991fe68408
PKG_MD5SUM:=cc3582da827bc4c468147af1afaa5aff
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@ -24,35 +24,27 @@ include $(INCLUDE_DIR)/package.mk
define Package/bluez-utils
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+bluez-libs +libpthread
DEPENDS:=+bluez-libs +libpthread +dbus
TITLE:=Bluetooth utilities
URL:=http://www.bluez.org/
endef
define Package/bluez-utils/conffiles
/etc/bluetooth/givepin
/etc/bluetooth/hcid.conf
/etc/bluetooth/rfcomm.conf
/etc/config/bluetooth
endef
define Build/Configure
$(call Build/Configure/Default, \
--disable-dbus \
--disable-fuse \
--disable-obex \
--disable-alsa \
--disable-cups \
--disable-pcmcia \
--disable-initscripts \
--disable-bccmd \
--disable-avctrl \
--disable-hid2hci \
--disable-dfutool \
--disable-bcm203x \
--disable-bluepin \
--enable-debug \
--enable-usb \
--enable-input \
--enable-serial \
--enable-network \
--with-bluez="$(STAGING_DIR)/usr/include" \
--with-usb=no \
--with-usb=yes \
)
endef
@ -62,17 +54,21 @@ define Build/Compile
all install
endef
#copy bluetooth.conf nach /etc/dbus-1/system.d/
define Package/bluez-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/../daemon/passkey-agent $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/bluetooth
$(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
$(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
install -m0700 ./files/givepin $(1)/etc/bluetooth/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
$(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/../daemon/bluetooth.conf $(1)/etc/dbus-1/system.d/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
endef

View File

@ -1,7 +1,8 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2007 OpenWrt.org
START=60
#start after dbus (60)
START=62
append_bool() {
local section="$1"
@ -107,6 +108,16 @@ start() {
config_foreach rfcomm_config rfcomm
config_foreach dund_config dund
config_foreach pand_config pand
#start passkey agent
passkey-agent --default 1234&
hcitool hci0 up
rfcomm release 0
#set up serial conenction
#rfcomm connect /dev/rfcomm0 00:1D:E9:5B:92:8D&
}
stop() {

View File

@ -0,0 +1,24 @@
diff -urN bluez-utils-3.24.orig/input/device.c bluez-utils-3.24/input/device.c
--- bluez-utils-3.24/input/device.orig 2007-12-08 20:04:42.000000000 +0100
+++ bluez-utils-3.24/input/device.c 2008-01-16 09:20:41.000000000 +0100
@@ -25,6 +25,8 @@
#include <config.h>
#endif
+#define ENOKEY 161 /* Required key not available */
+
#include <stdlib.h>
#include <errno.h>
#include <fcntl.h>
diff -urN bluez-utils-3.24.orig/input/storage.c bluez-utils-3.24/input/storage.c
--- bluez-utils-3.24/input/storage.orig 2007-10-05 09:17:06.000000000 +0200
+++ bluez-utils-3.24/input/storage.c 2008-01-16 09:26:23.000000000 +0100
@@ -25,6 +25,8 @@
#include <config.h>
#endif
+#define ENOKEY 161 /* Required key not available */
+
#include <stdio.h>
#include <errno.h>
#include <ctype.h>