[packages] asterisk-1.8.x: upgrade to 1.8.10.0

git-svn-id: svn://svn.openwrt.org/openwrt/packages@30891 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
zandbelt 2012-03-11 19:25:48 +00:00
parent 71637c9981
commit a2105ef51a
5 changed files with 19 additions and 40 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=asterisk18
PKG_VERSION:=1.8.8.0
PKG_VERSION:=1.8.10.0
PKG_RELEASE:=1
PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk/releases/
PKG_MD5SUM:=7a32b35e1da0019c781b4ae10b599f61
PKG_MD5SUM:=7b0f4c40ff21ffab6d777e4fa16ec724
PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)

View File

@ -64,3 +64,14 @@
<support_level>extended</support_level>
***/
--- a/res/res_pktccops.c
+++ b/res/res_pktccops.c
@@ -31,7 +31,7 @@
*/
/*** MODULEINFO
- <defaultenabled>no</defaultenabled>
+ <defaultenabled>yes</defaultenabled>
<support_level>extended</support_level>
***/

View File

@ -1,20 +0,0 @@
--- a/main/utils.c
+++ b/main/utils.c
@@ -1666,7 +1666,7 @@ ast_string_field __ast_string_field_allo
}
result = (*pool_head)->base + (*pool_head)->used;
-#ifdef __sparc__
+#if defined(__sparc__) || defined(__arm__)
/* SPARC requires that the allocation field be aligned. */
if ((long) result % sizeof(ast_string_field_allocation)) {
result++;
@@ -1747,7 +1747,7 @@ void __ast_string_field_ptr_build_va(str
}
} else {
target = (*pool_head)->base + (*pool_head)->used + sizeof(ast_string_field_allocation);
-#ifdef __sparc__
+#if defined(__sparc__) || defined(__arm__)
if ((long) target % sizeof(ast_string_field_allocation)) {
target++;
space--;

View File

@ -1,12 +0,0 @@
--- a/channels/chan_gtalk.c
+++ b/channels/chan_gtalk.c
@@ -481,7 +481,8 @@ static int gtalk_ringing_ack(void *data,
break;
}
if (!strcasecmp(name, "error") &&
- (redirect = iks_find_cdata(traversenodes, "redirect")) &&
+ ( (redirect = iks_find_cdata(traversenodes, "redirect")) ||
+ (redirect = iks_find_cdata(traversenodes, "sta:redirect")) ) &&
(redirect = strstr(redirect, "xmpp:"))) {
redirect += 5;
ast_log(LOG_DEBUG, "redirect %s\n", redirect);

View File

@ -1,11 +1,11 @@
--- a/configure
+++ b/configure
@@ -24234,7 +24234,7 @@ $as_echo "$ac_try_echo") >&5
@@ -16784,7 +16784,7 @@ if ac_fn_c_try_link "$LINENO"; then :
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
cat >>confdefs.h <<\_ACEOF
-#define HAVE_RES_NINIT 1
+//#define HAVE_RES_NINIT 1
_ACEOF
-$as_echo "#define HAVE_RES_NINIT 1" >>confdefs.h
+$as_echo "//#define HAVE_RES_NINIT 1" >>confdefs.h
{ $as_echo "$as_me:$LINENO: checking for library containing res_9_ndestroy" >&5
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing res_9_ndestroy" >&5
$as_echo_n "checking for library containing res_9_ndestroy... " >&6; }