[packages] iperf: update to 2.0.5

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22164 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2010-07-13 09:11:08 +00:00
parent 18f21b45f9
commit a42227213d
2 changed files with 5 additions and 9 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007 OpenWrt.org
# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=2.0.4
PKG_RELEASE:=2
PKG_VERSION:=2.0.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=8c5bc14cc2ea55f18f22afe3c23e3dcb
PKG_MD5SUM:=44b5536b67719f4250faed632a3cd016
include $(INCLUDE_DIR)/package.mk
@ -31,7 +31,6 @@ define Package/iperf/Default/description
characteristics.
endef
define Package/iperf
$(call Package/iperf/Default)
TITLE+= (with single thread support)
@ -42,7 +41,6 @@ $(call Package/iperf/Default/description)
This package is built with single thread support.
endef
define Package/iperf-mt
$(call Package/iperf/Default)
DEPENDS+= +libpthread
@ -54,7 +52,6 @@ $(call Package/iperf/Default/description)
This package is built with multithread support.
endef
define Build/Template
$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
@ -80,7 +77,6 @@ CONFIGURE_VARS += \
CXX="g++-uc" \
CXXFLAGS="$$$$CXX_CFLAGS -fno-rtti" \
ifneq ($(SDK)$(CONFIG_PACKAGE_iperf),)
define Build/singlethread
$(call Build/Template,iperf,singlethread, \

View File

@ -1,6 +1,6 @@
--- a/src/Reporter.c
+++ b/src/Reporter.c
@@ -309,6 +309,11 @@ ReportHeader* InitReport( thread_Setting
@@ -308,6 +308,11 @@ ReportHeader* InitReport( thread_Setting
#else
// set start time
gettimeofday( &(reporthdr->report.startTime), NULL );