[Packages] net/rtorrent:

* Update to 0.7.9
 * Fix linking against uClibc++

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10883 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2008-04-20 10:52:43 +00:00
parent f7d1c1825d
commit a45f974064
2 changed files with 27 additions and 5 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007 OpenWrt.org
# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtorrent
PKG_VERSION:=0.7.7
PKG_VERSION:=0.7.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
PKG_MD5SUM:=430ac264605fc13be6a5d15180e5c957
PKG_MD5SUM:=136202fdd540a92aafbcee29f849d228
PKG_FIXUP = libtool
@ -46,10 +46,13 @@ CONFIGURE_VARS += \
CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
LIBS="-lm" \
define Package/rtorrent/install
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all
endef
define Package/rtorrent/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rtorrent $(1)/usr/bin/
endef
$(eval $(call BuildPackage,rtorrent))

View File

@ -0,0 +1,19 @@
Index: rtorrent-0.7.9/configure
===================================================================
--- rtorrent-0.7.9.orig/configure 2008-04-20 12:43:14.000000000 +0200
+++ rtorrent-0.7.9/configure 2008-04-20 12:43:14.000000000 +0200
@@ -20227,11 +20227,11 @@
echo $ECHO_N "checking for execinfo.h... $ECHO_C" >&6; }
if test "$cross_compiling" = yes; then
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+ { { echo "$as_me:$LINENO: warning: cannot run test program while cross compiling
See \`config.log' for more details." >&5
-echo "$as_me: error: cannot run test program while cross compiling
+echo "$as_me: warning: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#include <execinfo.h>