[packages] polarssl: update to v0.14.0 (#8234)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23988 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cfb3d5e379
commit
a6440620b5
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=polarssl
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.14.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
|
||||
PKG_SOURCE_URL:=http://polarssl.org/code/releases/
|
||||
PKG_MD5SUM:=08bc85a19bbe65493076b9968b421e80
|
||||
PKG_MD5SUM:=669a0582a27a5ec381542f0c67e966b7
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -pruN polarssl-0.12.0.orig/library/Makefile polarssl-0.12.0/library/Makefile
|
||||
--- polarssl-0.12.0.orig/library/Makefile 2009-03-28 18:53:03.000000000 +0100
|
||||
+++ polarssl-0.12.0/library/Makefile 2009-08-05 17:53:55.000000000 +0200
|
||||
--- a/library/Makefile
|
||||
+++ b/library/Makefile
|
||||
@@ -29,7 +29,7 @@ OBJS= aes.o arc4.o base64.o \
|
||||
|
||||
.SILENT:
|
||||
|
@ -1,30 +1,20 @@
|
||||
diff -pruN polarssl-0.12.0.orig/Makefile polarssl-0.12.0/Makefile
|
||||
--- polarssl-0.12.0.orig/Makefile 2009-07-28 22:29:34.000000000 +0200
|
||||
+++ polarssl-0.12.0/Makefile 2009-08-05 17:52:14.000000000 +0200
|
||||
@@ -5,9 +5,9 @@ PREFIX=polarssl_
|
||||
.SILENT:
|
||||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -7,7 +7,7 @@ PREFIX=polarssl_
|
||||
all:
|
||||
- cd library && make all && cd ..
|
||||
- cd programs && make all && cd ..
|
||||
- cd tests && make all && cd ..
|
||||
+ cd library && $(MAKE) all && cd ..
|
||||
+ cd programs && $(MAKE) all && cd ..
|
||||
cd library && $(MAKE) all && cd ..
|
||||
cd programs && $(MAKE) all && cd ..
|
||||
- cd tests && $(MAKE) all && cd ..
|
||||
+ #cd tests && $(MAKE) all && cd ..
|
||||
|
||||
install:
|
||||
mkdir -p $(DESTDIR)/include/polarssl
|
||||
@@ -26,9 +26,9 @@ install:
|
||||
done
|
||||
|
||||
@@ -28,7 +28,7 @@ install:
|
||||
clean:
|
||||
- cd library && make clean && cd ..
|
||||
- cd programs && make clean && cd ..
|
||||
- cd tests && make clean && cd ..
|
||||
+ cd library && $(MAKE) clean && cd ..
|
||||
+ cd programs && $(MAKE) clean && cd ..
|
||||
cd library && $(MAKE) clean && cd ..
|
||||
cd programs && $(MAKE) clean && cd ..
|
||||
- cd tests && $(MAKE) clean && cd ..
|
||||
+ #cd tests && $(MAKE) clean && cd ..
|
||||
|
||||
check:
|
||||
- ( cd tests && make check )
|
||||
+ ( cd tests && $(MAKE) check )
|
||||
( cd tests && $(MAKE) check )
|
||||
|
Loading…
x
Reference in New Issue
Block a user