[packages] transmission: use internal miniupnpc, update to 2.83
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40843 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
26991441ef
commit
a896e9b47e
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2009-2013 OpenWrt.org
|
# Copyright (C) 2009-2014 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=transmission
|
PKG_NAME:=transmission
|
||||||
PKG_VERSION:=2.82
|
PKG_VERSION:=2.83
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
|
PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
|
||||||
PKG_MD5SUM:=a5ef870c0410b12d10449c2d36fa4661
|
PKG_MD5SUM:=4620cfbfefee2ce55a6fa12c3ec330a7
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
@ -32,7 +32,7 @@ endef
|
|||||||
|
|
||||||
define Package/transmission-daemon
|
define Package/transmission-daemon
|
||||||
$(call Package/transmission/template)
|
$(call Package/transmission/template)
|
||||||
DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt +libminiupnpc
|
DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
|
||||||
MENU:=1
|
MENU:=1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -43,7 +43,7 @@ endef
|
|||||||
|
|
||||||
define Package/transmission-remote
|
define Package/transmission-remote
|
||||||
$(call Package/transmission/template)
|
$(call Package/transmission/template)
|
||||||
DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt +libminiupnpc
|
DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/transmission-web
|
define Package/transmission-web
|
||||||
|
11
net/transmission/patches/020-use-internal-miniupnp.patch
Normal file
11
net/transmission/patches/020-use-internal-miniupnp.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -251,7 +251,7 @@
|
||||||
|
AC_LINK_IFELSE(
|
||||||
|
[AC_LANG_PROGRAM([#include <miniupnpc/miniupnpc.h>],
|
||||||
|
[struct UPNPDev dev;])],
|
||||||
|
- [upnp_version="unknown"],
|
||||||
|
+ [upnp_version="none"],
|
||||||
|
[upnp_version="none"]
|
||||||
|
)
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user