packages/apr: force LFS support, fix apr_time_now function (closes: #9287)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28760 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8cfd00d0d2
commit
aa0823201c
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apr
|
||||
PKG_VERSION:=1.4.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
|
||||
@ -39,10 +39,11 @@ CONFIGURE_ARGS += \
|
||||
# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_sizeof_struct_iovec=1 \
|
||||
ac_cv_struct_rlimit=yes \
|
||||
apr_cv_process_shared_works=no \
|
||||
apr_cv_mutex_robust_shared=no \
|
||||
apr_cv_tcp_nodelay_with_cork=yes \
|
||||
ac_cv_struct_rlimit=yes \
|
||||
apr_cv_use_lfs64=yes \
|
||||
LDFLAGS="$$$$LDFLAGS -lpthread" \
|
||||
|
||||
define Build/InstallDev
|
||||
|
13
libs/apr/patches/101-fix_apr_time_now.patch
Normal file
13
libs/apr/patches/101-fix_apr_time_now.patch
Normal file
@ -0,0 +1,13 @@
|
||||
https://dev.openwrt.org/ticket/9287
|
||||
|
||||
--- a/time/unix/time.c
|
||||
+++ b/time/unix/time.c
|
||||
@@ -75,7 +75,7 @@ APR_DECLARE(apr_time_t) apr_time_now(voi
|
||||
{
|
||||
struct timeval tv;
|
||||
gettimeofday(&tv, NULL);
|
||||
- return tv.tv_sec * APR_USEC_PER_SEC + tv.tv_usec;
|
||||
+ return tv.tv_sec * (apr_time_t)APR_USEC_PER_SEC + (apr_time_t)tv.tv_usec;
|
||||
}
|
||||
|
||||
static void explode_time(apr_time_exp_t *xt, apr_time_t t,
|
Loading…
x
Reference in New Issue
Block a user