* Update 1.0.25 > 2.0.0
 * Cleanup Makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8678 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-09-07 20:27:27 +00:00
parent a28a8d47ec
commit ab4ee87174
4 changed files with 36 additions and 127 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,20 +9,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
PKG_VERSION:=1.0.25
PKG_RELEASE:=0
PKG_VERSION:=2.0.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/ \
ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/ \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
http://josefsson.org/gnutls/releases/
PKG_MD5SUM:=3585b5b204135e51e0efc9084b3e028b
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
ftp://ftp.gnutls.org/pub/gnutls/ \
ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
PKG_MD5SUM:=181b2ff554a83e6cf85505ea16699d39
include $(INCLUDE_DIR)/package.mk
@ -30,19 +26,21 @@ define Package/gnutls/Default
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GNU TLS
DESCRIPTION:=\
GnuTLS is a project that aims to develop a library which provides a \\\
secure layer, over a reliable transport layer. Currently the GnuTLS \\\
library implements the proposed standards by the IETF's TLS working \\\
group.
URL:=http://www.gnu.org/software/gnutls/
endef
define Package/gnutls/Default/description
GnuTLS is a project that aims to develop a library which provides a
secure layer, over a reliable transport layer. Currently the GnuTLS
library implements the proposed standards by the IETF's TLS working
group.
endef
define Package/gnutls-utils
$(call Package/gnutls/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libgnutls
DEPENDS:=+libgnutls +libgpg-error
TITLE+= (utilities)
DESCRIPTION+=\\\
\\\
@ -68,32 +66,23 @@ define Package/libgnutls-openssl
endef
define Build/Configure
(cd $(PKG_BUILD_DIR); touch \
configure.in \
acinclude.m4 \
aclocal.m4 \
Makefile.in \
config.h.in \
configure \
)
$(call Build/Configure/Default, \
--enable-shared \
--enable-static \
--disable-srp-authentication \
--disable-anon-authentication \
--disable-openpgp-authentication \
--with-included-opencdk=yes \
--with-included-libtasn1=yes \
--with-included-libcfg=yes \
--without-libopencdk-prefix \
--without-zlib \
--without-lzo \
)
$(call libtool_disable_rpath)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
$(MAKE) -C $(PKG_BUILD_DIR) all
$(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
endef
define Build/InstallDev
@ -107,8 +96,6 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
$(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
$(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
mkdir -p $(STAGING_DIR)/usr/share/aclocal
$(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
$(SED) "s,"prefix\=/usr",prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/gnutls-extra.pc
$(SED) "s,"exec_prefix\=/usr",exec_prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/gnutls-extra.pc
endef

View File

@ -0,0 +1,14 @@
Index: gnutls-2.0.0/Makefile.in
===================================================================
--- gnutls-2.0.0.orig/Makefile.in 2007-09-07 21:59:37.000000000 +0200
+++ gnutls-2.0.0/Makefile.in 2007-09-07 22:00:00.000000000 +0200
@@ -498,8 +498,7 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
-SUBDIRS = lgl gl includes lib libextra src $(am__append_1) doc tests \
- po
+SUBDIRS = lgl gl includes lib libextra src $(am__append_1)
ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lgl/m4
tag = $(PACKAGE)_`echo $(VERSION) | sed 's/\./_/g'`
all: config.h

View File

@ -1,68 +0,0 @@
diff -ruN gnutls-1.0.24-orig/configure gnutls-1.0.24-1/configure
--- gnutls-1.0.24-orig/configure 2005-01-18 19:31:03.000000000 +0100
+++ gnutls-1.0.24-1/configure 2005-03-15 23:23:12.000000000 +0100
@@ -3633,7 +3633,7 @@
if test x$opt_developer_mode = xyes; then
CFLAGS="${CFLAGS} -g -Wno-format-y2k -Wall -Wcast-align -W -Wpointer-arith -Wchar-subscripts -Wformat-security -Wmissing-braces -Winline -Wstrict-prototypes"
else
- CFLAGS="${CFLAGS} -O2 -finline-functions"
+ CFLAGS="${CFLAGS} -finline-functions"
fi
if test x$opt_dmalloc_mode = xyes; then
@@ -25004,8 +25004,8 @@
-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
-LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
+LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
+LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
CFLAGS="${CFLAGS} ${LIBGCRYPT_CFLAGS}"
@@ -25015,8 +25015,8 @@
SERV_LIBS="$LIBS $SERV_LIBS"
-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
-LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS -I${includedir}"
+LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
+LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS $LIBGNUTLS_CFLAGS"
diff -ruN gnutls-1.0.24-orig/configure.in gnutls-1.0.24-1/configure.in
--- gnutls-1.0.24-orig/configure.in 2004-11-14 00:06:57.000000000 +0100
+++ gnutls-1.0.24-1/configure.in 2005-03-15 23:24:35.000000000 +0100
@@ -137,7 +137,7 @@
if test x$opt_developer_mode = xyes; then
CFLAGS="${CFLAGS} -g -Wno-format-y2k -Wall -Wcast-align -W -Wpointer-arith -Wchar-subscripts -Wformat-security -Wmissing-braces -Winline -Wstrict-prototypes"
else
- CFLAGS="${CFLAGS} -O2 -finline-functions"
+ CFLAGS="${CFLAGS} -finline-functions"
fi
if test x$opt_dmalloc_mode = xyes; then
@@ -489,8 +489,8 @@
])
AM_PROG_LIBTOOL
-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
-LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
+LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
+LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
CFLAGS="${CFLAGS} ${LIBGCRYPT_CFLAGS}"
@@ -500,8 +500,8 @@
SERV_LIBS="$LIBS $SERV_LIBS"
AC_SUBST(SERV_LIBS)
-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
-LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS -I${includedir}"
+LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
+LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS $LIBGNUTLS_CFLAGS"
AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)

View File

@ -1,24 +0,0 @@
diff -ruN gnutls-1.0.24-orig/src/Makefile.am gnutls-1.0.24-1/src/Makefile.am
--- gnutls-1.0.24-orig/src/Makefile.am 2004-09-17 11:08:24.000000000 +0200
+++ gnutls-1.0.24-1/src/Makefile.am 2005-03-15 23:28:19.000000000 +0100
@@ -31,7 +31,7 @@
cfg/cfg+.c cfg/cfgfile.c cfg/cmdline.c cfg/parse.c cfg/props.c \
cfg/shared.c cfg/platon/str/dynfgets.c cfg/platon/str/strctype.c \
cfg/platon/str/strdyn.c cfg/platon/str/strplus.c
-certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS)
+certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS)
endif
diff -ruN gnutls-1.0.24-orig/src/Makefile.in gnutls-1.0.24-1/src/Makefile.in
--- gnutls-1.0.24-orig/src/Makefile.in 2005-01-18 19:31:14.000000000 +0100
+++ gnutls-1.0.24-1/src/Makefile.in 2005-03-15 23:28:41.000000000 +0100
@@ -308,7 +308,7 @@
@HAVE_LIBCFG_FALSE@ cfg/platon/str/strdyn.c cfg/platon/str/strplus.c
@HAVE_LIBCFG_TRUE@certtool_SOURCES = certtool-gaa.c certtool.c prime.c getpass.c certtool-cfg.c
-@HAVE_LIBCFG_FALSE@certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS)
+@HAVE_LIBCFG_FALSE@certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS)
@HAVE_LIBCFG_TRUE@certtool_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS) -lcfg+
all: all-recursive