php4: add compatibility fix for gmp
gmp modified some if it's internal constants, in particular __GMP_BITS_PER_MP_LIMB. Added a patch to substitute GMP_LIMB_BITS. Also bumped release number and copyright date. Signed-off-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@35955 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
18dd3715b6
commit
ab79cf8bc7
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
# Copyright (C) 2006-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=php4
|
||||
PKG_VERSION:=4.4.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=php-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||
|
11
lang/php4/patches/120-gmp-compat.patch
Normal file
11
lang/php4/patches/120-gmp-compat.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/ext/gmp/gmp.c
|
||||
+++ b/ext/gmp/gmp.c
|
||||
@@ -1159,7 +1159,7 @@ ZEND_FUNCTION(gmp_random)
|
||||
|
||||
GMPG(rand_initialized) = 1;
|
||||
}
|
||||
- mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * __GMP_BITS_PER_MP_LIMB);
|
||||
+ mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * GMP_LIMB_BITS);
|
||||
|
||||
ZEND_REGISTER_RESOURCE(return_value, gmpnum_result, le_gmp);
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user