port libgcrypt to buildroot-ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4214 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2006-07-22 16:34:42 +00:00
parent a5a40696de
commit acc296cffe
2 changed files with 130 additions and 0 deletions

106
libs/libgcrypt/Makefile Normal file
View File

@ -0,0 +1,106 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=libgcrypt
PKG_VERSION:=1.2.1
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ftp.gnupg.org/gcrypt/libgcrypt/
PKG_MD5SUM:=b6d3217c9333c520fe54d2e8dc5e60ec
PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/libgcrypt
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libgpg-error
TITLE:=GNU crypto library
DESCRIPTION:=The GNU crypto library.\\\
This is a general purpose cryptographic library based on the code from \\\
GnuPG. It provides functions for all cryptograhic building blocks: \\\
symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash \\\
algorithms (MD4, MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all \\\
hash algorithms), public key algorithms (RSA, ElGamal, DSA), large \\\
integer functions, random numbers and a lot of supporting functions.
URL:=http://directory.fsf.org/security/libgcrypt.html
endef
define Build/Configure
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--enable-shared \
--enable-static \
--disable-rpath \
--disable-asm \
--with-gpg-error-prefix="$(STAGING_DIR)/usr" \
);
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/libgcrypt/install
install -m0755 -d $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.so.* $(1)/usr/lib/
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/share/aclocal
$(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(STAGING_DIR)/usr/share/aclocal/
endef
define Build/UninstallDev
rm -rf \
$(STAGING_DIR)/usr/bin/libgcrypt-config \
$(STAGING_DIR)/usr/include/gcrypt*.h \
$(STAGING_DIR)/usr/lib/libgcrypt.{a,so*} \
$(STAGING_DIR)/usr/share/aclocal/libgcrypt.m4
endef
$(eval $(call BuildPackage,libgcrypt))

View File

@ -0,0 +1,24 @@
diff -ruN libgcrypt-1.2.1-orig/tests/Makefile.am libgcrypt-1.2.1-1/tests/Makefile.am
--- libgcrypt-1.2.1-orig/tests/Makefile.am 2004-03-03 09:08:05.000000000 +0100
+++ libgcrypt-1.2.1-1/tests/Makefile.am 2005-03-15 21:36:49.000000000 +0100
@@ -21,7 +21,7 @@
TESTS = prime register ac basic tsexp keygen pubkey benchmark
INCLUDES = -I$(top_srcdir)/src
-LDADD = ../src/libgcrypt.la
+LDADD = ../src/libgcrypt.la @LTLIBOBJS@ @GPG_ERROR_LIBS@
EXTRA_PROGRAMS = testapi
noinst_PROGRAMS = $(TESTS)
diff -ruN libgcrypt-1.2.1-orig/tests/Makefile.in libgcrypt-1.2.1-1/tests/Makefile.in
--- libgcrypt-1.2.1-orig/tests/Makefile.in 2005-01-05 14:53:23.000000000 +0100
+++ libgcrypt-1.2.1-1/tests/Makefile.in 2005-03-15 21:37:12.000000000 +0100
@@ -258,7 +258,7 @@
target_vendor = @target_vendor@
TESTS = prime register ac basic tsexp keygen pubkey benchmark
INCLUDES = -I$(top_srcdir)/src
-LDADD = ../src/libgcrypt.la
+LDADD = ../src/libgcrypt.la @LTLIBOBJS@ @GPG_ERROR_LIBS@
AM_CFLAGS = @GPG_ERROR_CFLAGS@
all: all-am