[packages] miniupnpd: bump to v1.4 (#6266)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18641 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2009-12-04 23:11:05 +00:00
parent 2ae2252b5d
commit afd0c20a5f
3 changed files with 11 additions and 50 deletions

View File

@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=1.3
PKG_RELEASE:=5
PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
PKG_VERSION:=1.4
PKG_RELEASE:=1
PKG_MD5SUM:=ffa33d4ed8732c662bdb7d511e86db76
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@ -26,6 +26,10 @@ define Package/miniupnpd
URL:=http://miniupnp.free.fr/
endef
define Package/miniupnpd/conffiles
/etc/config/upnpd
endef
define Build/Compile
ln -sf $(PKG_BUILD_DIR)/config.h.openwrt $(PKG_BUILD_DIR)/config.h
$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
@ -39,7 +43,7 @@ define Package/miniupnpd/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/etc/init.d $(1)/etc/config $(1)/etc/hotplug.d/firewall
$(INSTALL_BIN) $(PKG_BUILD_DIR)/miniupnpd $(1)/usr/bin/miniupnpd
$(INSTALL_BIN) ./files/miniupnpd.init $(1)/etc/init.d/miniupnpd
$(INSTALL_DATA) ./files/upnpd.config $(1)/etc/config/upnpd
$(INSTALL_CONF) ./files/upnpd.config $(1)/etc/config/upnpd
$(INSTALL_DATA) ./files/miniupnpd.hotplug $(1)/etc/hotplug.d/firewall/50-miniupnpd
endef

View File

@ -1,4 +1,5 @@
config upnpd config
option enabled 0
option secure_mode 1
option log_output 0
option download 1024

View File

@ -1,6 +1,6 @@
--- a/netfilter/iptcrdr.c
+++ b/netfilter/iptcrdr.c
@@ -415,11 +415,21 @@ delete_redirect_and_filter_rules(unsigne
@@ -424,10 +424,20 @@ delete_redirect_and_filter_rules(unsigne
if(h)
{
r = delete_rule_and_commit(index, h, miniupnpd_nat_chain, "delete_redirect_rule");
@ -10,8 +10,7 @@
+ iptc_free(&h);
+#endif
}
h = iptc_init("filter");
if(h && (r == 0))
if((r == 0) && (h = iptc_init("filter")))
{
r = delete_rule_and_commit(index, h, miniupnpd_forward_chain, "delete_filter_rule");
+#ifdef IPTABLES_143
@ -22,46 +21,3 @@
}
}
del_redirect_desc(eport, proto);
@@ -509,6 +519,11 @@ iptc_init_verify_and_append(const char *
{
syslog(LOG_ERR, "%s : iptc_is_chain() error : %s\n",
logcaller, iptc_strerror(errno));
+#ifdef IPTABLES_143
+ iptc_free(h);
+#else
+ iptc_free(&h);
+#endif
return -1;
}
#ifdef IPTABLES_143
@@ -519,6 +534,11 @@ iptc_init_verify_and_append(const char *
{
syslog(LOG_ERR, "%s : iptc_append_entry() error : %s\n",
logcaller, iptc_strerror(errno));
+#ifdef IPTABLES_143
+ iptc_free(h);
+#else
+ iptc_free(&h);
+#endif
return -1;
}
#ifdef IPTABLES_143
@@ -529,8 +549,18 @@ iptc_init_verify_and_append(const char *
{
syslog(LOG_ERR, "%s : iptc_commit() error : %s\n",
logcaller, iptc_strerror(errno));
+#ifdef IPTABLES_143
+ iptc_free(h);
+#else
+ iptc_free(&h);
+#endif
return -1;
}
+#ifdef IPTABLES_143
+ iptc_free(h);
+#else
+ iptc_free(&h);
+#endif
return 0;
}