update aiccu to 20070107 (should close: #1201)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6105 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
bf2b94dd10
commit
b00fc05ca8
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=aiccu
|
||||
PKG_VERSION:=2006.07.25
|
||||
PKG_VERSION:=20070107
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
|
||||
PKG_MD5SUM:=0df76e92eb34f4ce8aa3cfcf6896f271
|
||||
PKG_MD5SUM:=67a6d55ef2d6e88a3f17bcb5eec02c61
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
@ -26,17 +26,19 @@ define Package/aiccu
|
||||
CATEGORY:=IPv6
|
||||
DEPENDS:=+libpthread
|
||||
TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
|
||||
URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
|
||||
URL:=http://www.sixxs.net/tools/aiccu/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
|
||||
$(SED) "s,strip,/bin/true," $(PKG_BUILD_DIR)/unix-console/Makefile
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-lpthread" DEBUG=0
|
||||
CC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DAICCU_CONSOLE -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpthread" \
|
||||
DEBUG=0
|
||||
endef
|
||||
|
||||
define Package/aiccu/install
|
||||
|
101
ipv6/aiccu/patches/100-cross_compile.patch
Normal file
101
ipv6/aiccu/patches/100-cross_compile.patch
Normal file
@ -0,0 +1,101 @@
|
||||
diff -ruN aiccu-old/unix-console/Makefile aiccu-new/unix-console/Makefile
|
||||
--- aiccu-old/unix-console/Makefile 2007-01-15 12:22:48.000000000 +0100
|
||||
+++ aiccu-new/unix-console/Makefile 2007-01-15 12:33:13.000000000 +0100
|
||||
@@ -10,6 +10,9 @@
|
||||
# $Date: 2007-01-11 00:28:45 $
|
||||
# **********************************************************/
|
||||
|
||||
+OS_NAME=$(shell uname)
|
||||
+OS_VERSION=$(shell uname -r)
|
||||
+
|
||||
SRCS = main.c ../common/tun.c ../common/aiccu.c ../common/hash_md5.c ../common/hash_sha1.c ../common/common.c ../common/heartbeat.c ../common/tic.c ../common/ayiya.c ../common/aiccu_test.c ../common/resolver.c
|
||||
INCS = ../common/tun.h ../common/aiccu.h ../common/hash_md5.h ../common/hash_sha1.h ../common/common.h ../common/heartbeat.h ../common/tic.h ../common/ayiya.h ../common/resolver.h
|
||||
OBJS = main.o ../common/tun.o ../common/aiccu.o ../common/hash_md5.o ../common/hash_sha1.o ../common/common.o ../common/heartbeat.o ../common/tic.o ../common/ayiya.o ../common/aiccu_test.o ../common/resolver.o
|
||||
@@ -40,13 +43,13 @@
|
||||
# GnuTLS Support ?
|
||||
# Used by TIC to secure that communication
|
||||
# Currently defaultly builds only on Linux, but other platforms might easily also support it
|
||||
-ifeq ($(shell uname | grep -c "Linux"),1)
|
||||
+ifneq ($(HAVE_GNUTLS),)
|
||||
CFLAGS += -D AICCU_GNUTLS
|
||||
LDFLAGS += -lgnutls
|
||||
endif
|
||||
|
||||
# Linux
|
||||
-ifeq ($(shell uname | grep -c "Linux"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "Linux"),1)
|
||||
CFLAGS += -D_LINUX -D HAS_IFHEAD -D AICCU_TYPE="\"linux\""
|
||||
SRCS += ../common/aiccu_linux.c
|
||||
OBJS += ../common/aiccu_linux.o
|
||||
@@ -54,11 +57,11 @@
|
||||
endif
|
||||
|
||||
# FreeBSD
|
||||
-ifeq ($(shell uname | grep -c "FreeBSD"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "FreeBSD"),1)
|
||||
CFLAGS += -D_FREEBSD
|
||||
|
||||
# FreeBSD 4.x
|
||||
-ifeq ($(shell uname -r | cut -c 1),4)
|
||||
+ifeq ($(shell echo $(OS_VERSION) | cut -c 1),4)
|
||||
CFLAGS += -D AICCU_TYPE="\"freebsd4\""
|
||||
SRCS += ../common/aiccu_freebsd4.c
|
||||
OBJS += ../common/aiccu_freebsd4.o
|
||||
@@ -71,7 +74,7 @@
|
||||
endif
|
||||
|
||||
# DragonFlyBSD
|
||||
-ifeq ($(shell uname | grep -c "DragonFly"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "DragonFly"),1)
|
||||
CFLAGS += -D_DFBSD -D NEED_IFHEAD -D AICCU_TYPE="\"dragonfly\""
|
||||
SRCS += ../common/aiccu_freebsd4.c
|
||||
OBJS += ../common/aiccu_freebsd4.o
|
||||
@@ -79,7 +82,7 @@
|
||||
endif
|
||||
|
||||
# NetBSD
|
||||
-ifeq ($(shell uname | grep -c "NetBSD"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "NetBSD"),1)
|
||||
CFLAGS += -D_NETBSD -D NEED_IFHEAD -D AICCU_TYPE="\"kame\""
|
||||
SRCS += ../common/aiccu_kame.c
|
||||
OBJS += ../common/aiccu_kame.o
|
||||
@@ -87,10 +90,10 @@
|
||||
endif
|
||||
|
||||
# OpenBSD
|
||||
-ifeq ($(shell uname | grep -c "OpenBSD"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "OpenBSD"),1)
|
||||
CFLAGS += -D_OPENBSD -D HAS_IFHEAD
|
||||
# 2.7-2.9
|
||||
-ifeq ($(shell uname -r | cut -c 1),2)
|
||||
+ifeq ($(shell echo $(OS_VERSION) | cut -c 1),2)
|
||||
CFLAGS += -D AICCU_TYPE="\"openbsd2\""
|
||||
SRCS += ../common/aiccu_openbsd2.c
|
||||
OBJS += ../common/aiccu_openbsd2.o
|
||||
@@ -104,7 +107,7 @@
|
||||
endif
|
||||
|
||||
# Darwin
|
||||
-ifeq ($(shell uname | grep -c "Darwin"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "Darwin"),1)
|
||||
CFLAGS += -D_DARWIN -D NEED_IFHEAD -D AICCU_TYPE="\"darwin\""
|
||||
SRCS += ../common/aiccu_darwin.c
|
||||
OBJS += ../common/aiccu_darwin.o
|
||||
@@ -112,7 +115,7 @@
|
||||
endif
|
||||
|
||||
# SunOS / Solaris
|
||||
-ifeq ($(shell uname | grep -c "SunOS"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "SunOS"),1)
|
||||
CFLAGS += -D_SUNOS -D AICCU_TYPE="\"sunos\""
|
||||
SRCS += ../common/aiccu_sunos.c
|
||||
OBJS += ../common/aiccu_sunos.o
|
||||
@@ -120,7 +123,7 @@
|
||||
endif
|
||||
|
||||
# AIX
|
||||
-ifeq ($(shell uname | grep -c "AIX"),1)
|
||||
+ifeq ($(shell echo $(OS_NAME) | grep -c "AIX"),1)
|
||||
CC = @/usr/vac/bin/xlc_r
|
||||
CFLAGS = -qthreaded -q64 -qlanglvl=stdc99 -bmaxdata:0xD0000000 -D_64BIT -g -qdbxextra -qfullpath -qheapdebug -qformat=all -qcheck=all
|
||||
CFLAGS += -D AICCU_CONSOLE
|
@ -1,18 +0,0 @@
|
||||
diff -Nru aiccu.old/unix-console/Makefile aiccu/unix-console/Makefile
|
||||
--- aiccu.old/unix-console/Makefile 2006-07-25 12:20:48.000000000 +0300
|
||||
+++ aiccu/unix-console/Makefile 2006-11-04 00:44:03.000000000 +0200
|
||||
@@ -37,12 +37,10 @@
|
||||
# This is a console client
|
||||
CFLAGS += -D AICCU_CONSOLE
|
||||
|
||||
-# GnuTLS Support ?
|
||||
+# GnuTLS Support ? Removed for OpenWRT.
|
||||
# Used by TIC to secure that communication
|
||||
-# Currently defaultly builds only on Linux, but other platforms might easily also support it
|
||||
ifeq ($(shell uname | grep -c "Linux"),1)
|
||||
-CFLAGS += -D _LINUX -D AICCU_GNUTLS
|
||||
-LDFLAGS += -lgnutls
|
||||
+CFLAGS += -D _LINUX
|
||||
endif
|
||||
|
||||
# Linux
|
Loading…
x
Reference in New Issue
Block a user