[pacakges] olsrd: Update to v0.6.0
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21585 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
45fd949501
commit
b1cbbbe509
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=olsrd
|
||||
PKG_VERSION:=0.5.6-r8
|
||||
PKG_VERSION:=0.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.olsr.org/releases/0.5
|
||||
PKG_MD5SUM:=aef6f4350c44fd0ad015a26621ef9607
|
||||
PKG_SOURCE_URL:=http://www.olsr.org/releases/0.6
|
||||
PKG_MD5SUM:=8425a10e315be5e061143ac310f2424b
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -8,7 +8,7 @@ config LoadPlugin
|
||||
option library 'olsrd_arprefresh.so.0.1'
|
||||
|
||||
config LoadPlugin
|
||||
option library 'olsrd_dyn_gw.so.0.4'
|
||||
option library 'olsrd_dyn_gw.so.0.5'
|
||||
|
||||
config LoadPlugin
|
||||
option library 'olsrd_httpinfo.so.0.1'
|
||||
|
@ -1,34 +1,29 @@
|
||||
--- a/src/linux/net.c
|
||||
+++ b/src/linux/net.c
|
||||
@@ -115,6 +115,7 @@
|
||||
int
|
||||
enable_ip_forwarding(int version)
|
||||
{
|
||||
@@ -171,11 +171,13 @@ static bool is_at_least_linuxkernel_2_6_
|
||||
*/
|
||||
void
|
||||
net_os_set_global_ifoptions(void) {
|
||||
+#if 0
|
||||
FILE *proc_fwd;
|
||||
const char *const procfile = version == AF_INET ? "/proc/sys/net/ipv4/ip_forward" : "/proc/sys/net/ipv6/conf/all/forwarding";
|
||||
|
||||
@@ -150,6 +151,7 @@
|
||||
}
|
||||
fclose(proc_fwd);
|
||||
if (writeToProc(olsr_cnf->ip_version == AF_INET ? PROC_IPFORWARD_V4 : PROC_IPFORWARD_V6, &orig_fwd_state, '1')) {
|
||||
OLSR_PRINTF(1, "Warning, could not enable IP forwarding!\n"
|
||||
"you should manually ensure that IP forwarding is enabled!\n\n");
|
||||
olsr_startup_sleep(3);
|
||||
}
|
||||
+#endif
|
||||
return 1;
|
||||
}
|
||||
|
||||
@@ -276,6 +278,7 @@
|
||||
if (olsr_cnf->smart_gw_active) {
|
||||
char procfile[FILENAME_MAX];
|
||||
@@ -266,10 +268,12 @@ net_os_restore_ifoptions(void)
|
||||
|
||||
OLSR_PRINTF(1, "Restoring network state\n");
|
||||
|
||||
/* Restore IP forwarding to "off" */
|
||||
+#if 0
|
||||
if (orig_fwd_state == '0') {
|
||||
const char *const procfile = version == AF_INET ? "/proc/sys/net/ipv4/ip_forward" : "/proc/sys/net/ipv6/conf/all/forwarding";
|
||||
FILE *proc_fd;
|
||||
@@ -288,6 +291,7 @@
|
||||
fclose(proc_fd);
|
||||
}
|
||||
/* Restore IP forwarding to "off" */
|
||||
if (writeToProc(olsr_cnf->ip_version == AF_INET ? PROC_IPFORWARD_V4 : PROC_IPFORWARD_V6, NULL, orig_fwd_state)) {
|
||||
OLSR_PRINTF(1, "Error, could not restore ip_forward settings\n");
|
||||
}
|
||||
+#endif
|
||||
|
||||
/* Restore global ICMP redirect setting */
|
||||
if (orig_global_redirect_state != '0') {
|
||||
if (olsr_cnf->smart_gw_active) {
|
||||
/* Generate the procfile name */
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
x
Reference in New Issue
Block a user