mysql: cleanup and update to 5.1.73

This is a cryptographically signed message in MIME format.

- some mirrors do not have the old version anymore
- cleanup deprecated options

--without-vio : removed in 5.0.2
--without-raid, --without-mysqlfs : removed in 5.0.3
http://dev.mysql.com/doc/refman/5.0/en/source-configuration-options.html

--without-pstack : removed in 5.1.54
--without-bench : removed in 5.1.11
http://dev.mysql.com/doc/refman/5.1/en/source-configuration-options.html

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@39488 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-02-05 21:14:15 +00:00
parent 64f84b7d0b
commit b47d1ebf84
3 changed files with 12 additions and 17 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/uclibc++.mk
PKG_NAME:=mysql
PKG_VERSION:=5.1.68
PKG_VERSION:=5.1.73
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@ -20,7 +20,7 @@ PKG_SOURCE_URL:=\
http://mirror.switch.ch/ftp/mirror/mysql/Downloads/MySQL-5.1/ \
http://downloads.mysql.com/archives/mysql-5.1/
PKG_MD5SUM:=3a4a627d0865ce7660504728a15b0fb9
PKG_MD5SUM:=887f869bcc757957067b9198f707f32f
PKG_BUILD_DEPENDS:=libncurses libreadline
PKG_BUILD_PARALLEL:=1
@ -68,20 +68,15 @@ CONFIGURE_ARGS += \
--with-pthread \
--with-server \
--without-mysqlmanager \
--without-raid \
--with-mysqld-user=root \
--with-unix-socket-path=/tmp \
--without-libwrap \
--without-pstack \
--with-low-memory \
--without-embedded-server \
--without-query-cache \
--without-mysqlfs \
--without-vio \
--without-ssl \
--without-docs \
--without-man \
--without-bench \
--without-readline \
--without-debug \
--with-named-thread-libs=-lpthread

View File

@ -1,6 +1,6 @@
--- a/scripts/mysql_install_db.sh
+++ b/scripts/mysql_install_db.sh
@@ -322,7 +322,7 @@
@@ -322,7 +322,7 @@ then
fi
# Try to determine the hostname

View File

@ -1,6 +1,6 @@
--- a/storage/innodb_plugin/plug.in
+++ b/storage/innodb_plugin/plug.in
@@ -56,10 +56,8 @@
@@ -56,10 +56,8 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
esac
AC_SUBST(INNODB_DYNAMIC_CFLAGS)
@ -13,7 +13,7 @@
int main()
{
long x;
@@ -96,21 +94,18 @@
@@ -96,21 +94,18 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
return(0);
}
@ -46,7 +46,7 @@
#include <pthread.h>
#include <string.h>
@@ -127,16 +122,14 @@
@@ -127,16 +122,14 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
return(0);
}
@ -71,7 +71,7 @@
AC_MSG_CHECKING(whether Solaris libc atomic functions are available)
# Define HAVE_IB_SOLARIS_ATOMICS if _all_ of the following
@@ -156,7 +149,6 @@
@@ -156,7 +149,6 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
AC_DEFINE([HAVE_IB_SOLARIS_ATOMICS], [1],
[Define to 1 if Solaris libc atomic functions are available]
)
@ -79,7 +79,7 @@
AC_MSG_CHECKING(whether pthread_t can be used by Solaris libc atomic functions)
# either define HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS or not
@@ -230,6 +222,8 @@
@@ -230,6 +222,8 @@ MYSQL_PLUGIN_ACTIONS(innodb_plugin, [
AC_MSG_RESULT(no)
]
)
@ -90,7 +90,7 @@
# vim: set ft=config:
--- a/sql/gen_lex_hash.cc
+++ b/sql/gen_lex_hash.cc
@@ -344,55 +344,6 @@
@@ -344,55 +344,6 @@ void print_find_structs()
}
@ -146,7 +146,7 @@
int check_dup_symbols(SYMBOL *s1, SYMBOL *s2)
{
if (s1->length!=s2->length || strncmp(s1->name,s2->name,s1->length))
@@ -443,12 +394,6 @@
@@ -443,12 +394,6 @@ int check_duplicates()
int main(int argc,char **argv)
{
@ -159,7 +159,7 @@
/* Broken up to indicate that it's not advice to you, gentle reader. */
printf("/*\n\n Do " "not " "edit " "this " "file " "directly!\n\n*/\n");
@@ -549,7 +494,6 @@
@@ -549,7 +494,6 @@ static SYMBOL *get_hash_symbol(const cha
}\n\
}\n"
);
@ -169,7 +169,7 @@
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -26,7 +26,6 @@
@@ -26,7 +26,6 @@ INCLUDES = @ZLIB_INCLUDES@ \
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld