update Asterisk to 1.4.22

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13685 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
zandbelt 2008-12-18 19:42:25 +00:00
parent 4057c0147a
commit b6a3fa1c22
9 changed files with 69 additions and 68 deletions

View File

@ -9,12 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=asterisk
PKG_VERSION:=1.4.21
PKG_VERSION:=1.4.22
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
PKG_MD5SUM:=c4cf69eb6eae3105806b08d3efc28ec7
#PKG_MD5SUM:=c4cf69eb6eae3105806b08d3efc28ec7
PKG_MD5SUM:=7626febc4a01e16e012dfccb9e4ab9d2
PKG_BUILD_DEPENDS:= libopenh323 pwlib
@ -334,6 +335,7 @@ define Package/asterisk14-rawplayer/description
endef
# --with-ltdl="$(STAGING_DIR)/usr" \
CONFIGURE_ARGS+= \
--without-curl \
--without-curses \
@ -341,7 +343,6 @@ CONFIGURE_ARGS+= \
--without-imap \
--without-isdnnet \
--without-kde \
--with-ltdl="$(STAGING_DIR)/usr" \
--without-misdn \
--without-nbs \
--with-ncurses="$(STAGING_DIR)/usr" \
@ -530,15 +531,15 @@ define Package/asterisk14/conffiles
/etc/asterisk/users.conf
endef
define Package/asterisk14/postinst
#!/bin/sh
ROOT=`echo $${PKG_ROOT} | sed 's:[\/]:\\\&:g' -`
/bin/sed -i 's/\ \/etc/\ '$${ROOT}'etc/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
/bin/sed -i 's/\ \/var/\ '$${ROOT}'var/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
/bin/sed -i 's/\ \/usr/\ '$${ROOT}'usr/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
/bin/sed -i 's/^DEST=/DEST='$${ROOT}'/g' $${PKG_ROOT}/etc/init.d/asterisk
/bin/sed -i 's/OPTIONS=\"\"/OPTIONS=\"-C\ '$${ROOT}'etc\/asterisk\/asterisk.conf\"/g' $${PKG_ROOT}/etc/default/asterisk
endef
#define Package/asterisk14/postinst
##!/bin/sh
#ROOT=`echo $${PKG_ROOT} | sed 's:[\/]:\\\&:g' -`
#/bin/sed -i 's/\ \/etc/\ '$${ROOT}'etc/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
#/bin/sed -i 's/\ \/var/\ '$${ROOT}'var/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
#/bin/sed -i 's/\ \/usr/\ '$${ROOT}'usr/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
#/bin/sed -i 's/^DEST=/DEST='$${ROOT}'/g' $${PKG_ROOT}/etc/init.d/asterisk
#/bin/sed -i 's/OPTIONS=\"\"/OPTIONS=\"-C\ '$${ROOT}'etc\/asterisk\/asterisk.conf\"/g' $${PKG_ROOT}/etc/default/asterisk
#endef
define Package/asterisk14/install
$(CP) $(PKG_INSTALL_DIR)/* $(1)

View File

@ -1,6 +1,6 @@
diff -Nru asterisk-1.4.18.org/main/Makefile asterisk-1.4.18/main/Makefile
--- asterisk-1.4.18.org/main/Makefile 2008-01-29 18:43:41.000000000 +0100
+++ asterisk-1.4.19.1/main/Makefile 2008-03-02 19:30:04.000000000 +0100
diff -Nru asterisk-1.4.22.org/main/Makefile asterisk-1.4.22/main/Makefile
--- asterisk-1.4.22.org/main/Makefile 2008-07-18 18:15:41.000000000 +0200
+++ asterisk-1.4.22/main/Makefile 2008-11-29 14:58:13.000000000 +0100
@@ -144,7 +144,7 @@
ifneq ($(findstring chan_h323,$(MENUSELECT_CHANNELS)),)
$(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS)
@ -8,5 +8,5 @@ diff -Nru asterisk-1.4.18.org/main/Makefile asterisk-1.4.18/main/Makefile
- $(CMD_PREFIX) $(CXX) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS)
+ $(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS)
endif
@$(ASTTOPDIR)/build_tools/strip_nonapi $@
$(CMD_PREFIX) $(ASTTOPDIR)/build_tools/strip_nonapi $@ || rm $@

View File

@ -1,7 +1,7 @@
diff -Nru asterisk-1.4.18.org/channels/chan_iax2.c asterisk-1.4.18/channels/chan_iax2.c
--- asterisk-1.4.18.org/channels/chan_iax2.c 2008-01-31 20:52:49.000000000 +0100
+++ asterisk-1.4.19.1/channels/chan_iax2.c 2008-03-02 19:32:14.000000000 +0100
@@ -1554,7 +1554,7 @@
diff -Nru asterisk-1.4.22.org/channels/chan_iax2.c asterisk-1.4.22/channels/chan_iax2.c
--- asterisk-1.4.22.org/channels/chan_iax2.c 2008-09-02 20:14:57.000000000 +0200
+++ asterisk-1.4.22/channels/chan_iax2.c 2008-11-29 15:00:00.000000000 +0100
@@ -1815,7 +1815,7 @@
last++;
else
last = s;

View File

@ -1,7 +1,7 @@
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:33:55.000000000 +0100
@@ -884,7 +884,7 @@
diff -Nru asterisk-1.4.22.org/configure.ac asterisk-1.4.22/configure.ac
--- asterisk-1.4.22.org/configure.ac 2008-09-08 18:26:00.000000000 +0200
+++ asterisk-1.4.22/configure.ac 2008-11-29 15:01:13.000000000 +0100
@@ -1319,7 +1319,7 @@
AST_EXT_LIB_CHECK([SQLITE], [sqlite], [sqlite_exec], [sqlite.h])

View File

@ -1,6 +1,6 @@
diff -Nru asterisk-1.4.18.org/apps/app_rxfax.c asterisk-1.4.18/apps/app_rxfax.c
--- asterisk-1.4.18.org/apps/app_rxfax.c 1970-01-01 01:00:00.000000000 +0100
+++ asterisk-1.4.19.1/apps/app_rxfax.c 2008-03-02 19:35:45.000000000 +0100
diff -Nru asterisk-1.4.22.org/apps/app_rxfax.c asterisk-1.4.22/apps/app_rxfax.c
--- asterisk-1.4.22.org/apps/app_rxfax.c 1970-01-01 01:00:00.000000000 +0100
+++ asterisk-1.4.22/apps/app_rxfax.c 2008-11-29 15:02:27.000000000 +0100
@@ -0,0 +1,376 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
@ -378,9 +378,9 @@ diff -Nru asterisk-1.4.18.org/apps/app_rxfax.c asterisk-1.4.18/apps/app_rxfax.c
+AST_MODULE_INFO_STANDARD(ASTERISK_GPL_KEY, "Trivial FAX Receive Application");
+
+/*- End of file ------------------------------------------------------------*/
diff -Nru asterisk-1.4.18.org/apps/app_txfax.c asterisk-1.4.18/apps/app_txfax.c
--- asterisk-1.4.18.org/apps/app_txfax.c 1970-01-01 01:00:00.000000000 +0100
+++ asterisk-1.4.19.1/apps/app_txfax.c 2008-03-02 19:35:45.000000000 +0100
diff -Nru asterisk-1.4.22.org/apps/app_txfax.c asterisk-1.4.22/apps/app_txfax.c
--- asterisk-1.4.22.org/apps/app_txfax.c 1970-01-01 01:00:00.000000000 +0100
+++ asterisk-1.4.22/apps/app_txfax.c 2008-11-29 15:02:27.000000000 +0100
@@ -0,0 +1,303 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
@ -685,21 +685,21 @@ diff -Nru asterisk-1.4.18.org/apps/app_txfax.c asterisk-1.4.18/apps/app_txfax.c
+AST_MODULE_INFO_STANDARD(ASTERISK_GPL_KEY, "Trivial FAX Transmit Application");
+
+/*- End of file ------------------------------------------------------------*/
diff -Nru asterisk-1.4.18.org/build_tools/menuselect-deps.in asterisk-1.4.18/build_tools/menuselect-deps.in
--- asterisk-1.4.18.org/build_tools/menuselect-deps.in 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/build_tools/menuselect-deps.in 2008-03-02 19:35:45.000000000 +0100
@@ -21,6 +21,7 @@
diff -Nru asterisk-1.4.22.org/build_tools/menuselect-deps.in asterisk-1.4.22/build_tools/menuselect-deps.in
--- asterisk-1.4.22.org/build_tools/menuselect-deps.in 2008-08-14 04:02:15.000000000 +0200
+++ asterisk-1.4.22/build_tools/menuselect-deps.in 2008-11-29 15:02:27.000000000 +0100
@@ -23,6 +23,7 @@
POPT=@PBX_POPT@
PRI=@PBX_PRI@
RADIUS=@PBX_RADIUS@
+SPANDSP=@PBX_SPANDSP@
SPEEX=@PBX_SPEEX@
SPEEXDSP=@PBX_SPEEXDSP@
SQLITE=@PBX_SQLITE@
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:35:45.000000000 +0100
@@ -198,6 +198,7 @@
SPEEX_PREPROCESS=@PBX_SPEEX_PREPROCESS@
diff -Nru asterisk-1.4.22.org/configure.ac asterisk-1.4.22/configure.ac
--- asterisk-1.4.22.org/configure.ac 2008-09-08 18:26:00.000000000 +0200
+++ asterisk-1.4.22/configure.ac 2008-11-29 15:02:27.000000000 +0100
@@ -201,6 +201,7 @@
AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
@ -707,7 +707,7 @@ diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
AST_EXT_LIB_SETUP([SPEEXDSP], [Speexdsp], [speexdsp])
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
@@ -878,6 +879,8 @@
@@ -1302,6 +1303,8 @@
AST_EXT_LIB_CHECK([RADIUS], [radiusclient-ng], [rc_read_config], [radiusclient-ng.h])
@ -715,10 +715,10 @@ diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
+
AST_EXT_LIB_CHECK([SPEEX], [speex], [speex_encode], [speex/speex.h], [-lm])
AST_EXT_LIB_CHECK([SPEEXDSP], [speexdsp], [speex_preprocess_ctl], [speex/speex.h], [-lm])
diff -Nru asterisk-1.4.18.org/include/asterisk/plc.h asterisk-1.4.18/include/asterisk/plc.h
--- asterisk-1.4.18.org/include/asterisk/plc.h 2006-06-14 16:12:56.000000000 +0200
+++ asterisk-1.4.19.1/include/asterisk/plc.h 2008-03-02 19:35:45.000000000 +0100
# See if the main speex library contains the preprocess functions
diff -Nru asterisk-1.4.22.org/include/asterisk/plc.h asterisk-1.4.22/include/asterisk/plc.h
--- asterisk-1.4.22.org/include/asterisk/plc.h 2006-06-14 16:12:56.000000000 +0200
+++ asterisk-1.4.22/include/asterisk/plc.h 2008-11-29 15:02:27.000000000 +0100
@@ -1,18 +1,17 @@
-/*! \file
- * \brief SpanDSP - a series of DSP components for telephony
@ -860,10 +860,10 @@ diff -Nru asterisk-1.4.18.org/include/asterisk/plc.h asterisk-1.4.18/include/ast
}
#endif
diff -Nru asterisk-1.4.18.org/makeopts.in asterisk-1.4.18/makeopts.in
--- asterisk-1.4.18.org/makeopts.in 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/makeopts.in 2008-03-02 19:35:45.000000000 +0100
@@ -137,6 +137,9 @@
diff -Nru asterisk-1.4.22.org/makeopts.in asterisk-1.4.22/makeopts.in
--- asterisk-1.4.22.org/makeopts.in 2008-06-12 21:08:20.000000000 +0200
+++ asterisk-1.4.22/makeopts.in 2008-11-29 15:02:27.000000000 +0100
@@ -138,6 +138,9 @@
RADIUS_INCLUDE=@RADIUS_INCLUDE@
RADIUS_LIB=@RADIUS_LIB@

View File

@ -1,7 +1,7 @@
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:38:21.000000000 +0100
@@ -470,7 +470,7 @@
diff -Nru asterisk-1.4.22.org/configure.ac asterisk-1.4.22/configure.ac
--- asterisk-1.4.22.org/configure.ac 2008-09-08 18:26:00.000000000 +0200
+++ asterisk-1.4.22/configure.ac 2008-11-29 15:04:09.000000000 +0100
@@ -514,7 +514,7 @@
fi
fi

View File

@ -1,6 +1,6 @@
diff -Nru asterisk-1.4.18.org/Makefile asterisk-1.4.18/Makefile
--- asterisk-1.4.18.org/Makefile 2008-01-29 18:21:33.000000000 +0100
+++ asterisk-1.4.19.1/Makefile 2008-03-02 19:39:23.000000000 +0100
diff -Nru asterisk-1.4.22.org/Makefile asterisk-1.4.22/Makefile
--- asterisk-1.4.22.org/Makefile 2008-09-08 22:15:42.000000000 +0200
+++ asterisk-1.4.22/Makefile 2008-11-29 15:05:12.000000000 +0100
@@ -215,7 +215,7 @@
endif

View File

@ -1,7 +1,7 @@
diff -Nru asterisk-1.4.18.org/acinclude.m4 asterisk-1.4.18/acinclude.m4
--- asterisk-1.4.18.org/acinclude.m4 2007-07-25 19:14:14.000000000 +0200
+++ asterisk-1.4.19.1/acinclude.m4 2008-03-02 19:40:27.000000000 +0100
@@ -508,6 +508,7 @@
diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
--- asterisk-1.4.22.org/acinclude.m4 2008-07-22 22:49:41.000000000 +0200
+++ asterisk-1.4.22/acinclude.m4 2008-11-29 15:06:28.000000000 +0100
@@ -588,6 +588,7 @@
;;
esac
AC_MSG_RESULT(${OPENH323_BUILD})
@ -9,10 +9,10 @@ diff -Nru asterisk-1.4.18.org/acinclude.m4 asterisk-1.4.18/acinclude.m4
AC_SUBST([OPENH323_SUFFIX])
AC_SUBST([OPENH323_BUILD])
diff -Nru asterisk-1.4.18.org/configure.ac asterisk-1.4.18/configure.ac
--- asterisk-1.4.18.org/configure.ac 2008-01-16 02:13:27.000000000 +0100
+++ asterisk-1.4.19.1/configure.ac 2008-03-02 19:40:27.000000000 +0100
@@ -835,7 +835,7 @@
diff -Nru asterisk-1.4.22.org/configure.ac asterisk-1.4.22/configure.ac
--- asterisk-1.4.22.org/configure.ac 2008-09-08 18:26:00.000000000 +0200
+++ asterisk-1.4.22/configure.ac 2008-11-29 15:06:28.000000000 +0100
@@ -1259,7 +1259,7 @@
if test "${HAS_PWLIB:-unset}" != "unset"; then
AST_CHECK_OPENH323_PLATFORM()

View File

@ -1,7 +1,7 @@
diff -urN asterisk-1.4.11.orig/acinclude.m4 asterisk-1.4.11/acinclude.m4
--- asterisk-1.4.11.orig/acinclude.m4 2008-09-13 04:34:47.000000000 +0200
+++ asterisk-1.4.11/acinclude.m4 2008-09-13 04:35:19.000000000 +0200
@@ -585,7 +585,7 @@
diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
--- asterisk-1.4.22.org/acinclude.m4 2008-07-22 22:49:41.000000000 +0200
+++ asterisk-1.4.22/acinclude.m4 2008-11-29 15:08:07.000000000 +0100
@@ -664,7 +664,7 @@
[assume the C compiler uses GNU ld @<:@default=no@:>@])],
[test "$withval" = no || with_gnu_ld=yes],
[with_gnu_ld=no])
@ -10,7 +10,7 @@ diff -urN asterisk-1.4.11.orig/acinclude.m4 asterisk-1.4.11/acinclude.m4
AC_REQUIRE([AC_PROG_CC])dnl
AC_REQUIRE([AC_CANONICAL_HOST])dnl
AC_REQUIRE([AC_CANONICAL_BUILD])dnl
@@ -690,28 +690,6 @@
@@ -769,28 +769,6 @@
AC_SUBST([EGREP])
])]) # AST_PROG_EGREP