Upgrade imapfilter to 2.0.10 (#769
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11809 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
dade8dd899
commit
b80cac5dbd
@ -9,23 +9,35 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=imapfilter
|
||||
PKG_VERSION:=1.2.2
|
||||
PKG_VERSION:=2.0.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://imapfilter.hellug.gr/source/
|
||||
PKG_MD5SUM:=4c1f28dffbb727a4769948f10baccd79
|
||||
PKG_MD5SUM:=7a82c69a71105da185cb4dd7c57b01f7
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/imapfilter
|
||||
SECTION:=mail
|
||||
CATEGORY:=Mail
|
||||
DEPENDS:=+liblua +libopenssl
|
||||
DEPENDS:=+liblua +libopenssl +libpcre
|
||||
TITLE:=IMAP server based email filtering
|
||||
URL:=http://imapfilter.hellug.gr/
|
||||
endef
|
||||
|
||||
define Package/imapfilter/description
|
||||
IMAPFilter is a mail filtering utility. It connects to remote mail
|
||||
servers using the Internet Message Access Protocol (IMAP), sends
|
||||
searching queries to the server and processes mailboxes based on the
|
||||
results. It can be used to delete, copy, move, flag, etc. messages
|
||||
residing in mailboxes at the same or different mail servers. The 4rev1
|
||||
and 4 versions of the IMAP protocol are supported.
|
||||
|
||||
IMAPFilter uses the Lua programming language as a configuration and
|
||||
extension language.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
./configure \
|
||||
@ -51,8 +63,7 @@ define Package/imapfilter/install
|
||||
$(INSTALL_DIR) $(1)/etc/imapfilter
|
||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/sample.config.lua $(1)/etc/imapfilter/config.lua
|
||||
$(INSTALL_DIR) $(1)/usr/share/imapfilter
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/interface.lua $(1)/usr/share/imapfilter/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/auxiliary.lua $(1)/usr/share/imapfilter/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/{account,auxiliary,common,mailbox,message,options,regex,set}.lua $(1)/usr/share/imapfilter/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,imapfilter))
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- imapfilter-1.2.2/pathnames.h 2006-08-01 14:11:20.000000000 +0200
|
||||
+++ imapfilter-1.2.2/pathnames.h 2006-09-07 23:58:12.000000000 +0200
|
||||
--- a/pathnames.h
|
||||
+++ b/pathnames.h
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
/* Program's configuration file. */
|
||||
#define PATHNAME_CONFIG PATHNAME_HOME "/config.lua"
|
||||
@@ -18,7 +18,7 @@
|
||||
@@ -39,7 +39,7 @@
|
||||
#define PATHNAME_CERTS PATHNAME_HOME "/certificates"
|
||||
|
||||
/* Debug temporary file template. */
|
||||
@ -18,8 +18,8 @@
|
||||
|
||||
|
||||
#endif /* PATHNAMES_H */
|
||||
--- imapfilter-1.2.2/imapfilter.c 2006-09-08 00:02:11.000000000 +0200
|
||||
+++ imapfilter-1.2.2/imapfilter.c 2006-09-08 00:02:32.000000000 +0200
|
||||
--- a/imapfilter.c
|
||||
+++ b/imapfilter.c
|
||||
@@ -50,7 +50,7 @@
|
||||
opts.config = NULL;
|
||||
opts.oneline = NULL;
|
||||
|
Loading…
x
Reference in New Issue
Block a user