[packages] openssh: update to v5.2p1 (partially closes: #4780, thanks to puchu)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15462 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9c7603b355
commit
b8e63fb44a
@ -8,7 +8,7 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openssh
|
PKG_NAME:=openssh
|
||||||
PKG_VERSION:=5.0p1
|
PKG_VERSION:=5.2p1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
|||||||
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
||||||
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
||||||
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
||||||
PKG_MD5SUM:=1f1dfaa775f33dd3328169de9bdc292a
|
PKG_MD5SUM:=ada79c7328a8551bdf55c95e631e7dad
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libopenssl
|
PKG_BUILD_DEPENDS:=libopenssl
|
||||||
|
|
||||||
|
@ -1,12 +1,12 @@
|
|||||||
--- a/cipher.c
|
--- a/cipher.c
|
||||||
+++ b/cipher.c
|
+++ b/cipher.c
|
||||||
@@ -72,7 +72,9 @@
|
@@ -73,7 +73,9 @@ struct Cipher {
|
||||||
|
|
||||||
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, EVP_des_ede3_cbc },
|
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, 1, EVP_des_ede3_cbc },
|
||||||
{ "blowfish-cbc", SSH_CIPHER_SSH2, 8, 16, 0, EVP_bf_cbc },
|
{ "blowfish-cbc", SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_bf_cbc },
|
||||||
+#ifndef OPENSSL_NO_CAST
|
+#ifndef OPENSSL_NO_CAST
|
||||||
{ "cast128-cbc", SSH_CIPHER_SSH2, 8, 16, 0, EVP_cast5_cbc },
|
{ "cast128-cbc", SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_cast5_cbc },
|
||||||
+#endif
|
+#endif
|
||||||
{ "arcfour", SSH_CIPHER_SSH2, 8, 16, 0, EVP_rc4 },
|
{ "arcfour", SSH_CIPHER_SSH2, 8, 16, 0, 0, EVP_rc4 },
|
||||||
{ "arcfour128", SSH_CIPHER_SSH2, 8, 16, 1536, EVP_rc4 },
|
{ "arcfour128", SSH_CIPHER_SSH2, 8, 16, 1536, 0, EVP_rc4 },
|
||||||
{ "arcfour256", SSH_CIPHER_SSH2, 8, 32, 1536, EVP_rc4 },
|
{ "arcfour256", SSH_CIPHER_SSH2, 8, 32, 1536, 0, EVP_rc4 },
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/mac.c
|
--- a/mac.c
|
||||||
+++ b/mac.c
|
+++ b/mac.c
|
||||||
@@ -59,8 +59,10 @@
|
@@ -59,8 +59,10 @@ struct {
|
||||||
{ "hmac-sha1-96", SSH_EVP, EVP_sha1, 96, -1, -1 },
|
{ "hmac-sha1-96", SSH_EVP, EVP_sha1, 96, -1, -1 },
|
||||||
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
|
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
|
||||||
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
|
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
|
||||||
|
12
net/openssh/patches/130-implicit_memset_decl_fix.patch
Normal file
12
net/openssh/patches/130-implicit_memset_decl_fix.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- a/includes.h
|
||||||
|
+++ b/includes.h
|
||||||
|
@@ -56,6 +56,9 @@
|
||||||
|
/*
|
||||||
|
*-*-nto-qnx needs these headers for strcasecmp and LASTLOG_FILE respectively
|
||||||
|
*/
|
||||||
|
+#ifdef HAVE_STRING_H
|
||||||
|
+# include <string.h>
|
||||||
|
+#endif
|
||||||
|
#ifdef HAVE_STRINGS_H
|
||||||
|
# include <strings.h>
|
||||||
|
#endif
|
Loading…
x
Reference in New Issue
Block a user