mc: add a patch to fix the annoying error message about missing Syntax file (#2133)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8182 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-07-26 15:44:00 +00:00
parent 33f4742ad1
commit bae28c11de
2 changed files with 20 additions and 1 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mc
PKG_VERSION:=4.6.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/

View File

@ -0,0 +1,19 @@
Index: mc-4.6.1/edit/syntax.c
===================================================================
--- mc-4.6.1.orig/edit/syntax.c 2007-07-26 17:35:14.000000000 +0200
+++ mc-4.6.1/edit/syntax.c 2007-07-26 17:35:14.000000000 +0200
@@ -1113,13 +1113,8 @@
f = catstrs (home_dir, SYNTAX_FILE, (char *) NULL);
r = edit_read_syntax_file (edit, names, f, edit ? edit->filename : 0,
get_first_editor_line (edit), type);
- if (r == -1) {
- edit_free_syntax_rules (edit);
- message (D_ERROR, _(" Load syntax file "),
- _(" Cannot open file %s \n %s "), f,
- unix_error_string (errno));
+ if (r == -1)
return;
- }
if (r) {
edit_free_syntax_rules (edit);
message (D_ERROR, _(" Load syntax file "),