Port icecast to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4405 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
04c83df055
commit
bc010047d7
99
net/icecast/Makefile
Normal file
99
net/icecast/Makefile
Normal file
@ -0,0 +1,99 @@
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=icecast
|
||||
PKG_VERSION:=2.3.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=35256fbc4a93571662af2ed18fbbfcc5
|
||||
|
||||
PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/icecast/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/icecast
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libcurl +libvorbisidec +libxml2 +libxslt
|
||||
TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
|
||||
DESCRIPTION:=Icecast is a streaming media server which currently supports Ogg\\\
|
||||
Vorbis and MP3 audio streams. It can be used to create an Internet\\\
|
||||
radio station or a privately running jukebox and many things in\\\
|
||||
between. It is very versatile in that new formats can be added\\\
|
||||
relatively easily and supports open standards for commuincation and\\\
|
||||
interaction.\\\
|
||||
URL:=http://www.icecast.org/
|
||||
endef
|
||||
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 " \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-rpath \
|
||||
--with-gnu-ld \
|
||||
--enable-yp \
|
||||
--with-curl="yes" \
|
||||
--with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
|
||||
--with-ogg="$(STAGING_DIR)/usr" \
|
||||
--with-speex="no" \
|
||||
--with-theora="no" \
|
||||
--with-vorbis="$(STAGING_DIR)/usr" \
|
||||
--with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config" \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/icecast/install
|
||||
install -d -m0755 $(1)/etc
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/icecast.xml $(1)/etc/
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/icecast $(1)/usr/bin/
|
||||
install -d -m0755 $(1)/usr/share/icecast
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/admin $(1)/usr/share/icecast/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/icecast/web $(1)/usr/share/icecast/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,icecast))
|
153
net/icecast/patches/01-icecast-2.3.0-tremor.patch
Normal file
153
net/icecast/patches/01-icecast-2.3.0-tremor.patch
Normal file
@ -0,0 +1,153 @@
|
||||
diff -rNu icecast-2.3.0.old/configure icecast-2.3.0.new/configure
|
||||
--- icecast-2.3.0.old/configure 2005-09-24 07:18:46.000000000 +1000
|
||||
+++ icecast-2.3.0.new/configure 2005-10-07 22:08:29.000000000 +1000
|
||||
@@ -21967,7 +21967,7 @@
|
||||
if test "${xt_cv_lib_ogg+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- OGG_LIBS="-logg"
|
||||
+ OGG_LIBS="-lvorbisidec"
|
||||
|
||||
#
|
||||
# check if the installed Ogg is sufficiently new.
|
||||
@@ -22033,7 +22033,7 @@
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
int
|
||||
main ()
|
||||
{
|
||||
@@ -22188,9 +22188,9 @@
|
||||
|
||||
fi
|
||||
|
||||
-VORBIS_LIBS="-lvorbis"
|
||||
-VORBISFILE_LIBS="-lvorbisfile"
|
||||
-VORBISENC_LIBS="-lvorbisenc"
|
||||
+VORBIS_LIBS="-lvorbisidec"
|
||||
+VORBISFILE_LIBS="-lvorbisidec"
|
||||
+VORBISENC_LIBS="-lvorbisidec"
|
||||
|
||||
xt_save_LIBS="$LIBS"
|
||||
xt_save_LDFLAGS="$LDFLAGS"
|
||||
@@ -22327,17 +22327,18 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
|
||||
-#include <vorbis/codec.h>
|
||||
-#include <vorbis/vorbisenc.h>
|
||||
+#include <tremor/ivorbiscodec.h>
|
||||
|
||||
|
||||
int
|
||||
main ()
|
||||
{
|
||||
+/*
|
||||
if ((struct ovectl_ratemanage_arg *) 0)
|
||||
return 0;
|
||||
if (sizeof (struct ovectl_ratemanage_arg))
|
||||
return 0;
|
||||
+*/
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
diff -rNu icecast-2.3.0.old/src/format_flac.c icecast-2.3.0.new/src/format_flac.c
|
||||
--- icecast-2.3.0.old/src/format_flac.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_flac.c 2005-10-07 22:10:24.000000000 +1000
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include <string.h>
|
||||
|
||||
typedef struct source_tag source_t;
|
||||
diff -rNu icecast-2.3.0.old/src/format_midi.c icecast-2.3.0.new/src/format_midi.c
|
||||
--- icecast-2.3.0.old/src/format_midi.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_midi.c 2005-10-07 22:10:12.000000000 +1000
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include <string.h>
|
||||
|
||||
typedef struct source_tag source_t;
|
||||
diff -rNu icecast-2.3.0.old/src/format_ogg.c icecast-2.3.0.new/src/format_ogg.c
|
||||
--- icecast-2.3.0.old/src/format_ogg.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_ogg.c 2005-10-07 22:10:02.000000000 +1000
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
|
||||
#include "refbuf.h"
|
||||
#include "source.h"
|
||||
diff -rNu icecast-2.3.0.old/src/format_ogg.h icecast-2.3.0.new/src/format_ogg.h
|
||||
--- icecast-2.3.0.old/src/format_ogg.h 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_ogg.h 2005-10-07 22:09:51.000000000 +1000
|
||||
@@ -18,7 +18,7 @@
|
||||
#ifndef __FORMAT_OGG_H__
|
||||
#define __FORMAT_OGG_H__
|
||||
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include "refbuf.h"
|
||||
#include "format.h"
|
||||
|
||||
diff -rNu icecast-2.3.0.old/src/format_speex.c icecast-2.3.0.new/src/format_speex.c
|
||||
--- icecast-2.3.0.old/src/format_speex.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_speex.c 2005-10-07 22:09:44.000000000 +1000
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include <speex/speex_header.h>
|
||||
|
||||
typedef struct source_tag source_t;
|
||||
diff -rNu icecast-2.3.0.old/src/format_theora.c icecast-2.3.0.new/src/format_theora.c
|
||||
--- icecast-2.3.0.old/src/format_theora.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_theora.c 2005-10-07 22:09:38.000000000 +1000
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include <theora/theora.h>
|
||||
|
||||
typedef struct source_tag source_t;
|
||||
diff -rNu icecast-2.3.0.old/src/format_vorbis.c icecast-2.3.0.new/src/format_vorbis.c
|
||||
--- icecast-2.3.0.old/src/format_vorbis.c 2005-08-19 12:01:58.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/format_vorbis.c 2005-10-07 22:09:29.000000000 +1000
|
||||
@@ -18,8 +18,8 @@
|
||||
#endif
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <ogg/ogg.h>
|
||||
-#include <vorbis/codec.h>
|
||||
+#include <tremor/ogg.h>
|
||||
+#include <tremor/ivorbiscodec.h>
|
||||
#include <memory.h>
|
||||
#include <string.h>
|
||||
|
||||
diff -rNu icecast-2.3.0.old/src/source.c icecast-2.3.0.new/src/source.c
|
||||
--- icecast-2.3.0.old/src/source.c 2005-09-23 06:19:28.000000000 +1000
|
||||
+++ icecast-2.3.0.new/src/source.c 2005-10-07 22:09:17.000000000 +1000
|
||||
@@ -19,7 +19,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
-#include <ogg/ogg.h>
|
||||
+#include <tremor/ogg.h>
|
||||
#include <errno.h>
|
||||
|
||||
#ifndef _WIN32
|
27127
net/icecast/patches/icecast-2.3.0-curl_config.patch
Normal file
27127
net/icecast/patches/icecast-2.3.0-curl_config.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
x
Reference in New Issue
Block a user