[packages] openswan: fix setup scripts (#8029)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25609 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a0025e2b8a
commit
c2b3b465a4
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=openswan
|
||||
PKG_VERSION:=2.6.29
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.openswan.org/download
|
||||
|
@ -5,32 +5,32 @@
|
||||
3 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
--- /dev/null
|
||||
+++ openswan-2.6.29/programs/loggerfix
|
||||
+++ b/programs/loggerfix
|
||||
@@ -0,0 +1,5 @@
|
||||
+#!/bin/sh
|
||||
+# use filename instead of /dev/null to log, but dont log to flash or ram
|
||||
+# pref. log to nfs mount
|
||||
+echo "$*" >> /dev/null
|
||||
+exit 0
|
||||
--- openswan-2.6.29.orig/programs/_plutorun/_plutorun.in
|
||||
+++ openswan-2.6.29/programs/_plutorun/_plutorun.in
|
||||
--- a/programs/_plutorun/_plutorun.in
|
||||
+++ b/programs/_plutorun/_plutorun.in
|
||||
@@ -155,7 +155,7 @@ then
|
||||
exit 1
|
||||
fi
|
||||
else
|
||||
- if test ! -w "`dirname $stderrlog`"
|
||||
+ if test ! -w "`echo $stderrlog | sed -r 's/(^.*\/)(.*$)/\1/'`"
|
||||
+ if test ! -w "${stderrlog%/*}"
|
||||
then
|
||||
echo Cannot write to directory to create \"$stderrlog\".
|
||||
exit 1
|
||||
--- openswan-2.6.29.orig/programs/_realsetup/_realsetup.in
|
||||
+++ openswan-2.6.29/programs/_realsetup/_realsetup.in
|
||||
--- a/programs/_realsetup/_realsetup.in
|
||||
+++ b/programs/_realsetup/_realsetup.in
|
||||
@@ -290,7 +290,7 @@ case "$1" in
|
||||
|
||||
# misc pre-Pluto setup
|
||||
|
||||
- perform test -d $subsysdir "&&" touch $subsyslock
|
||||
+ rm test -d `echo $subsyslock | sed -r 's/(^.*\/)(.*$)/\1/'` "&&" touch $subsyslock "&&" rm -f $subsyslock
|
||||
+ perfrom test -d "${subsyslock%/*}" "&&" touch $subsyslock "&&" rm -f $subsyslock
|
||||
|
||||
manualconns
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user