port pcre to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4141 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
822b05e6a9
commit
c4d74baf14
101
libs/pcre/Makefile
Normal file
101
libs/pcre/Makefile
Normal file
@ -0,0 +1,101 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pcre
|
||||
PKG_VERSION:=5.0
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/pcre
|
||||
PKG_MD5SUM:=813850808894d99fb5b1c41ec6335d4f
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libpcre
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=A Perl Compatible Regular Expression library
|
||||
DESCRIPTION:=A Perl Compatible Regular Expression library.
|
||||
URL:=http://www.pcre.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--enable-utf8 \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
CC_FOR_BUILD="$(HOSTCC)" \
|
||||
LINK_FOR_BUILD="$(HOSTCC)" \
|
||||
CFLAGS_FOR_BUILD="" \
|
||||
dftables
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libpcre/install
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/pcre{,posix}.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/pcre-config \
|
||||
$(STAGING_DIR)/usr/include/pcre{,posix}.h \
|
||||
$(STAGING_DIR)/usr/lib/libpcre{,posix}.{a,so*}
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libpcre))
|
24
libs/pcre/patches/100-honor_cppflags_ldflags.patch
Normal file
24
libs/pcre/patches/100-honor_cppflags_ldflags.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN pcre-5.0-old/Makefile.in pcre-5.0-new/Makefile.in
|
||||
--- pcre-5.0-old/Makefile.in 2004-09-13 16:20:00.000000000 +0200
|
||||
+++ pcre-5.0-new/Makefile.in 2006-03-15 08:28:12.000000000 +0100
|
||||
@@ -63,6 +63,7 @@
|
||||
CC = @CC@
|
||||
CFLAGS = @CFLAGS@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
|
||||
CC_FOR_BUILD = @CC_FOR_BUILD@
|
||||
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
|
||||
@@ -84,10 +85,10 @@
|
||||
# to do one or the other or both by ./configure.
|
||||
|
||||
LIBTOOL = @LIBTOOL@
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
|
||||
@ON_WINDOWS@LINK = $(CC) $(CFLAGS) -I. -I$(top_srcdir) -L.libs
|
||||
@NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
|
||||
-LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
|
||||
+LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir) $(LDFLAGS)
|
||||
LINK_FOR_BUILD = $(LIBTOOL) --mode=link $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -I. -I$(top_srcdir)
|
||||
|
||||
# These are the version numbers for the shared libraries
|
27
libs/pcre/patches/750-pcre_config_cross.patch
Normal file
27
libs/pcre/patches/750-pcre_config_cross.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -ruN pcre-5.0-old/pcre-config.in pcre-5.0-new/pcre-config.in
|
||||
--- pcre-5.0-old/pcre-config.in 2004-09-13 16:20:00.000000000 +0200
|
||||
+++ pcre-5.0-new/pcre-config.in 2005-09-04 16:34:39.000000000 +0200
|
||||
@@ -18,6 +18,10 @@
|
||||
libR=" -R@libdir@"
|
||||
;;
|
||||
esac
|
||||
+libS=
|
||||
+if test @libdir@ != /usr/lib ; then
|
||||
+ libS=-L@libdir@
|
||||
+fi
|
||||
|
||||
while test $# -gt 0; do
|
||||
case "$1" in
|
||||
@@ -52,10 +56,10 @@
|
||||
echo $includes
|
||||
;;
|
||||
--libs-posix)
|
||||
- echo -L@libdir@$libR -lpcreposix -lpcre
|
||||
+ echo $libS$libR -lpcreposix -lpcre
|
||||
;;
|
||||
--libs)
|
||||
- echo -L@libdir@$libR -lpcre
|
||||
+ echo $libS$libR -lpcre
|
||||
;;
|
||||
*)
|
||||
echo "${usage}" 1>&2
|
Loading…
x
Reference in New Issue
Block a user