[packages] upx: update to 3.05

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21553 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2010-05-23 21:11:51 +00:00
parent 11e780ba8c
commit c51ed0d5b1
3 changed files with 7 additions and 29 deletions

View File

@ -1,4 +1,4 @@
#
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=upx
PKG_VERSION:=3.04
PKG_VERSION:=3.05
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
PKG_SOURCE_URL:=http://upx.sourceforge.net/download/
PKG_MD5SUM:=68d662b1f831335460f9bfdbf632c6ce
PKG_SOURCE_URL:=http://upx.sourceforge.net/download
PKG_MD5SUM:=1f0ca94c8c26a816402274dd7e628334
include $(INCLUDE_DIR)/package.mk

View File

@ -1,6 +1,5 @@
diff -pruN upx-3.04.orig//Makefile upx-3.04/Makefile
--- upx-3.04.orig//Makefile 2010-02-18 15:07:46.894410571 +0100
+++ upx-3.04/Makefile 2010-02-18 15:08:32.758657685 +0100
--- a/Makefile
+++ b/Makefile
@@ -35,7 +35,7 @@ ifeq ($(BUILD_STUB),1)
$(MAKE) -C src/stub $@
endif
@ -9,4 +8,4 @@ diff -pruN upx-3.04.orig//Makefile upx-3.04/Makefile
+# $(MAKE) -C doc $@
ifneq ($(wildcard .hg/.),)
.PHONY: default all mostlyclean clean distclean maintainer-clean

View File

@ -1,21 +0,0 @@
--- a/src/miniacc.h
+++ b/src/miniacc.h
@@ -756,6 +756,9 @@
#elif (UINT_MAX <= ACC_0xffffL) && defined(__AVR__)
# define ACC_ARCH_AVR 1
# define ACC_INFO_ARCH "avr"
+#elif defined(__avr32__)
+# define ACC_ARCH_AVR32 1
+# define ACC_INFO_ARCH "avr32"
#elif defined(__bfin__)
# define ACC_ARCH_BLACKFIN 1
# define ACC_INFO_ARCH "blackfin"
@@ -1316,7 +1319,7 @@ extern "C" {
# define ACC_ABI_BIG_ENDIAN 1
#elif (ACC_ARCH_ALPHA || ACC_ARCH_AMD64 || ACC_ARCH_BLACKFIN || ACC_ARCH_CRIS || ACC_ARCH_I086 || ACC_ARCH_I386 || ACC_ARCH_MSP430)
# define ACC_ABI_LITTLE_ENDIAN 1
-#elif (ACC_ARCH_M68K || ACC_ARCH_S390)
+#elif (ACC_ARCH_AVR32 || ACC_ARCH_M68K || ACC_ARCH_S390)
# define ACC_ABI_BIG_ENDIAN 1
#elif 1 && defined(__IAR_SYSTEMS_ICC__) && defined(__LITTLE_ENDIAN__)
# if (__LITTLE_ENDIAN__ == 1)