add <orbit2> - a corba-compliant Object Request Broker implementation
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16462 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e5eb35e374
commit
c568d82760
102
libs/orbit2/Makefile
Normal file
102
libs/orbit2/Makefile
Normal file
@ -0,0 +1,102 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=orbit2
|
||||
PKG_VERSION:=2.14.16
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/ORBit2-$(PKG_VERSION)
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/ORBit2-$(PKG_VERSION)
|
||||
PKG_SOURCE:=ORBit2-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@GNOME/ORBit2/2.14
|
||||
#PKG_MD5SUM:=d7fb9eb41e8196f1aacf2f08375ae555
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
HOST_BUILD_DEPENDS:=libIDL2/host
|
||||
PKG_BUILD_DEPENDS:=orbit2/host
|
||||
|
||||
TARGET_CFLAGS+= \
|
||||
-I$(STAGING_DIR)/usr/lib/libintl/include \
|
||||
-I$(STAGING_DIR)/usr/libiconv/include
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib
|
||||
|
||||
BIGENDIAN=no
|
||||
ifeq ($(CONFIG_BIG_ENDIAN),y)
|
||||
BIGENDIAN:=yes
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_c_bigendian=$(BIGENDIAN) \
|
||||
ac_cv_alignof_CORBA_octet=1 \
|
||||
ac_cv_alignof_CORBA_boolean=1 \
|
||||
ac_cv_alignof_CORBA_char=1 \
|
||||
ac_cv_alignof_CORBA_wchar=2 \
|
||||
ac_cv_alignof_CORBA_short=2 \
|
||||
ac_cv_alignof_CORBA_long=4 \
|
||||
ac_cv_alignof_CORBA_long_long=4 \
|
||||
ac_cv_alignof_CORBA_float=4 \
|
||||
ac_cv_alignof_CORBA_double=4 \
|
||||
ac_cv_alignof_CORBA_long_double=4 \
|
||||
ac_cv_alignof_CORBA_struct=1 \
|
||||
ac_cv_alignof_CORBA_pointer=4
|
||||
|
||||
define Package/orbit2
|
||||
SECTION:=xorg-libs
|
||||
CATEGORY:=Xorg
|
||||
SUBMENU:=libraries
|
||||
TITLE:=ORBit2
|
||||
URL:=http://www.gnome.org/projects/ORBit2/
|
||||
DEPENDS:=+glib2 +libIDL2
|
||||
endef
|
||||
|
||||
define Package/orbit2/description
|
||||
ORBit2 is a CORBA 2.4-compliant Object Request Broker (ORB).
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
find $(PKG_BUILD_DIR) -name Makefile -exec sed -i 's,IDL_COMPILER.*orbit-idl-2,IDL_COMPILER = $(STAGING_DIR_HOST)/bin/orbit-idl-2,g' {} \; # tell orbit2 to use the host-built idl-compiler
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/{include/orbit-2.0,lib/pkgconfig}
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/orbit-2.0/* \
|
||||
$(1)/usr/include/orbit-2.0/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/share/aclocal
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/aclocal/* \
|
||||
$(1)/usr/share/aclocal/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/share/idl/orbit-2.0
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/idl/orbit-2.0/* \
|
||||
$(1)/usr/share/idl/orbit-2.0/
|
||||
endef
|
||||
|
||||
define Package/orbit2/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libORBit*.so* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,orbit2))
|
13
libs/orbit2/patches/010-dont-run-testprograms.patch
Normal file
13
libs/orbit2/patches/010-dont-run-testprograms.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/configure b/configure
|
||||
index bd8d550..74c5330 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -24219,7 +24219,7 @@ if test "$cross_compiling" = yes; then
|
||||
See \`config.log' for more details." >&5
|
||||
$as_echo "$as_me: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+ }
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
Loading…
x
Reference in New Issue
Block a user