port xinetd to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4268 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9feab7d7cf
commit
c7d24c57fd
88
net/xinetd/Makefile
Normal file
88
net/xinetd/Makefile
Normal file
@ -0,0 +1,88 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xinetd
|
||||
PKG_VERSION:=2.3.13
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.xinetd.org/
|
||||
PKG_MD5SUM:=4295b5fe12350f09b5892b363348ac8b
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/xinetd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=A powerful and secure super-server
|
||||
DESCRIPTION:=A powerful and secure super-server.
|
||||
URL:=http://www.xinetd.org/
|
||||
endef
|
||||
|
||||
define Package/xinetd/conffiles
|
||||
/etc/xinetd.conf
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--without-libwrap \
|
||||
--with-loadavg \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
build install
|
||||
endef
|
||||
|
||||
define Package/xinetd/install
|
||||
install -d -m0755 $(1)/etc
|
||||
install -m0644 ./files/xinetd.conf $(1)/etc/xinetd.conf
|
||||
install -d -m0755 $(1)/etc/xinetd.d
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m0755 ./files/xinetd.init $(1)/etc/init.d/xinetd
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/xinetd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,xinetd))
|
6
net/xinetd/files/xinetd.conf
Normal file
6
net/xinetd/files/xinetd.conf
Normal file
@ -0,0 +1,6 @@
|
||||
defaults
|
||||
{
|
||||
|
||||
}
|
||||
|
||||
includedir /etc/xinetd.d
|
21
net/xinetd/files/xinetd.init
Normal file
21
net/xinetd/files/xinetd.init
Normal file
@ -0,0 +1,21 @@
|
||||
#!/bin/sh
|
||||
|
||||
DEFAULT=/etc/default/xinetd
|
||||
RUN_D=/var/run
|
||||
PID_F=$RUN_D/xinetd.pid
|
||||
[ -f $DEFAULT ] && . $DEFAULT
|
||||
|
||||
case $1 in
|
||||
start)
|
||||
[ -d $RUN_D ] || mkdir -p $RUN_D
|
||||
xinetd $OPTIONS
|
||||
;;
|
||||
stop)
|
||||
[ -f $PID_F ] && kill $(cat $PID_F)
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 (start|stop)"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit $?
|
72
net/xinetd/patches/ar.patch
Normal file
72
net/xinetd/patches/ar.patch
Normal file
@ -0,0 +1,72 @@
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/misc/Makefile.in xinetd-2.3.13-6/libs/src/misc/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/misc/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/misc/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -62,7 +62,7 @@
|
||||
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
install: $(LIBNAME)
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/portable/Makefile.in xinetd-2.3.13-6/libs/src/portable/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/portable/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/portable/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -57,7 +57,7 @@
|
||||
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
install: $(LIBNAME)
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/pset/Makefile.in xinetd-2.3.13-6/libs/src/pset/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/pset/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/pset/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -53,7 +53,7 @@
|
||||
mv $(LIBNAME) $(LIBDIR)/optimized
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
install: $(LIBNAME)
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/sio/Makefile.in xinetd-2.3.13-6/libs/src/sio/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/sio/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/sio/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
$(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
install: $(LIBNAME)
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/str/Makefile.in xinetd-2.3.13-6/libs/src/str/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/str/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/str/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -63,7 +63,7 @@
|
||||
$(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
LINT_IGNORE=possible pointer alignment|RCSid unused
|
||||
diff -ruN xinetd-2.3.13-orig/libs/src/xlog/Makefile.in xinetd-2.3.13-6/libs/src/xlog/Makefile.in
|
||||
--- xinetd-2.3.13-orig/libs/src/xlog/Makefile.in 2003-02-19 18:29:27.000000000 +0100
|
||||
+++ xinetd-2.3.13-6/libs/src/xlog/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -58,7 +58,7 @@
|
||||
$(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- ar r $@ $?
|
||||
+ $(AR) r $@ $?
|
||||
$(RANLIB) $@
|
||||
|
||||
install: $(LIBNAME)
|
28
net/xinetd/patches/destdir.patch
Normal file
28
net/xinetd/patches/destdir.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -ruN xinetd-2.3.13-orig/Makefile.in xinetd-2.3.13-6/Makefile.in
|
||||
--- xinetd-2.3.13-orig/Makefile.in 2003-08-15 16:00:45.000000000 +0200
|
||||
+++ xinetd-2.3.13-6/Makefile.in 2005-03-09 22:53:15.000000000 +0100
|
||||
@@ -75,15 +75,15 @@
|
||||
|
||||
install: build
|
||||
for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
|
||||
- test -d $$i || mkdir -p $$i ; done
|
||||
- $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
|
||||
+ test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
|
||||
+ $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
|
||||
@echo "You must put your xinetd.conf in /etc/xinetd.conf"
|
||||
@echo "There is a sample config file in xinetd/sample.conf and you can"
|
||||
@echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
|
33
net/xinetd/patches/xinetd-2.3.13-gcc4-1.patch
Normal file
33
net/xinetd/patches/xinetd-2.3.13-gcc4-1.patch
Normal file
@ -0,0 +1,33 @@
|
||||
Submitted By: Randy McMurchy <randy_at_linuxfromscratch_dot_org>
|
||||
Date: 2005-08-07
|
||||
Initial Package Version: 2.3.13
|
||||
Upstream Status: Not submitted
|
||||
Origin: Fedora Development CVS
|
||||
Description: Fixes compilation error if using GCC-4.x
|
||||
|
||||
|
||||
diff -Naur xinetd-2.3.13-orig/xinetd/service.c xinetd-2.3.13/xinetd/service.c
|
||||
--- xinetd-2.3.13-orig/xinetd/service.c 2003-11-16 12:44:10.000000000 +0000
|
||||
+++ xinetd-2.3.13/xinetd/service.c 2005-08-07 18:37:33.395942648 +0000
|
||||
@@ -764,8 +764,8 @@
|
||||
return FAILED;
|
||||
|
||||
if ( last == NULL ) {
|
||||
- last = SAIN( SVC_LAST_DGRAM_ADDR(sp) ) =
|
||||
- SAIN( calloc( 1, sizeof(union xsockaddr) ) );
|
||||
+ SVC_LAST_DGRAM_ADDR(sp) = calloc( 1, sizeof(union xsockaddr) );
|
||||
+ last = SAIN(SVC_LAST_DGRAM_ADDR(sp));
|
||||
}
|
||||
|
||||
(void) time( ¤t_time ) ;
|
||||
@@ -791,8 +791,8 @@
|
||||
return FAILED;
|
||||
|
||||
if( last == NULL ) {
|
||||
- last = SAIN6(SVC_LAST_DGRAM_ADDR(sp)) =
|
||||
- SAIN6(calloc( 1, sizeof(union xsockaddr) ) );
|
||||
+ SVC_LAST_DGRAM_ADDR(sp) = calloc( 1, sizeof(union xsockaddr) );
|
||||
+ last = SAIN6( SVC_LAST_DGRAM_ADDR(sp) );
|
||||
}
|
||||
|
||||
(void) time( ¤t_time ) ;
|
Loading…
x
Reference in New Issue
Block a user