add fftw3 (patch from #3987)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12576 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cec2f97cbc
commit
c8e611ff9a
59
libs/fftw3/Makefile
Normal file
59
libs/fftw3/Makefile
Normal file
@ -0,0 +1,59 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
# $Id: $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fftw3
|
||||
PKG_VERSION:=3.1.2
|
||||
|
||||
|
||||
PKG_SOURCE_URL:=http://www.fftw.org/
|
||||
PKG_SOURCE:=fftw-3.1.2.tar.gz
|
||||
PKG_MD5SUM:=08f2e21c9fd02f4be2bd53a62592afa4
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/fftw-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/fftw3
|
||||
SECTION:=Libraries
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Fast Fourier transform library
|
||||
URL:=http://www.fftw.org/
|
||||
endef
|
||||
|
||||
define Package/fftw3/description
|
||||
FFTW is a collection of fast C routines for computing the
|
||||
Discrete Fourier Transform in one or more dimensions. It
|
||||
includes complex, real, and parallel transforms, and can
|
||||
handle arbitrary array sizes efficiently.
|
||||
http://www.fftw.org/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--prefix=/usr \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--disable-nls \
|
||||
--enable-shared \
|
||||
--enable-threads \
|
||||
--enable-double \
|
||||
--enable-type-prefix \
|
||||
--disable-debug \
|
||||
--disable-fortran \
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
|
||||
endef
|
||||
|
||||
define Package/fftw3/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fftw3))
|
21
libs/fftw3/patches/001-makefile.patch
Normal file
21
libs/fftw3/patches/001-makefile.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -Naur fftw-3.1.2/Makefile.in fftw-3.1.2-p/Makefile.in
|
||||
--- fftw-3.1.2/Makefile.in 2006-01-28 01:19:57.000000000 +0100
|
||||
+++ fftw-3.1.2-p/Makefile.in 2006-03-13 20:50:29.829075989 +0100
|
||||
@@ -112,7 +112,7 @@
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
DIST_SUBDIRS = support genfft genfft-k7 kernel simd dft rdft reodft \
|
||||
- threads api libbench2 . tests doc tools
|
||||
+ threads api libbench2 . doc tools
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
top_distdir = $(distdir)
|
||||
@@ -277,7 +277,7 @@
|
||||
@MAINTAINER_MODE_TRUE@GENFFT = genfft genfft-k7
|
||||
ACLOCAL_AMFLAGS = -I ./m4
|
||||
SUBDIRS = support $(GENFFT) kernel simd dft rdft reodft threads api \
|
||||
-libbench2 . tests doc tools
|
||||
+libbench2 .
|
||||
|
||||
EXTRA_DIST = COPYRIGHT bootstrap.sh CONVENTIONS fftw.pc.in m4
|
||||
@HAVE_SIMD_FALSE@SIMD_LIBS =
|
Loading…
x
Reference in New Issue
Block a user