Upgrade motion to 3.2.10.1 (#3678)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11651 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-07-05 12:45:00 +00:00
parent 1018e0f40d
commit cb89352cd1
3 changed files with 14 additions and 21 deletions

View File

@ -9,16 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=motion
PKG_VERSION:=3.2.9
PKG_VERSION:=3.2.10.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
@SF/motion
PKG_MD5SUM:=6003011b126c9b17e23e085e7fba6536
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM:=5ffdc958313345c69d3e0d5ec5c013cd
include $(INCLUDE_DIR)/package.mk

View File

@ -1,8 +1,6 @@
Index: motion-3.2.9/motion.c
===================================================================
--- motion-3.2.9.orig/motion.c
+++ motion-3.2.9/motion.c
@@ -1285,6 +1285,7 @@ static void *motion_loop(void *arg)
--- a/motion.c
+++ b/motion.c
@@ -1611,6 +1611,7 @@
* httpd-control snaps are always enabled.
*/
@ -10,8 +8,8 @@ Index: motion-3.2.9/motion.c
/* time_current_frame is used both for snapshot and timelapse features */
time_current_frame = cnt->currenttime;
@@ -1294,7 +1295,7 @@ static void *motion_loop(void *arg)
event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
@@ -1620,7 +1621,7 @@
event(cnt, EVENT_IMAGE_SNAPSHOT, cnt->current_image->image, NULL, NULL, &cnt->current_image->timestamp_tm);
cnt->snapshot = 0;
}
-
@ -19,7 +17,7 @@ Index: motion-3.2.9/motion.c
/***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
@@ -1369,9 +1370,9 @@ static void *motion_loop(void *arg)
@@ -1695,9 +1696,9 @@
event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);

View File

@ -1,16 +1,14 @@
Index: motion-3.2.9/Makefile.in
===================================================================
--- motion-3.2.9.orig/Makefile.in
+++ motion-3.2.9/Makefile.in
@@ -33,6 +33,7 @@ examplesdir = $(docdir)/examples
--- a/Makefile.in
+++ b/Makefile.in
@@ -32,6 +32,7 @@
################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
-Dsysconfdir=\"$(sysconfdir)\"
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" \
-Dsysconfdir=\"$(sysconfdir)\" -Ddocdir=\"$(docdir)\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@
@@ -120,7 +121,7 @@ endif
@@ -119,7 +120,7 @@
################################################################################
$(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..."