[packages] anyremote: upgrade to version 6.2
Signed-off-by: Mikhail Fedotov <anyremote@mail.ru> git-svn-id: svn://svn.openwrt.org/openwrt/packages@35550 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
267e737434
commit
cbca2c811f
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2008-2011 OpenWrt.org
|
||||
# Copyright (C) 2008-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=anyremote
|
||||
PKG_VERSION:=4.7.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=6.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/${PKG_NAME}
|
||||
PKG_MD5SUM:=bd177156faa8a59a5d3e02cada243fc3
|
||||
PKG_MD5SUM:=130369d8f632127b20de67930386e9ca
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -21,7 +21,7 @@ define Package/anyremote
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=A bluetooth remote control app
|
||||
DEPENDS:=+bluez-libs
|
||||
DEPENDS:=+bluez-libs +libpthread
|
||||
URL:=http://anyremote.sourceforge.net/
|
||||
endef
|
||||
|
||||
@ -31,7 +31,7 @@ endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--disable-xtest \
|
||||
--disable-xtest --disable-glib --disable-iconv \
|
||||
)
|
||||
endef
|
||||
|
||||
|
@ -1,66 +1,105 @@
|
||||
%
|
||||
% anyremote configuration file for sound management. (Server-mode)
|
||||
% prerequisites: amixer utility
|
||||
% anyremote configuration file. (Server-mode)
|
||||
%
|
||||
|
||||
% STATUS stable
|
||||
% STATUS unknown
|
||||
% XTEST no
|
||||
% SOUND mixer
|
||||
% SOUND no
|
||||
% ENV no
|
||||
|
||||
% Uncomment if needed
|
||||
%AutoRepeat=false
|
||||
%Baudrate=19200
|
||||
Device=bluetooth:19
|
||||
%Log=true
|
||||
Screen=true
|
||||
|
||||
GuiAppName=Sound volume test
|
||||
GuiAppIcon=sound.png
|
||||
GuiAppName=Admin
|
||||
GuiAppType=Example
|
||||
GuiAppBinary=true
|
||||
GuiAppProtocols=Server
|
||||
GuiAppDesc=Show free space on disks, system uptime, dmesg output. Allows to reboot PC.
|
||||
|
||||
% 1 - increase sound volume
|
||||
% 2 - mute/unmute
|
||||
% 3 - increase sound volume
|
||||
% 5 - show list of available controls
|
||||
[Protocol]=Server
|
||||
|
||||
[Aliases]
|
||||
(Connect)=\
|
||||
ExecAndSet(status,uname -n);\
|
||||
ExecAndSet(title,whoami);\
|
||||
Set(icons,ADMIN,1,plus,2,default,3,default,4,default,5,default,6,default,7,default,8,default,9,default,*,question,0,no,#,default);
|
||||
|
||||
% Aliases for AverMedia IR remote
|
||||
VOLUMEDOWN=1
|
||||
MIN_INTERESTING=2
|
||||
VOLUMEUP=3
|
||||
TEXT=*
|
||||
* *=\
|
||||
Set(text,replace,Help,1 - Show list of features)
|
||||
|
||||
Back=\
|
||||
Set(text,close);
|
||||
|
||||
1=\
|
||||
Make(mode,LIST);
|
||||
|
||||
|
||||
[Mode]=LIST
|
||||
|
||||
(EnterMode)=\
|
||||
Macro(ADM_LIST);\
|
||||
Set(menu,replace,Choose);
|
||||
|
||||
ADM_LIST=\
|
||||
Set(list,replace,Admin,Disk space,Uptime,Dmesg,Reboot,Shutdown);
|
||||
|
||||
DISK_SPACE=\
|
||||
ExecAndSet(text,replace,Free Space,df -kl|tr -s ' '|cut -f 1,4 -d ' ');\
|
||||
Make(mode,TXT);
|
||||
|
||||
UPTIME=\
|
||||
Set(list,close);\
|
||||
ExecAndSet(title,uptime|tr -s ' '|cut -d ' ' -f 3,4,5);\
|
||||
Make(mode,default);
|
||||
|
||||
DMESG=\
|
||||
ExecAndSet(text,replace,Dmesg output, dmesg|tail -50);\
|
||||
Make(mode,TXT);
|
||||
|
||||
REBOOT=\
|
||||
Exec(reboot);
|
||||
|
||||
SHUTDOWN=\
|
||||
Exec(poweroff);
|
||||
|
||||
Back($$)=\
|
||||
Set(list,close);\
|
||||
Make(mode,default);
|
||||
|
||||
Choose(Disk space)=\
|
||||
Macro(DISK_SPACE);
|
||||
|
||||
Choose(Uptime)=\
|
||||
Macro(UPTIME);
|
||||
|
||||
Choose(Dmesg)=\
|
||||
Macro(DMESG);
|
||||
|
||||
Choose(Reboot)=\
|
||||
Macro(REBOOT);
|
||||
|
||||
Choose(Shutdown)=\
|
||||
Macro(SHUTDOWN);
|
||||
|
||||
Push(Disk space)=\
|
||||
Macro(DISK_SPACE);
|
||||
|
||||
Push(Uptime)=\
|
||||
Macro(UPTIME);
|
||||
|
||||
Push(Dmesg)=\
|
||||
Macro(DMESG);
|
||||
|
||||
Push(Reboot)=\
|
||||
Macro(REBOOT);
|
||||
|
||||
Push(Shutdown)=\
|
||||
Macro(SHUTDOWN);
|
||||
|
||||
[ModeEnd]
|
||||
|
||||
[Mode]=TXT
|
||||
|
||||
Back=\
|
||||
Set(text,close);\
|
||||
Make(mode,LIST);
|
||||
|
||||
[ModeEnd]
|
||||
|
||||
[End]
|
||||
|
||||
[Keys]
|
||||
|
||||
(Init) =Macro(SET_CARD);Macro(TEST_MIXER);Macro(INIT_CONTROL);
|
||||
(Connect)=Set(parameter,debug,on);\
|
||||
Set(icons,SoundControl,1,minus,2,mute,3,plus,4,default,5,configure,6,default,7,default,8,default,9,default,0,default,*,question,#,default);\
|
||||
Macro(SET_VIEW);
|
||||
|
||||
SET_CARD =Make(var,mixer_card,echo 'if [ -f $HOME/.anyRemote/amixer.card ]; then cat $HOME/.anyRemote/amixer.card; else true; fi;'|bash -f -s);
|
||||
TEST_MIXER =Exec(echo 'TEST=`amixer $(mixer_card) sget Master,0`;U=`echo $TEST|grep "Usage: amixer" |wc -l`;KD=`which kdialog|grep kdialog|grep -v not|wc -l`;if [ "x$KD" == "x1" ]; then M="kdialog --msgbox"; else M="echo";fi;if [ "x$U" != "x0" ]; then $M "ERROR: You have to correct example according to Your system configuration !"; fi;'|bash -f -s);
|
||||
INIT_CONTROL=Exec(echo 'if [ -f $HOME/.anyRemote/amixer.control ]; then true; else echo "Master@0" > $HOME/.anyRemote/amixer.control; fi;'|bash -f -s)
|
||||
SET_VIEW =Set(menu,add,Controls);ExecAndSet(title,cat $HOME/.anyRemote/amixer.control|sed "s/@/,/");
|
||||
|
||||
Cancel=Exit
|
||||
|
||||
Controls=ExecAndSet(list,replace,Mixer Controls,amixer scontrols|sed 's/Simple mixer control //;s/,/@/;s/$/,/');Set(menu,replace,Choose);
|
||||
Choose($$)=Exec(echo $(Param) > $HOME/.anyRemote/amixer.control);Set(list,close);Macro(SET_VIEW);
|
||||
Back=Set(text,close);Macro(SET_VIEW);
|
||||
Back($$)=Set(list,close);Macro(SET_VIEW);
|
||||
|
||||
1=Exec(amixer $(mixer_card) sset `cat $HOME/.anyRemote/amixer.control|sed "s/@/,/"` 5%- -q)
|
||||
2=Exec(amixer $(mixer_card) sset `cat $HOME/.anyRemote/amixer.control|sed "s/@/,/"` toggle -q)
|
||||
3=Exec(amixer $(mixer_card) sset `cat $HOME/.anyRemote/amixer.control|sed "s/@/,/"` 5%+ -q)
|
||||
|
||||
5=Macro(Controls);
|
||||
|
||||
* *=Set(text,replace,Help,1 - Vol-\n2 - Mute/Unmute\n3 - Vol+\n5 - Choose mixer control)
|
||||
|
||||
[End]
|
||||
|
||||
|
@ -1,8 +1,6 @@
|
||||
diff --git a/configure b/configure
|
||||
index 2a4e2a4..396d5a2 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3940,7 +3940,7 @@ _ACEOF
|
||||
@@ -4135,7 +4135,7 @@ $as_echo "#define HAVE_SYS_WAIT_H 1" >>c
|
||||
fi
|
||||
|
||||
|
||||
@ -10,4 +8,4 @@ index 2a4e2a4..396d5a2 100755
|
||||
+CFLAGS="$CFLAGS -Wall -D_REENTRANT -O2 -g"
|
||||
|
||||
# On IRIX 5.3, sys/types and inttypes.h are conflicting.
|
||||
|
||||
for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
|
||||
|
Loading…
x
Reference in New Issue
Block a user