[packages] sslh: update to v1.7a (#6631)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19506 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a4aadc2469
commit
d2f668216a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sslh
|
||||
PKG_VERSION:=1.6i
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.7a
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://rutschle.net/tech/
|
||||
PKG_MD5SUM:=b2e0a207df885d7be57713449edae815
|
||||
PKG_MD5SUM:=ee124654412198a5e11fe28acf10634d
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
|
||||
NAME=sslh
|
||||
PROG=/usr/sbin/sslh
|
||||
@ -60,7 +60,7 @@ stop()
|
||||
# killing all server processes
|
||||
for pidfile in `ls /var/run/${NAME}.*.pid`
|
||||
do
|
||||
start-stop-daemon -K -s KILL -p "${pidfile}" -n "${NAME}" >/dev/null
|
||||
start-stop-daemon -q -K -s KILL -p "${pidfile}" -n "${NAME}"
|
||||
[ $? -ne 0 ] && rc=1
|
||||
rm -f "${pidfile}"
|
||||
done
|
||||
@ -103,12 +103,10 @@ killclients()
|
||||
server=`echo ${connection} | cut -d ' ' -f 7 | cut -d '/' -f 1`
|
||||
|
||||
# check if client connection
|
||||
ps | grep -e "^[ ]*${server} " | grep -e "${PROG}" >/dev/null
|
||||
if [ $? -eq 0 ]
|
||||
then
|
||||
grep -F -q -e "${PROG}" "/proc/${server}/cmdline" && {
|
||||
append ignore "${server}"
|
||||
break
|
||||
fi
|
||||
}
|
||||
done
|
||||
|
||||
# get all server pids that should be ignored
|
||||
@ -121,9 +119,10 @@ killclients()
|
||||
local skip
|
||||
for pid in `pidof "${NAME}"`
|
||||
do
|
||||
# check if correct program
|
||||
ps | grep -e "^[ ]*${pid} " | grep -e "${PROG}" >/dev/null
|
||||
[ $? -ne 0 ] && continue
|
||||
# check if correct program, otherwise process next pid
|
||||
grep -F -q -e "${PROG}" "/proc/${pid}/cmdline" || {
|
||||
continue
|
||||
}
|
||||
|
||||
# check if pid should be ignored (servers, ourself)
|
||||
skip=0
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- a/sslh.c
|
||||
+++ b/sslh.c
|
||||
@@ -469,6 +469,7 @@
|
||||
|
||||
if (!fork())
|
||||
{
|
||||
+ close(listen_socket);
|
||||
start_shoveler(in_socket);
|
||||
exit(0);
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user